Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 16268 - GCC Crashes and reports it is unable to build executable files. Config log reports segmentation fault
Summary: GCC Crashes and reports it is unable to build executable files. Config log re...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Please assign to toolchain
Depends on:
Reported: 2003-02-24 05:35 UTC by Florian Beisel
Modified: 2003-10-01 21:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

My config log from mysql i tried to build (config.log,6.21 KB, text/plain)
2003-02-24 05:38 UTC, Florian Beisel
My config log from mysql i tried to build (config.log,6.21 KB, application/octet-stream)
2003-02-24 05:39 UTC, Florian Beisel

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Beisel 2003-02-24 05:35:51 UTC
First I tried to emerge apache. Because it died I tried mysql to minimize the 
risk of a broken package. It crashed too. I looked up the config.log and found 
something that could be a bug / interesting for you.

Reproducible: Always
Steps to Reproduce:
1. emerge mysql 

Actual Results:  
emerge stopped telling me my gcc would be unable to build executables

Expected Results:  
it should have build my programs 

Portage 2.0.46-r12 (default-x86-1.4, gcc-3.2.1, glibc-2.3.1-r2)
System uname: 2.4.19-gentoo-r10 i686 Intel(R) Celeron(TM) CPU                
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/confi
g /usr/kde/3/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm arts avi crypt cups encode gif imlib java jpeg libg++ 
libwww mikmod mmx motif mpeg ncurses nls oggvorbis opengl pdflib png qtmt 
quicktime sdl spell svga truetype xml2 xmms xv zlib gdbm berkdb slang readline 
tcpd pam ssl perl python -X -kde -qt -gtk -gnome -alsa -xfree -gpm"
CFLAGS="-march=pentium3 -O3 -pipe"
CXXFLAGS="-march=pentium3 -O3 -pipe"
FEATURES="sandbox ccache"

see config.log attached
Comment 1 Florian Beisel 2003-02-24 05:38:57 UTC
Created attachment 8665 [details]
My config log from mysql i tried to build
Comment 2 Florian Beisel 2003-02-24 05:39:21 UTC
Created attachment 8666 [details]
My config log from mysql i tried to build
Comment 3 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-24 10:24:55 UTC
Please update to gcc-3.2.2 and binutils-, and try again ?
Comment 4 Florian Beisel 2003-02-24 11:41:32 UTC
just updated. 

no changes. 
emerge vim (i tried something other then mysql and apache) writes following: 
p15112415 root # emerge vim
Calculating dependencies ...done!
>>> emerge (1 of 4) sys-libs/libtermcap-compat-1.2.3 to /
>>> md5 ;-) termcap-compat_1.2.3.tar.gz
>>> Unpacking source...
>>> Unpacking termcap-compat_1.2.3.tar.gz
patching file tparam.c
>>> Source unpacked.
if [ ! -d pic ]; then mkdir pic; fi
gcc -march=pentium3 -O3 -pipe -I. -M termcap.c tparam.c version.c | \
        sed -e 's,^[    ]*\(.*\.o\)[    ]*:,\1 pic/\1:,' > .depend
gcc -march=pentium3 -O3 -pipe -I. -c termcap.c
gcc: Internal error: Segmentation fault (program as)
Please submit a full bug report.
See <URL:> for instructions.
make: *** [termcap.o] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: sys-libs/libtermcap-compat-1.2.3 failed.
!!! Function src_compile, Line 25, Exitcode 2
!!! (no error message)

p15112415 root # cc1: Broken pipe: error writing to -
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2003-02-24 14:00:05 UTC
Dunno .. maybe run memtest86 for a few hours and enable all tests and addresses?
Comment 6 Burcin Erocal 2003-02-26 21:24:07 UTC
I see a similar problem on my 1.0 system using gcc-2.95.3.

I did an emerge -u world this morning, and here's the log output:

1046286881: Started emerge on: Feb 26, 2003 21:14:41
1046286881:  *** emerge --update world
1046286885:  >>> emerge (1 of 8) sys-devel/binutils- to /
1046287357:  >>> AUTOCLEAN: sys-devel/binutils
1046287364:  >>> unmerge success: sys-devel/binutils-
1046287367:  ::: completed emerge (1 of 8) sys-devel/binutils- to /
1046287367:  >>> emerge (2 of 8) net-misc/rsync-2.5.6-r1 to /

rsync did not emerge properly, saying the compiler couldn't generate executables.

I didn't have time to deal with that at the time, so just forgot about it. Until just now when I saw the same message..

checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
/usr/sbin/ die: command not found

!!! ERROR: net-www/dillo-0.6.6-r3 failed.
!!! Function src_compile, Line -176, Exitcode 127
!!! (no error message)

The config log contains:

configure:1569: gcc   -I/usr/local/include  -L/usr/local/lib conftest.c  >&5
gcc: installation problem, cannot exec `as': No such file or directory
configure:1572: $? = 1

There is no /usr/bin/as on my system, it must have gotten lost when emerge unmerged the binutils- it just merged.

I can't re-emerge anything at the moment, since I can't compile anything. I'll try compiling binutils on another machine, and copying the necessary files over.

Any hints on recovery would also be appreciated..

Component should be changed to Portage, since this is obviously not a GCC 3 problem. The culprit is portage, removing the package it just installed..
Comment 7 Ricardo Cordeiro 2003-02-27 04:51:27 UTC
Brucin, use emerge -B
Comment 8 Burcin Erocal 2003-02-27 06:07:12 UTC
I was able to get my system back by emerging binutils from a tbz2 package.

I also used carpaski's fix-db script on the database. Trying to update binutils after that point did not cause any problems, so I guess it was just a database corruption.

To the original poster: How did you update binutils and gcc? from packages? Did you do anything to binutils before the problem occured? Can you compile anything with gcc?
Comment 9 Joshua Kinard gentoo-dev 2003-10-01 21:24:38 UTC
Resolving as CANTFIX as no further information is provided on whether the
original issue was ever resolved.  If the issue re-appears in newer versions
of gcc, feel free to re-open this bug.