Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 162574 - net-dialup/ltmodem causes kernel panic when dialing
Summary: net-dialup/ltmodem causes kernel panic when dialing
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Dialup Developers
Depends on:
Reported: 2007-01-17 19:56 UTC by Serhiy Kalchuk
Modified: 2007-03-17 13:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Kernel panic full output (kernel_panic.JPG,67.31 KB, image/jpeg)
2007-01-23 21:23 UTC, Serhiy Kalchuk

Note You need to log in before you can comment on or make changes to this bug.
Description Serhiy Kalchuk 2007-01-17 19:56:42 UTC
When I dial to my ISP (with wvdial) everything goes fine until the moment when connection should be established. Then I get a message:

BUG: unable to handle kernel paging request at virtual address ffffffc5
<... some very hard to understand debug and backtrace info ...>
<0> Kernel panic - not syncing: Fatal exception in interrupt.

The problem appeared when I switched to gentoo-sources-2.6.18-r6 and added several new options in config in comparison to my previous 2.6.17-r8 one like HPET timer support, Local APIC support for uniprocessors and Use register arguments. Disabling them resolves the problem. However, I didn't figure out yet which feature listed above exactly causes it.

Reproducible: Always

Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-01-17 20:54:50 UTC
<... some very hard to understand debug and backtrace info ...>

Might be hard to understand, but you need to post it; we can't guess... Also try with 2.6.19-r4.
Comment 2 Serhiy Kalchuk 2007-01-23 21:19:00 UTC
I tried it with 2.6.19-r4 using the config with HPET,Local APIC and register arguments options but it failed too. See the attached picture of the full output.

There also appeared a new line (the very last one), which repeats constantly.
Comment 3 Serhiy Kalchuk 2007-01-23 21:23:08 UTC
Created attachment 107950 [details]
Kernel panic full output
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-23 21:28:35 UTC
Noone will notice again if you don't reopen...
Comment 5 Serhiy Kalchuk 2007-01-24 08:12:53 UTC
Oops.. =) Thanks! Actually, that's my first bug report, so I don't really know what to do when. 
Comment 6 Alin Năstac (RETIRED) gentoo-dev 2007-03-17 08:27:26 UTC
Is your modem actually supported by ltmodem? Did you tried with slmodem or hsfmodem? You should use scanModem utility found at to see what package support your specific modem (if any).

I'm sorry, but the kernel modules installed these packages are not open source and therefore we can't do much more than redirect you to one of these alternatives.

Closed as CANTFIX.
Comment 7 Serhiy Kalchuk 2007-03-17 13:54:56 UTC
(In reply to comment #6)
The modem works fine unless my kernel is compiled with 'use registered arguments' option (REGPARM).