Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 162076 - nvidia-drivers-1.0.9746 fail to load xf86SigHandler+0x85
Summary: nvidia-drivers-1.0.9746 fail to load xf86SigHandler+0x85
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2007-01-14 17:49 UTC by Chris Holcombe
Modified: 2007-07-12 17:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

X server log (log.txt,1.53 KB, text/plain)
2007-01-14 17:50 UTC, Chris Holcombe
emerge --info (emergeInfo.txt,3.26 KB, text/plain)
2007-01-14 17:51 UTC, Chris Holcombe
Full X server log (Xorg.1.log,23.04 KB, text/plain)
2007-01-14 17:53 UTC, Chris Holcombe

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Holcombe 2007-01-14 17:49:50 UTC
Hello everyone,
After the latest emerge and an update to the nvidia drivers I'm getting an xf86SigHandler+0x85 crash on the x server.  I tried backing off to the older nvidia drivers all the way back to the 8776 which previous worked and nothing worked.  When I do a mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup and the server defaults to the nv driver it works just fine.  This makes me suspect the nvidia driver could be at fault.  I'm using the kernel.  I tried searching through the bug lists but I couldn't find anything to help.
Comment 1 Chris Holcombe 2007-01-14 17:50:37 UTC
Created attachment 106964 [details]
X server log
Comment 2 Chris Holcombe 2007-01-14 17:51:55 UTC
Created attachment 106965 [details]
emerge --info
Comment 3 Chris Holcombe 2007-01-14 17:53:05 UTC
Created attachment 106967 [details]
Full X server log
Comment 4 Evgeniy Dushistov 2007-06-30 11:19:35 UTC
The same happened on my machine,
if Xorg works more then hour, Xorg is crashed with:
0: X(xf86SigHandler+0x85) [0x80bf3c5]

Fatal server error:
Caught signal 11.  Server aborting
Comment 5 Evgeniy Dushistov 2007-06-30 11:21:47 UTC
Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r3, 2.6.20-gentoo-r8 i686)
System uname: 2.6.20-gentoo-r8 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System release 1.12.9
Timestamp of tree: Sat, 30 Jun 2007 05:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.3.5-r3, 2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.23b
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -msse -mmmx -m3dnow -pipe"
CONFIG_PROTECT="${NXDIR}/etc ${NXDIR}/home /etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php4/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -msse -mmmx -m3dnow -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
LDFLAGS="-Wl,-O1 -Wl,--sort-common"
LINGUAS="en ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/portage/local/layman/nx /usr/portage/local/layman/toolchain /usr/portage/local/layman/vmware /home/evgeniy/portage"
USE="3dnow X acl acpi alsa apache2 arts bash-completion berkdb bitmap-fonts cairo cdr cjk cli cracklib crypt cups dbus dlloader doc dri dvd dvdr dvdread eds emacs emboss encode esd evo fam fbcon firefox font-server foomaticdb fortran gdbm gif gimpprint gpm gstreamer gtk hal iconv isdnlog jpeg kde kdeenablefinal kdexdeltas kerberos ldap libg++ logrotate mad maildir midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pch pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spel spell spl sse ssl svg tcpd tiff truetype truetype-fonts type1 type1-fonts udev unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev vga vesa nv"
Comment 6 Doug Goldstein (RETIRED) gentoo-dev 2007-07-12 17:06:36 UTC
signal 11 errors in drivers are very much a very specific system hardware
issue. This issue is not something we at Gentoo are going to be able to
magically fix. The issue is that the nvidia driver, which only ships in a
binary format, is failing during handling of signals, which are directly tied to hardware interrupts This could be specific to the make and model of video card you have (i.e. they differed from the nVidia reference design and as such the memory position is available at a different address and the drivers don't take that into account), which is why in the Windows world you are always advises to use the drivers shipped by your video card manufacture. However, in Linux we can only use what nVidia ships since no manufacture ships their own driver. This being said, your only real recourse is to contact nVidia with specific make/model information and attempt to see if they can reproduce it. Other places to search for information are the nvidia forums for other users that have issues with the same make/model video card.

Now I know I'm blaming the video card a lot here, however a signal 11 isn't
necessary a video card. It could be your processor, your motherboard, your RAM,
your sound card all doing something wrong. A voltage could be off here or
there. It's very specific and very localized to your system.

While several people have reported this issue, it is possible that it's
specific issues in everyone's case is a hardware issue, it's also possible that
it's a software issue inside nVidia's driver itself.

All in all, signal 11 issues are nearly impossible for developers to debug
since they're typically hardware issues. The only fixes are to work around the
hardware issue in software. However to do that full debugging backtraces need
to be provided. Since the nVidia driver only ships in a binary format, you're
really out of luck to have anyone outside of nVidia help debug the issue and
provide a software work around.

For more information about signal 11 use Google and just type that in. Links
such as these will explain it further.