Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 161057 - sys-apps/hal can't find pci.ids on latest pciutils
Summary: sys-apps/hal can't find pci.ids on latest pciutils
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Project Gentopia
URL:
Whiteboard:
Keywords:
: 161604 162083 162452 163212 (view as bug list)
Depends on:
Blocks: 166812
  Show dependency tree
 
Reported: 2007-01-09 03:27 UTC by Hanno Böck
Modified: 2007-02-19 04:18 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2007-01-09 03:27:21 UTC
econf fails with:

checking for /var/lib/misc/pci.ids... no
configure: error: cannot find pci.ids. Use --with-hwdata to specify location

Reason: New pciutils have pci.ids.gz (earlier ones weren't gzipped) and thus hal doesn't find it.
Comment 1 Adam Bowers 2007-01-10 12:18:43 UTC
Same problem here.

adam@hotbbq ~ $ emerge --info
Portage 2.1.2_rc4-r7 (default-linux/x86/no-nptl, gcc-4.1.1, glibc-2.5-r0, 2.6.19-gentoo-r3 i686)
=================================================================
System uname: 2.6.19-gentoo-r3 i686 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.8
Last Sync: Tue, 09 Jan 2007 00:30:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.19
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://open-systems.ufl.edu/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://192.168.15.101/gentoo-portage"
USE="3dnow X a52 aac acpi aim alsa apm avahi bash-completion bzip2 caps cddb cdr cjk cracklib crypt cups dbus dts dvd dvdr dvdread encode exif fbcon ffmpeg firefox foomaticdb ftp gd gdbm gif glut gnome gnutls gpm gstreamer gtk gtk2 gtkhtml hal imlib ipod java javascript jbig jpeg jpeg2k lcms libcaca libwww mad mmap mmx mng mono mp3 mpeg mpi msn ncurses nls nntp nsplugin offensive openal opengl pam pcre pdf perl php png posix profile python quicktime rdesktop readline samba sdl session sockets spell spl sse sse2 ssl startup-notification svg svga sysvipc tcpd threads tiff truetype unicode usb win32codecs x86 xml xorg xpm xprint xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 2 Adam Bowers 2007-01-10 12:50:24 UTC
By the way, the file is located at /usr/share/misc/pci.ids.gz on my system.  /var/lib/misc is empty.
Comment 3 Krister Bäckman 2007-01-11 19:09:50 UTC
I did a

zcat /usr/share/misc/pci.ids.gz > /var/lib/misc/pci.ids

and the ebuild worked, weird behaviour.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-11 19:51:25 UTC
*** Bug 161604 has been marked as a duplicate of this bug. ***
Comment 5 Örjan Södergren 2007-01-11 20:54:15 UTC
added 

--with-hwdata=/usr/share/misc/pci.ids.gz \ 

at line 138 in a copy of the ebuild that i placed in portage overlay dir. Digested it along with a copy of all its patches. Then it worked.

Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-01-14 21:03:07 UTC
*** Bug 162083 has been marked as a duplicate of this bug. ***
Comment 7 Ash Varma 2007-01-15 18:19:12 UTC
zcat /usr/share/misc/pci.ids.gz > /var/lib/misc/pci.ids worked for me also ..
Comment 8 Martin Wegner 2007-01-16 15:02:48 UTC
Above patch works for me here, too. Would be glad if it could be added to portage soon, thanks. 
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-01-16 22:46:16 UTC
*** Bug 162452 has been marked as a duplicate of this bug. ***
Comment 10 Aniruddha Shankar 2007-01-17 19:22:57 UTC
checking for /usr/share/hwdata/pci.ids... no
checking for /usr/share/misc/pci.ids... no
checking for /usr/share/pci.ids... no
checking for /var/lib/misc/pci.ids... no
Comment 11 Doug Goldstein gentoo-dev 2007-01-18 05:15:06 UTC
hal-0.5.7.1-r3 will be in the tree shortly and will fix it.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 10:13:57 UTC
*** Bug 163212 has been marked as a duplicate of this bug. ***
Comment 13 Bugs Bunny 2007-02-14 13:33:13 UTC
(In reply to comment #11)
> hal-0.5.7.1-r3 will be in the tree shortly and will fix it.
> 

Has not fixed anything, instead has caused regressions.
Comment 14 Xake 2007-02-14 15:16:50 UTC
For me tha latest revision of hal-0.5.7.1-r5 configures fine and compiles fine with latest pciutils (i.e. 2.2.4-r1)
I think it has something to do with having --with-hwdata pointing at the directory where pci.ids{,.gz} resides for pciutils-2.2.[2,3} on my system (/usr/share/misc) instead of having it pointing directly at the pci.ids{,.gz}.


Oh, and the Changelog-note "HAL does not read gzipped pci.ids data." is totally confusing. Do you mean at compiletime or runtime?
Comment 15 Harm Geerts 2007-02-15 20:55:01 UTC
Works for me as well, hal configures and installs fine.
There was no need to force pciutils to have USE=-zlib

[ebuild   R   ] sys-apps/pciutils-2.2.4-r2  USE="zlib" 0 kB
[ebuild   R   ] sys-apps/hal-0.5.7.1-r5  USE="acpi crypt -debug -dmi -doc -pcmcia (-selinux)" 0 kB

                    HAL 0.5.7.1
                  ==============

        prefix:                   /usr
        libdir:                   /usr/lib64
        libexecdir:               /usr/libexec
        bindir:                   /usr/bin
        sbindir:                  /usr/sbin
        datadir:                  /usr/share
        sysconfdir:               /etc
        localstatedir:            /var/lib
        docdir:                   /usr/share/doc/hal-0.5.7.1-r5
        dbus-1 system.d dir:      /etc/dbus-1/system.d
        pci.ids, usb.ids dir:     /usr/share/misc

        compiler:                 x86_64-pc-linux-gnu-gcc
        cflags:                   -march=athlon64 -O2 -pipe -msse3 -Wall -Wchar-subscripts -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare
        cppflags:
        Doxygen:                  no
        DocBook:                  no
        User for HAL:             haldaemon
        Group for HAL:            haldaemon
        hald pidfile:             /var/run/hald.pid
        hald backend:             linux2
        acpi proc support:        no
        acpi daemon support:      yes

        use libusb (for usb-csr): yes

        Maintainer mode:          no
        Building verbose mode:    no
        Building Doxygen docs:    no
        Building docs:            no
Comment 16 Doug Goldstein gentoo-dev 2007-02-15 23:31:48 UTC
First off, you have an old stale version laying around of pci.ids. Secondly, HAL reads the file at run time. Since it can't ungzip the file, it fails to read it. So no devices are detected properly from pci.ids.
Comment 17 Xake 2007-02-16 07:21:44 UTC
(In reply to comment #16)
> First off, you have an old stale version laying around of pci.ids. Secondly,
> HAL reads the file at run time. Since it can't ungzip the file, it fails to
> read it. So no devices are detected properly from pci.ids.
> 

Well HAL compiles fine without any pci.ids{,.gz} at all. Seems more like --with-hwdata is where to find a not gzipped pci.ids at runtime as I can confirm that HAL has "unknown" vendors and alike without a pci.ids.
Comment 18 Tim Boundy 2007-02-18 03:03:22 UTC
(In reply to comment #15)
> Works for me as well, hal configures and installs fine.
> There was no need to force pciutils to have USE=-zlib

I am curious of how this is possible, as hal-0.5.7.1-r5 checks to see if pciutils was built with zlib support and if it was, it forces the build process to die.
Comment 19 Doug Goldstein gentoo-dev 2007-02-19 04:18:57 UTC
(In reply to comment #18)
> (In reply to comment #15)
> > Works for me as well, hal configures and installs fine.
> > There was no need to force pciutils to have USE=-zlib
> 
> I am curious of how this is possible, as hal-0.5.7.1-r5 checks to see if
> pciutils was built with zlib support and if it was, it forces the build process
> to die.
> 

He's just plain wrong.