Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 159872 - random packages fail with Error:unknown pseudo-op: '.weakref'
Summary: random packages fail with Error:unknown pseudo-op: '.weakref'
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
: 144563 147303 149710 172881 182766 186592 186594 186595 187549 (view as bug list)
Depends on:
Reported: 2007-01-03 09:08 UTC by Walter-Martin
Modified: 2007-08-02 21:25 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

test.verbose.log (test.verbose.log,2.60 KB, text/plain)
2007-01-04 11:34 UTC, Walter-Martin
test.S (test.S,419 bytes, text/plain)
2007-01-04 11:35 UTC, Walter-Martin
test.ii (test.ii,81 bytes, text/plain)
2007-01-04 11:36 UTC, Walter-Martin
test.ii.dd (test.ii.dd,3.90 KB, text/plain)
2007-01-04 11:36 UTC, Walter-Martin
test.log (test.log,849 bytes, text/plain)
2007-01-04 14:02 UTC, Walter-Martin
test.verbose.log (test.verbose.log,2.82 KB, text/plain)
2007-01-04 14:02 UTC, Walter-Martin
test.ii (test.ii,707.92 KB, text/plain)
2007-01-04 14:03 UTC, Walter-Martin
test.ii.dd (test.ii.dd,784.76 KB, text/plain)
2007-01-04 14:03 UTC, Walter-Martin
test.S (test.S,4.39 KB, text/plain)
2007-01-04 14:04 UTC, Walter-Martin

Note You need to log in before you can comment on or make changes to this bug.
Description Walter-Martin 2007-01-03 09:08:20 UTC
Gentoo Base System version 1.12.6
Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Celeron(R) CPU 2.60GHz
Last Sync: Sun, 24 Dec 2006 13:50:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
CFLAGS="-O2 -march=pentium2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium2 -pipe -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dnow X aalib acpi alsa alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2 arts avi berkdb bitmap-fonts cairo cdparanoia cdr cli cracklib crypt cups dga dlloader dri dvb dvd dvdread elibc_glibc encode foomaticdb fortran gdbm gimpprint gpm gtk hal iconv icq input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog java jpeg jpg kde kernel_linux libg++ linguas_fr mmx mpeg mysql ncurses nls nptl nptlonly opengl oss pam pcre pda pdf perl ppds pppd python qt qt3 readline reflection session spl ssl tcpd truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_i810 video_cards_i830 video_cards_i915 xorg zlib"
Comment 1 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2007-01-03 09:28:52 UTC
"include this in your bug report" doesn't mean "put this in summary and nothing more"
what is your problem?
Comment 2 Walter-Martin 2007-01-03 09:36:32 UTC
{standard input}:4433: Error:unknown pseudo-op: '.weakref'
{standard input}:4434: Error:unknown pseudo-op: '.weakref'
{standard input}:4435: Error:unknown pseudo-op: '.weakref'
make: *** [cxx_db.lo]Error 1

!!! Error: sys-libs/db-4.2.52-p4-r2 failed.
call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  db-4.2.52_p4-r2.ebuild, line 103:   Called die

!!!!make failed
!!!! if you need support ...

!!! When you file a bug report, please include the following information:
GENTOO_VM=blackdown-jdk-1.4.2 CLASSPATH="" JAVA_HOME="opt/blackdown-jdk-"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""

I made an emerge -e system and i had this error.
Before I made emerge -uD gqview but I did not remember that the option "~X86" was in my make.conf (I am a beginner).
Comment 3 Walter-Martin 2007-01-03 09:41:27 UTC
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-01-03 09:58:38 UTC
Kindly post a couple more than those 3 lines without any context whatsoever. Thanks.
Comment 5 Walter-Martin 2007-01-03 23:15:37 UTC
I hope it's help.

localhost dwm # emerge sys-libs/db >> toto.txt
configure: WARNING: I have to compile Test.class from scratch
configure: WARNING: O_DIRECT interface ignored on linux-gnu-pc.
In file included from /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/include/g++-v4/backward/iostream.h:31,
                 from ./db_cxx.h:59,
                 from ../dist/../cxx/cxx_db.cpp:17:
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/include/g++-v4/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
{standard input}: Assembler messages:
{standard input}:4422: Error: unknown pseudo-op: `.weakref'
{standard input}:4423: Error: unknown pseudo-op: `.weakref'
{standard input}:4424: Error: unknown pseudo-op: `.weakref'
{standard input}:4425: Error: unknown pseudo-op: `.weakref'
{standard input}:4426: Error: unknown pseudo-op: `.weakref'
{standard input}:4427: Error: unknown pseudo-op: `.weakref'
{standard input}:4428: Error: unknown pseudo-op: `.weakref'
{standard input}:4429: Error: unknown pseudo-op: `.weakref'
{standard input}:4430: Error: unknown pseudo-op: `.weakref'
{standard input}:4431: Error: unknown pseudo-op: `.weakref'
{standard input}:4432: Error: unknown pseudo-op: `.weakref'
{standard input}:4433: Error: unknown pseudo-op: `.weakref'
{standard input}:4434: Error: unknown pseudo-op: `.weakref'
{standard input}:4435: Error: unknown pseudo-op: `.weakref'
make: *** [cxx_db.lo] Error 1

!!! ERROR: sys-libs/db-4.2.52_p4-r2 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  db-4.2.52_p4-r2.ebuild, line 103:   Called die

!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! When you file a bug report, please include the following information:
GENTOO_VM=blackdown-jdk-1.4.2  CLASSPATH="" JAVA_HOME="/opt/blackdown-jdk-"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info

java-config-1 --list -available-vms
The following JDKs are available for generation-1:
*)     Blackdown JDK [blackdown-jdk-]

java-config-2 -L
The following VMs are available for generation-2:
1)      Blackdown JDK [blackdown-jdk-1.4.2]
*)     Sun JDK [sun-jdk-1.5]

Comment 6 SpanKY gentoo-dev 2007-01-04 01:23:08 UTC
run these commands:
echo 'int main(){}' > test.cpp
g++ test.cpp >& test.log
g++ -v test.cpp >& test.verbose.log
g++ -S test.cpp -o test.S
g++ -E test.cpp -o test.ii
g++ -E -dD test.cpp -o test.ii.dd

and then post each of those files as attachments
Comment 7 Paul de Vrieze (RETIRED) gentoo-dev 2007-01-04 04:28:00 UTC
It seems indeed that something on the toolchain is broken.
Comment 8 Walter-Martin 2007-01-04 11:34:59 UTC
Created attachment 105404 [details]

test.log is empty
Comment 9 Walter-Martin 2007-01-04 11:35:34 UTC
Created attachment 105405 [details]
Comment 10 Walter-Martin 2007-01-04 11:36:00 UTC
Created attachment 105406 [details]
Comment 11 Walter-Martin 2007-01-04 11:36:32 UTC
Created attachment 105407 [details]

Thanks a lot!
Comment 12 SpanKY gentoo-dev 2007-01-04 13:03:33 UTC
you're saying that `g++ test.cpp` worked ?  if that's true, please redo those tests, but use this for your test.cpp:

#include <iostream>
void someoutput (void) { std::cout << 123; }
int main (void) { return 0; }
Comment 13 Walter-Martin 2007-01-04 14:02:19 UTC
Created attachment 105419 [details]

It seems it did not worked.
Comment 14 Walter-Martin 2007-01-04 14:02:39 UTC
Created attachment 105420 [details]
Comment 15 Walter-Martin 2007-01-04 14:03:11 UTC
Created attachment 105421 [details]
Comment 16 Walter-Martin 2007-01-04 14:03:38 UTC
Created attachment 105422 [details]
Comment 17 Walter-Martin 2007-01-04 14:04:47 UTC
Created attachment 105423 [details]
Comment 18 SpanKY gentoo-dev 2007-01-04 14:28:00 UTC
for some reason your gcc thinks your assembler supports .weakref when it obviously does not ... did you have newer versions of binutils installed at some point ?

if you built gcc-4.1.1 with binutils-2.17 but then downgraded your binutils to 2.16.1, you'd hit this
Comment 19 Walter-Martin 2007-01-04 23:07:34 UTC
localhost dwm # equery list binutils
[ Searching for package 'binutils' in all categories among: ]
 * installed packages
[I--] [ -] sys-devel/binutils-2.16.1-r3 (0)
[I--] [  ] sys-devel/binutils-config-1.9-r3 (0)

I don't know if i had a newer version installed before. Is there a command that gives all the versions that where built?

What can i do exactly?
Thanks a lot!!

Comment 20 SpanKY gentoo-dev 2007-01-04 23:10:35 UTC
run `qlop -l binutils` ... if you dont have `qlop`, run `emerge portage-utils`
Comment 21 SpanKY gentoo-dev 2007-02-17 01:44:13 UTC
solution: dont downgrade your binutils
Comment 22 SpanKY gentoo-dev 2007-02-17 01:45:05 UTC
*** Bug 147303 has been marked as a duplicate of this bug. ***
Comment 23 SpanKY gentoo-dev 2007-02-17 01:45:23 UTC
*** Bug 149710 has been marked as a duplicate of this bug. ***
Comment 24 Allen Parker 2007-02-17 01:55:05 UTC
*stabs vapier* don't add me to bugs that don't concern me please
Comment 25 SpanKY gentoo-dev 2007-02-17 02:02:27 UTC
if you actually read the bug you'd see that this explained the duped bug report *you filed*
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-03-31 17:50:22 UTC
*** Bug 172881 has been marked as a duplicate of this bug. ***
Comment 27 Steve Arnold archtester gentoo-dev 2007-05-19 23:23:53 UTC
*** Bug 144563 has been marked as a duplicate of this bug. ***
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2007-06-21 15:38:50 UTC
*** Bug 182766 has been marked as a duplicate of this bug. ***
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2007-07-25 14:19:50 UTC
*** Bug 186592 has been marked as a duplicate of this bug. ***
Comment 30 Jakub Moc (RETIRED) gentoo-dev 2007-07-25 14:20:33 UTC
*** Bug 186594 has been marked as a duplicate of this bug. ***
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2007-07-25 14:30:30 UTC
*** Bug 186595 has been marked as a duplicate of this bug. ***
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2007-08-02 21:19:31 UTC
*** Bug 187549 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2007-08-02 21:25:09 UTC
*** Bug 187549 has been marked as a duplicate of this bug. ***