Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 159534 - gnucash broken by gnome-base/gail
Summary: gnucash broken by gnome-base/gail
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-12-30 22:11 UTC by Mike Gant
Modified: 2007-01-01 02:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

gtkhtml error (config.log,48.70 KB, text/plain)
2006-12-31 08:23 UTC, Mike Gant

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Gant 2006-12-30 22:11:27 UTC
On 2006/12/16 I emerged the gnome-base/gail-1.9.3 package and it broke gnucash. I get this error when I run gnucash:

gnucash-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

So, I attempt to re-emerge gnucash. Fails. Unfortunately I don't have a listing of this error but it did fail during configuration when checking for the libofx library.

Nonetheless, onward I go. does not in fact exist on my system but does. I find that this file is installed by the gnome-base/gail ebuild. So I decide to emerge the prior version of gail to get the *.17 version of this library. So I do the following:

emerge --oneshot =gnome-base/gail-1.8.11

This does install

Now when I run gnucash I get this error:

gnucash-bin: error while loading shared libraries: cannot open shared object file: No such file or directory

Okay. Not what I expected. Now I re-emerge gnucash everything goes okay. But, I still get the same error.

Emerge latest version of gail. Again same error.

Now I emerge the older version of gail again, BUT this time I stop the emerge before it can unmerge the newer version. Now gnucash works. Finally.

So is this a problem with gnucash or gail? I don't know. Does gail need to be a Slot? I don't know that either.

If you need any additional info please let me know

Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-12-31 01:23:26 UTC
Run revdep-rebuild...
Comment 2 Mike Gant 2006-12-31 08:23:14 UTC
Created attachment 105050 [details]
gtkhtml error
Comment 3 Mike Gant 2006-12-31 08:25:56 UTC
Comment on attachment 105050 [details]
gtkhtml error

No it doesn't work. revdep-rebuild wants to emerge these packages
emerge --oneshot -pv =gnome-extra/gtkhtml-3.12.2 =app-office/gnucash-2.0.2 =app-office/kmymoney2-0.8.3

and the error for gtkhtml is in the attachment
Comment 4 Mike Gant 2006-12-31 09:04:19 UTC
I was going to add the error when emerge gnucash with gail-1.9.3 but now that works?? It's annoying when things begin working without knowing what changed. Or when nothing changed.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-01 02:47:12 UTC