Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 159139 - amule randomly crashes - wxGTK problem
Summary: amule randomly crashes - wxGTK problem
Status: RESOLVED DUPLICATE of bug 151528
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-26 07:18 UTC by George Prowse
Modified: 2006-12-26 07:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gdb backtrace (backtrace.txt,5.54 KB, text/plain)
2006-12-26 07:20 UTC, George Prowse
Details
gdb where (where.txt,5.49 KB, text/plain)
2006-12-26 07:20 UTC, George Prowse
Details
sigsev backtrace (backtrace2.txt,1.62 KB, text/plain)
2006-12-26 07:24 UTC, George Prowse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Prowse 2006-12-26 07:18:46 UTC
Using amule seems to create random crashes. some with different errors:

(gdb) run
Starting program: /usr/bin/amule 
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread -1225591120 (LWP 2712)]
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
[New Thread -1239712864 (LWP 2716)]
Loading temp files from /home/george/.aMule/Temp.
Loading PartFile 1 of 1
All PartFiles Loaded.
ListenSocket: Ok.

External connections disabled in config file
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Empty dir /home/george/.aMule/Incoming/ shared
[New Thread -1248105568 (LWP 2717)]
[Thread -1248105568 (zombie) exited]
[New Thread -1256498272 (LWP 2719)]
Search parsing resultfor "crash": 0
Search expression: crash 
Expression count: 1
Parameters: 1

(amule:2712): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

Gtk-ERROR **: file gtkcontainer.c: line 2447 (gtk_container_propagate_expose): assertion failed: (child->parent == GTK_WIDGET (container))
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread -1225591120 (LWP 2712)]
IA__g_logv (log_domain=<value optimized out>, log_level=G_LOG_LEVEL_ERROR, 
    format=0xb72b1860 "file %s: line %d (%s): assertion failed: (%s)", 
    args1=0xbfbe6ffc "&#65533;\200n&#65533;\217\t") at gmessages.c:503
503     gmessages.c: No such file or directory.
        in gmessages.c
Current language:  auto; currently c

I will try to recreate the SIGSEV crashes


emerge info:

Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r4 i686)
=================================================================
System uname: 2.6.18-gentoo-r4 i686 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System version 1.12.6
Last Sync: Tue, 26 Dec 2006 13:00:03 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks fixpackages metadata-transfer nostrip parallel-fetch sandbox sfperms splitdebug strict"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
LINGUAS="en_GB en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol asf berkdb bitmap-fonts cdr cli cracklib crypt cups debug dlloader dri dvd dvdr elibc_glibc flac fortran gdb gdbm gnome gpm gtk iconv imagemagick input_devices_keyboard input_devices_mouse ipod ipv6 isdnlog jpeg kernel_linux libg++ linguas_en linguas_en_GB mad mp3 ncurses nls nptl nptlonly nvidia pam pcre perl png ppds pppd python readline reflection session spl sse2 ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU v4l video_cards_nvidia vorbis win32codecs wma xine xorg xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 George Prowse 2006-12-26 07:20:01 UTC
Created attachment 104751 [details]
gdb backtrace

Adding backtrace attachment
Comment 2 George Prowse 2006-12-26 07:20:39 UTC
Created attachment 104752 [details]
gdb where
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-12-26 07:23:06 UTC

*** This bug has been marked as a duplicate of 151528 ***
Comment 4 George Prowse 2006-12-26 07:24:14 UTC
Created attachment 104753 [details]
sigsev backtrace