Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 158972 - net-nds/openldap stabilization
Summary: net-nds/openldap stabilization
Status: RESOLVED DUPLICATE of bug 159508
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 137264
  Show dependency tree
 
Reported: 2006-12-23 13:18 UTC by Markus Ullmann (RETIRED)
Modified: 2007-02-11 10:24 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Ullmann (RETIRED) gentoo-dev 2006-12-23 13:18:30 UTC
versions:

2.1.30-r9
2.2.28-r6
2.3.30-r1

Ebuilds are cleaned up, include tweaks for syncprov and preserve_libs issues and compiletime fixes for recent autotools
Comment 1 Markus Meier gentoo-dev 2006-12-26 03:52:20 UTC
net-nds/openldap-2.1.30-r9  USE="berkdb crypt gdbm ipv6 perl readline samba ssl tcpd -debug -odbc -sasl (-selinux) -slp"
1. fails:
/usr/portage/net-nds/openldap/openldap-2.1.30-r9.ebuild: line 104: eaclocal: command not found
Adding the autotools eclass solves this problem.
Please note:
QA Notice: pre-stripped files found:
/var/tmp/portage/openldap-2.1.30-r9/image/usr/lib/openldap/slapd
/var/tmp/portage/openldap-2.1.30-r9/image/usr/lib/openldap/slurpd
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapsearch
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapmodify
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapdelete
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapmodrdn
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldappasswd
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapwhoami
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapcompare
/var/tmp/portage/openldap-2.1.30-r9/image/usr/bin/ldapadd
/var/tmp/portage/openldap-2.1.30-r9/image/usr/sbin/slapadd
/var/tmp/portage/openldap-2.1.30-r9/image/usr/sbin/slapcat
/var/tmp/portage/openldap-2.1.30-r9/image/usr/sbin/slapindex
/var/tmp/portage/openldap-2.1.30-r9/image/usr/sbin/slappasswd
2. passes test suite
3. passes collision test
4. revdep-rebuild successfully rebuilt the depending packages

net-nds/openldap-2.2.28-r6  USE="berkdb crypt gdbm ipv6 perl readline samba ssl tcpd -debug -kerberos -minimal -odbc -sasl (-selinux) -slp"
1. emerges on x86, please note:
QA Notice: pre-stripped files found:
/var/tmp/portage/openldap-2.2.28-r6/image/usr/lib/openldap/slapd
/var/tmp/portage/openldap-2.2.28-r6/image/usr/lib/openldap/slurpd
/var/tmp/portage/openldap-2.2.28-r6/image/usr/lib/libldap.so.2.0.130
/var/tmp/portage/openldap-2.2.28-r6/image/usr/lib/libldap_r.so.2.0.130
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapsearch
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapmodify
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapdelete
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapmodrdn
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldappasswd
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapwhoami
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapcompare
/var/tmp/portage/openldap-2.2.28-r6/image/usr/bin/ldapadd
2. passes test suite
3. passes collision test
4. revdep-rebuild successfully rebuilt the depending packages

net-nds/openldap-2.3.30-r1  USE="berkdb crypt gdbm ipv6 perl readline samba ssl tcpd -debug -kerberos -minimal -odbc -overlays -sasl (-selinux) -slp -smbkrb5passwd"
1. emerges on x86, please note:
QA Notice: pre-stripped files found:
/var/tmp/portage/openldap-2.3.30-r1/image/usr/lib/libldap.so.2.0.130
/var/tmp/portage/openldap-2.3.30-r1/image/usr/lib/libldap_r.so.2.0.130
/var/tmp/portage/openldap-2.3.30-r1/image/usr/lib/libldap-2.2.so.7
/var/tmp/portage/openldap-2.3.30-r1/image/usr/lib/libldap_r-2.2.so.7
2. passes test suite
3. passes collision test
4. revdep-rebuild successfully rebuilt the depending packages

Gentoo Base System version 1.12.6
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18.4 i686)
=================================================================
System uname: 2.6.18.4 i686 Genuine Intel(R) CPU           T2300  @ 1.66GHz
Last Sync: Sun, 24 Dec 2006 10:00:03 +0000
ccache version 2.3 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.3.5-r3, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner"
FEATURES="autoconfig collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.switch.ch/mirror/gentoo/ http://gentoo.inode.at/"
LINGUAS="en de en_GB de_CH"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/pack
ages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acpi alsa alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa
_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via8
2xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop
 alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugin
s_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugin
s_shm alsa_pcm_plugins_softvol apache2 asf berkdb bitmap-fonts cairo cdr cdrom cli cracklib crypt cups dbus divx dlloader dri dts dvd dvdr dvdread eds elibc_glibc emboss encode fam ffmpeg firefox flac fort
ran gdbm gif gnome gpm gstreamer gtk hal iconv input_devices_keyboard input_devices_mouse ipv6 isdnlog java jpeg kde kdeenablefinal kernel_linux ldap libg++ linguas_de linguas_de_CH linguas_en linguas_en_G
B mad mikmod mmx mono mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre perl png ppds pppd python qt3 qt4 quicktime readline reflection rtsp ruby samba sdl session smp spell spl sse sse2 sse3 ssl
svg tcpd test tetex theora threads truetype truetype-fonts type1-fonts udev unicode userland_GNU vcd video_cards_fbdev video_cards_i810 video_cards_vesa vorbis win32codecs wxwindows x264 xine xml xorg xpri
nt xv xvid zlib"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 2 Doug Goldstein gentoo-dev 2006-12-27 07:45:58 UTC
I'm running 2.3.30-r1 at the office on amd64 & x86 machines.
Comment 3 Scott Van Der Wall 2007-01-07 02:43:41 UTC
on x86:

net-nds/openldap-2.1.30-r9 USE="berkdb crypt gdbm ipv6 perl readline ssl tcpd -debug -odbc -samba -sasl (-selinux) -slp (-kerberos%) (-minimal%) (-overlays%) (-smbkrb5passwd%)"

1: emerge fails with:

You should update your `aclocal.m4' by running aclocal.
Putting files in AC_CONFIG_AUX_DIR, `build'.
/usr/portage/net-nds/openldap/openldap-2.1.30-r9.ebuild: line 104: eaclocal: command not found

net-nds/openldap-2.2.28-r6 USE="berkdb crypt gdbm ipv6 perl readline ssl tcpd -debug -kerberos -minimal -odbc -samba -sasl (-selinux) -slp (-overlays%) (-smbkrb5passwd%)"

1: emerges ok
2: passes collision test
3: passes test suite
4: revdep-rebuild successfully recompiled all packages

net-nds/openldap-2.3.30-r1 USE="berkdb crypt gdbm ipv6 perl readline ssl tcpd -debug -kerberos -minimal -odbc -overlays% -samba -sasl (-selinux) -slp -smbkrb5passwd%"

1: emerges ok
2: passes collision test
3: passes test suite
4: revdep-rebuild successfully recompiled all packages

emerge --info:

Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r5 i686)
=================================================================
System uname: 2.6.18-gentoo-r5 i686 Genuine Intel(R) CPU           T2500  @ 2.00GHz
Gentoo Base System version 1.12.6
Last Sync: Sat, 06 Jan 2007 17:00:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa alsa_cards_hda-intel alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apm berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups dbus divx dlloader dri dvd dvdread elibc_glibc emacs encode ffmpeg firefox flac fortran gdbm gnome gpm gstreamer gtk gtk2 hal iconv input_devices_keyboard input_devices_mouse input_devices_synaptics ipv6 isdnlog ithreads java jpeg jpeg2k kernel_linux ldap libg++ mad mmx mmxext mono mp3 mp4 mpeg mplayer ncurses nls nptl nptlonly nsplugin nvidia ogg openal opengl oss pam pcre perl png ppds pppd python quicktime readline realmedia reflection session spl sse sse2 sse3 ssl tcpd test threads truetype-fonts type1-fonts udev unicode userland_GNU vcd video_cards_nvidia vidix win32codecs wmf wmp x264 xine xml xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS



Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2007-01-08 11:29:27 UTC

*** This bug has been marked as a duplicate of bug 159508 ***