Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 158376 - Request for ebuild for OpenEV
Summary: Request for ebuild for OpenEV
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://openev.sourceforge.net/index.php
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-17 07:45 UTC by Guy
Modified: 2007-12-27 15:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guy 2006-12-17 07:45:55 UTC
"OpenEV is a software library and application for viewing and analysing raster and vector geospatial data."

The issue is that there are no good tools in the Gentoo Package Library for viewing jpeg2000 images. There are especially no good tools for viewing very large jpeg 2000 images. Both Kwickview and Kolourpaint are capable of {very, very slowly} opening jp2 images, however large images are simply too much for them to handle. None of the other graphics applications I have on my Gentoo box have been capable of opening jp2 images. This includes Krita, GIMP etc.

The OpenEV application is an 'on the fly' image viewing capable of rendering very large jp2 images such as found at http://hiroc.lpl.arizona.edu/images/PSP/. Some of these images are over 1 gigabyte in size. The viewer works by only rendering the portion of the image currently visible on your screen.

I intalled OpenEV via FWTools from here: http://fwtools.maptools.org/. FWTools combines several graphics tools and all their dependencies into a single package. Installation consists of unzipping the tar ball, going to the new tool directory, performing ./install.sh and updating your PATH environmental variable.

FWTools is actively maintained. 

FWTools is hosted here: http://www.maptools.org/

It seems there are plenty of graphics tools hosted or linked to from here which could use a little Gentoo magic. :-D
Comment 1 Guy 2006-12-17 09:12:03 UTC
I also posted a "HOWTO view jpeg2000 images" post in Documentation Tips & Tricks -- http://forums.gentoo.org/viewtopic-p-3789278.html
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-12-27 15:29:07 UTC
No progress here for over one year; closing WONTFIX. 

Feel free to reopen with an ebuild.