Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 157821 - dev-libs/fcgi-2.4.0-r1 emerge fails
Summary: dev-libs/fcgi-2.4.0-r1 emerge fails
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
: 289143 (view as bug list)
Depends on:
Blocks: 302477
  Show dependency tree
 
Reported: 2006-12-11 05:07 UTC by Botykai Zsolt
Modified: 2010-02-01 11:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fcgi full emerge log (fcgi.log,28.91 KB, text/x-log)
2006-12-11 05:08 UTC, Botykai Zsolt
Details
log of fcgi install (fcgi.log,16.61 KB, text/plain)
2007-01-10 09:57 UTC, Botykai Zsolt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Botykai Zsolt 2006-12-11 05:07:35 UTC
Just wanted to play with rails & fcgi. But emergeing rails fails on fcgi, so I had tried to emerge fcgi only:

botykaizs ~ # emerge -uDv fcgi
Calculating dependencies... done!

>>> Emerging (1 of 1) dev-libs/fcgi-2.4.0-r1 to /
...
i686-pc-linux-gnu-gcc -march=prescott -O2 -pipe -Wall -o .libs/log-dump log-dump.o  ../libfcgi/.libs/libfcgi.so -lm -lnsl
creating log-dump
i686-pc-linux-gnu-g++ -march=prescott -O2 -pipe -o .libs/echo-cpp echo-cpp.o  ../libfcgi/.libs/libfcgi++.so -lfcgi /var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0/libfcgi/.libs/libfcgi.so -lnsl
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfcgi
collect2: ld returned 1 exit status
make[2]: *** [echo-cpp] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0/examples'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0'
make: *** [all] Error 2

!!! ERROR: dev-libs/fcgi-2.4.0-r1 failed.

# emerge --info
Portage 2.1.2_rc3-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r2 i686)
=================================================================
System uname: 2.6.18-gentoo-r2 i686 Intel(R) Pentium(R) D CPU 3.00GHz
Gentoo Base System version 1.12.6
Last Sync: Mon, 11 Dec 2006 01:47:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86 ~x86"
ARCH="x86"
AUTOCLEAN="yes"
CAMERAS="canon"
CBUILD="i686-pc-linux-gnu"
CCACHE_SIZE="512M"
CFLAGS="-march=prescott -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CVS_RSH="ssh"
CXXFLAGS="-march=prescott -O2 -pipe"
DISPLAYMANAGER="kdm"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="-v"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig ccache distlocks metadata-transfer noinfo parallel-fetch sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
FLTK_DOCDIR="/usr/share/doc/fltk-1.1.7/html"
GCC_SPECS=""
GDK_USE_XFT="1"
GENERATION="2"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
GUILE_LOAD_PATH="/usr/share/guile/1.6"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
HTTP_PROXY="http://proxy.lsy.bud.dlh.de:3128/"
ICAROOT="/opt/ICAClient"
INFOPATH="/usr/share/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/info:/usr/share/info/emacs-22.0.90:/usr/share/info/emacs-21:/usr/share/info"
INPUT_DEVICES="keyboard mouse"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDEDIRS="/usr/kde/3.5:/usr:/usr/local"
KDE_IS_PRELINKED="true"
KERNEL="linux"
LC_ALL="hu_HU.UTF-8"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBGL_DRIVERS_PATH="$LIBGL_DRIVERS_PATH::/usr/lib/xorg/modules/dri"
LINGUAS="hu en"
LOGNAME="root"
MAKEOPTS="-j5"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.17/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.1/man:/opt/ati/man:/opt/blackdown-jdk-1.4.2.03/man:/etc/java-config/system-vm/man/:/usr/qt/3/doc/man"
OPENGL_PROFILE="ati"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.1:/opt/ati/bin:/opt/ati/sbin:/opt/ICAClient:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn error log info"
PORTAGE_ELOG_MAILFROM="zsolt.botykai+portage@lhsystems.hu"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="zsolt.botykai@lhsystems.hu smtp.lsy.bud.dlh.de"
PORTAGE_ELOG_SYSTEM="save mail"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="3"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/local/portage"
PORT_LOGDIR="/var/log/portage"
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10:/lib/modules:/usr/lib/locale:/usr/lib/wine:/usr/lib/valgrind:*.la:*.png:*.py:*.pl:*.pm:*.sh:*.xml:*.xslt:*.a:*.js:/usr/lib/klibc"
PWD="/root"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.4/html"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.1:/opt/ati/bin:/opt/ati/sbin:/opt/ICAClient:/opt/ghc/bin:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
RSYNC_PROXY="http://proxy.lsy.bud.dlh.de:3128/"
RUBYOPT="-rauto_gem"
SHELL="/bin/bash"
SHLVL="1"
STAGE1_USE="nptl nptlonly unicode"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="x86 X aac aim alsa bash-completion beagle berkdb bitmap-fonts bzip2 cairo calendar cdparanoia cdr cli cracklib crypt cscope cups dbus dlloader doc dri dvd dvdr eds elibc_glibc emacs emboss encode examples exif fam firefox flac flash foomaticdb fortran ftp gd gdbm gif gphoto2 gpm graphviz gstreamer gtk gtk2 hal iconv icq imagemagick imap imlib input_devices_keyboard input_devices_mouse ipod isdnlog jabber java javascript jpeg jpeg2k kde kdeenablefinal kdexdeltas kernel_linux ldap libg++ linguas_en linguas_hu mad maildir mbox mcal mikmod mime mmx mono mp3 mpeg ncurses nls nptl nptlonly nsplugin offensive ogg opengl oscar oss pam pcre pdf perl png ppds pppd python qt3 quicktime readline reflection ruby samba sdl session spell spl sqlite sqlite3 sse2 ssl startup-notification svg svga tcl tcltk tcpd tidy tiff tk truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vcd video_cards_fbdev video_cards_fglrx video_cards_radeon video_cards_vesa vorbis win32codecs xface xinerama xml xorg xv yahoo zlib"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal"
VIDEO_CARDS="radeon vesa fbdev fglrx"
VMHANDLE="blackdown-jdk-1.4.2"
XARGS="xargs -r"
XDG_CONFIG_DIRS="/etc/xdg:/usr/kde/3.5/etc/xdg"
XDG_DATA_DIRS="/usr/kde/3.5/share:/usr/share"
_="/usr/bin/emerge"
ftp_proxy="http://proxy.lsy.bud.dlh.de:3128/"
http_proxy="http://proxy.lsy.bud.dlh.de:3128/"
Comment 1 Botykai Zsolt 2006-12-11 05:08:43 UTC
Created attachment 103795 [details]
fcgi full emerge log
Comment 2 Christian Heim (RETIRED) gentoo-dev 2007-01-08 22:12:08 UTC
(In reply to comment #0)
> Just wanted to play with rails & fcgi. But emergeing rails fails on fcgi, so I
> had tried to emerge fcgi only:
> 
> botykaizs ~ # emerge -uDv fcgi
> Calculating dependencies... done!
> 
> >>> Emerging (1 of 1) dev-libs/fcgi-2.4.0-r1 to /
> ...
> i686-pc-linux-gnu-gcc -march=prescott -O2 -pipe -Wall -o .libs/log-dump
> log-dump.o  ../libfcgi/.libs/libfcgi.so -lm -lnsl
> creating log-dump
> i686-pc-linux-gnu-g++ -march=prescott -O2 -pipe -o .libs/echo-cpp echo-cpp.o 
> ../libfcgi/.libs/libfcgi++.so -lfcgi
> /var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0/libfcgi/.libs/libfcgi.so
> -lnsl
> /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld:
> cannot find -lfcgi
> collect2: ld returned 1 exit status
> make[2]: *** [echo-cpp] Error 1
> make[2]: Leaving directory
> `/var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0/examples'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/dev-libs/fcgi-2.4.0-r1/work/fcgi-2.4.0'
> make: *** [all] Error 2
> 
> !!! ERROR: dev-libs/fcgi-2.4.0-r1 failed.
> 
> # emerge --info
> Portage 2.1.2_rc3-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1,
> glibc-2.5-r0, 2.6.18-gentoo-r2 i686)
> =================================================================
> System uname: 2.6.18-gentoo-r2 i686 Intel(R) Pentium(R) D CPU 3.00GHz
> Gentoo Base System version 1.12.6
> Last Sync: Mon, 11 Dec 2006 01:47:01 +0000
> ccache version 2.4 [enabled]
> dev-java/java-config: 1.3.7, 2.0.30
> dev-lang/python:     2.4.4
> dev-python/pycrypto: 2.0.1-r5
> dev-util/ccache:     2.4-r6
> dev-util/confcache:  0.4.2-r1
> sys-apps/sandbox:    1.2.18.1
> sys-devel/autoconf:  2.13, 2.61
> sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
> sys-devel/binutils:  2.17
> sys-devel/gcc-config: 1.3.14
> sys-devel/libtool:   1.5.22
> virtual/os-headers:  2.6.17-r2
> ACCEPT_KEYWORDS="x86 ~x86"
> ARCH="x86"
> AUTOCLEAN="yes"
> CAMERAS="canon"
> CBUILD="i686-pc-linux-gnu"
> CCACHE_SIZE="512M"
> CFLAGS="-march=prescott -O2 -pipe"
> CHOST="i686-pc-linux-gnu"

Could you please try to disable ccache and report back ?
Comment 3 Botykai Zsolt 2007-01-09 08:30:16 UTC
Yes, but only on wednesday.
Comment 4 Botykai Zsolt 2007-01-10 09:57:09 UTC
Created attachment 106326 [details]
log of fcgi install
Comment 5 Botykai Zsolt 2007-01-10 09:57:49 UTC
Not successed, and I did a revdep-rebuild before. New log attached.
Comment 6 Christian Heim (RETIRED) gentoo-dev 2007-01-14 21:39:05 UTC
OK, I just commited an updated ebuild (fcgi-2.4.0-r2) to the tree, hopefully that will fix your issues. Please wait up the usual time (~45mins) and then try to remerge it.
Comment 7 Botykai Zsolt 2007-01-17 08:13:39 UTC
Thaqnks, it works now!
Comment 8 Ben de Groot (RETIRED) gentoo-dev 2009-01-05 02:46:09 UTC
I get the same error as above, with dev-libs/fcgi-2.4.1_pre0311112127. Disabling parallel build with MAKEOPTS=-j1 makes it work.
Comment 9 Hans de Graaff gentoo-dev 2009-01-18 16:21:41 UTC
(In reply to comment #8)
> I get the same error as above, with dev-libs/fcgi-2.4.1_pre0311112127.
> Disabling parallel build with MAKEOPTS=-j1 makes it work.
> 

I can't seem to reproduce this even with very high -j settings, so I'm not sure what is going on here. It might be useful to see the build log, so could you please include that?
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-02-08 12:16:06 UTC
Hey Hans, I just hit this and I have a solution for you :)

Check out libfcgi/Makefile.am, -lfcgi is linked in libfcgi++.la through _LDFLAGS:

libfcgi___la_LDFLAGS = -lfcgi -rpath @libdir@

which is totally bogus for an automake/libtool-based build system. Replace the line above with

libfcgi___la_LIBADD = libfcgi.la

and the problem will disappear!

By the way the libfcgi++ library does not get installed but just built to build the examples, since I don't think you install the examples either you could also just disable the examples directory from the main Makefile.am SUBDIRS variable and it won't even be built (even better).

HTH!
Comment 11 Tiziano Müller gentoo-dev 2009-04-21 09:52:39 UTC
@Diego: nope, that won't work: The "-rpath" is needed otherwise the installation of libfcgi++.la fails (which gets installed with fcgi-2.4.1_pre...).
Comment 12 Adam Nielsen 2009-05-19 09:30:45 UTC
Just hit this problem myself.  MAKEOPTS=-j1 fixed it for me.
Comment 13 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-09-24 02:07:40 UTC
I don't understand this bug at all. It hit me twice in a row with MAKEOPTS=-j4, then worked with MAKEOPTS=-j1 now it works fine with MAKEOPTS=-j4 again.
Comment 14 Hans de Graaff gentoo-dev 2009-10-25 06:56:58 UTC
*** Bug 289143 has been marked as a duplicate of this bug. ***
Comment 15 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-02-01 11:12:36 UTC
rpath is not used to install libfcgi++… Hans, may I just go on and fix the hell out of this? Thanks.
Comment 16 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-02-01 11:19:11 UTC
(In reply to comment #11)
> @Diego: nope, that won't work: The "-rpath" is needed otherwise the
> installation of libfcgi++.la fails (which gets installed with
> fcgi-2.4.1_pre...).

Does it get installed _at all_? It's still an EXTRA_LTLIBRARIES target in 2.4.1_pre0910052249 …

And EXTRA_LTLIBRARIES don't get installed…

Comment 17 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-02-01 11:20:06 UTC
Oh god they double-declare it…
Comment 18 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-02-01 11:24:50 UTC
Okay fixed, the double-declaration causes libfcgi++ to fail install, so I've dropped that also and now it works.