Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 157814 - [Tracker] Media-video core stable request
Summary: [Tracker] Media-video core stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: Tracker
: 159053 (view as bug list)
Depends on: 143597 155520 157888 157890 157891 157892 157894
Blocks: 136979 142854 159054
  Show dependency tree
 
Reported: 2006-12-11 03:44 UTC by Matthias Schwarzott
Modified: 2007-06-01 21:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Schwarzott gentoo-dev 2006-12-11 03:44:41 UTC
Please test and mark stable media-video/ffmpeg-0.4.9_p20061016 on your arch.

Thanks
Comment 1 Timothy Redaelli (RETIRED) gentoo-dev 2006-12-11 08:58:26 UTC
It fails with FEATURES=stricter and it tries to install ChangeLog that does not exists anymore

dodoc: ChangeLog does not exist

QA Notice: the following files contain runtime text relocations
 Text relocations force the dynamic linker to perform extra
 work at startup, waste system resources, and may pose a security
 risk.  On some architectures, the code may not even function
 properly, if at all.
 For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
 Please include this file in your report:
 /var/tmp/portage/media-video/ffmpeg-0.4.9_p20061016/temp/scanelf-textrel.log
TEXTREL usr/lib/libavcodec.so.51.20.0
TEXTREL usr/lib/libpostproc.so.51.20.0
Comment 2 Matthias Schwarzott gentoo-dev 2006-12-11 09:41:22 UTC
It is necessary to stablize these packages at the same time:
(This is no definite complete list.)

#all versions before have cyclic depend on ffmpeg/gpac/itself
#and we do not want to port support for older x264-svn
#has been added to the tree on 07 Dec 2006.
x264-svn-20061014-r1

# as the x264-svn has no longer the encoder included
x264-svn-encoder-20061014

gpac-0.4.2-r1 - I'm not sure about this.

More things to check would be xine and mplayer.

@drizzt:
Already solved, Changlog now gets installed correct, see Bug #157628.
Comment 3 Alexis Ballier gentoo-dev 2006-12-11 23:45:16 UTC
As Matthias suggested, let's make a big tracker.


Removing temporarly archs, I'll readd you when this tracker will be set up :p

Adding jakub, since you're the b.g.o boss you might help us by setting the new bugs as blocking these ones.


My idea is : Have this tracker that will be blocked each single package stabilization bug, which bug will be blocked by bugs preventing stabilization.
Every package here will have to go stable at the same time to keep the tree consistency.
Comment 4 Alexis Ballier gentoo-dev 2006-12-12 00:32:07 UTC
Ok so this should all be set up now:
x264-svn{,encoder},  ffmpeg, mplayer, libquicktime, gpac.

All of these have to go stable at the same time due to x264-svn api changes.
gpac could be trivially fixed but it's a better idea to stabilize it also due to the block depending on its stabilization bug.


Some things are still to be decided :
avidemux : I'd vote to p.mask it until 2.4 is out without automagic dependencies
blender : luca you spent time fixing 2.42a-r1, does it have to go stable at the same time also ? 


This stabilisation will probably be long to accomplish but this will allow us to do some clean up in the media-video core libs/packages.
Comment 5 Matthias Schwarzott gentoo-dev 2006-12-12 01:16:17 UTC
closed as invalid, as this seems to be no ebuild/package problem.
Comment 6 Matthias Schwarzott gentoo-dev 2006-12-12 01:46:03 UTC
Ups, wanted to close other bug.
Comment 7 Luca Barbato gentoo-dev 2006-12-17 10:25:14 UTC
Blender should be updated too
Comment 8 Markus Rothe (RETIRED) gentoo-dev 2006-12-21 06:28:32 UTC
ppc64 done
Comment 9 Steve Dibb (RETIRED) gentoo-dev 2006-12-21 07:33:54 UTC
Here's a list:

media-libs/x264-svn-20061014-r1
media-video/x264-svn-encoder-20061014
media-video/mplayer-1.0_rc1
media-video/ffmpeg-0.4.9_p20061016
media-libs/libquicktime-0.9.10
media-gfx/blender-2.42a-r1
Comment 10 Gustavo Zacarias (RETIRED) gentoo-dev 2006-12-21 10:49:16 UTC
sparc stable and enabled x264 in the sparc profiles since it seems to work well enough.
nuked sparc stable keywords from ffmpeg-0.4.9_p20060530 since it wanted an older x264 lib which wasn't sparc-ready, same for mplayer-1.0_pre8 & pre8-r1.
blender was unkeyworded without notice so it'll probably have to wait a while to get into stable (actually i'm still building it to get it into ~sparc).
Comment 11 Tobias Scherbaum (RETIRED) gentoo-dev 2006-12-23 11:12:18 UTC
(In reply to comment #9)
> Here's a list:
> 
> media-libs/x264-svn-20061014-r1
> media-video/x264-svn-encoder-20061014
> media-video/mplayer-1.0_rc1
> media-video/ffmpeg-0.4.9_p20061016
> media-libs/libquicktime-0.9.10
> media-gfx/blender-2.42a-r1

ppc stable

Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-12-25 01:26:28 UTC
*** Bug 159053 has been marked as a duplicate of this bug. ***
Comment 13 Scott Van Der Wall 2006-12-29 14:17:34 UTC
on x86:
media-libs/x264-svn-20061014-r1 USE="threads -debug (-mp4%*)"
1: emerges ok
2: passes test suite
3: passes collision test

media-video/x264-svn-encoder-20061014  USE="gtk mp4 threads -debug"
1: emerges ok
2: passes test suite
3: passes collision test

media-video/mplayer-1.0_rc1 USE="X aac aalib alsa dvd dvdread encode gtk iconv%* ipv6 jpeg mad mmx mmxext openal opengl oss png sse sse2 unicode win32codecs x264 xv xvid -3dfx -3dnow -3dnowext (-altivec) -amr% -arts -bidi -bindist -bl -cdparanoia -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb -enca% -esd -fbcon -ggi -gif -jack -joystick -libcaca -lirc -live -livecd -lzo -matrox -musepack -nas -real -rtc -samba -sdl -speex -svga -tga -theora -truetype -v4l -v4l2 -vorbis -xanim -xinerama -xvmc (-i8x0%) (-nvidia%*)" LINGUAS="-bg -cs -da -de -el -en -es -fr -hu -ja -ko -mk -nl -no -pl -pt_BR -ro -ru -sk -tr -uk -zh_CN -zh_TW"
1: emerges ok
2: passes test suite
3: passes collision test
4: runs

media-video/ffmpeg-0.4.9_p20061016 [0.4.9_p20060530] USE="a52 aac encode mmx ogg oss threads x264 xvid zlib (-altivec) -amr -debug -doc -dts -ieee1394 -imlib -network -sdl -test -theora -truetype -v4l -vorbis"
1: emerges ok
2: passes test suite
3: passes collision test

media-libs/libquicktime-0.9.10  USE="X aac alsa encode ffmpeg gtk jpeg mmx opengl png x264 -dv -lame -vorbis"
1: emerges ok
2: passes test suite
3: passes collision test

media-gfx/blender-2.42a-r1  USE="ffmpeg iconv jpeg nls openal png -blender-game -openexr"
1: emerges ok
2: passes test suite
3: passes collision test

revdep-rebuild reports nothing amiss.

emerge --info:

Portage 2.1.1-r2 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r5 i686)
=================================================================
System uname: 2.6.18-gentoo-r5 i686 Genuine Intel(R) CPU           T2500  @ 2.00GHz
Gentoo Base System version 1.12.6
Last Sync: Fri, 29 Dec 2006 17:00:02 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa alsa_cards_hda-intel alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apm berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups dbus divx dlloader dri dvd dvdread elibc_glibc emacs encode ffmpeg firefox flac fortran gdbm gnome gpm gstreamer gtk gtk2 hal iconv input_devices_keyboard input_devices_mouse input_devices_synaptics ipv6 isdnlog ithreads java jpeg jpeg2k kernel_linux ldap libg++ mad mmx mmxext mono mp3 mp4 mpeg ncurses nls nptl nptlonly nsplugin nvidia ogg openal opengl oss pam pcre perl png ppds pppd python quicktime readline realmedia reflection session spl sse sse2 sse3 ssl tcpd threads truetype-fonts type1-fonts udev unicode userland_GNU vcd video_cards_nvidia vidix win32codecs wmf wmp x264 xine xml xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 14 Matthias Langer 2007-01-04 08:30:44 UTC
on x86:

media-video/ffmpeg-0.4.9_p20061016  USE="a52 aac encode mmx ogg sdl theora threads truetype vorbis xvid zlib (-altivec) -amr -debug -doc -dts -ieee1394 -imlib -network -oss -test -v4l -x264"

seems to be fine for me, as

media-video/totem-2.16.4  USE="a52 dbus dvd ffmpeg firefox flac gnome hal mad mpeg ogg theora vorbis xine xv -debug -lirc -nsplugin -nvtv"

using

media-libs/xine-lib-1.1.2-r3  USE="X a52 aac alsa asf dvd fbcon flac gnome ipv6 mp3 nls opengl sdl theora vcd vorbis win32codecs xv -aalib (-altivec) -arts -debug -directfb -dts -dxr3 -esd -imagemagick -libcaca -mng -modplug -oss -samba -speex -v4l -vidix -xinerama -xvmc" VIDEO_CARDS="nvidia -i810 -via"

still plays various sorts of movies.
Comment 15 Christian Faulhammer (RETIRED) gentoo-dev 2007-01-04 10:51:27 UTC
x86 stable
Comment 16 Ben 2007-01-06 21:34:08 UTC
Please add bug #156605 to the depends list as it does not work with the directfb use flag on x86. I use the directfb flag for my tv server so I would not consider it stable
Comment 17 Alexis Ballier gentoo-dev 2007-01-29 19:42:46 UTC
Let's check the keywords :

earch x264-svn
x264-svn-20060612[0]:
x264-svn-20061014[0]:
x264-svn-20061014-r1[0]: alpha amd64 ppc ppc64 sparc x86


earch mplayer
mplayer-1.0_pre8[0]: alpha hppa ia64
mplayer-1.0_pre8-r1[0]:
mplayer-1.0_rc1[0]: amd64 ppc ppc64 sparc x86
mplayer-1.0_rc1-r1[0]: ~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd

<1.0_rc1 breaks with x264-svn-20061014-r1 (might be a problem for alpha, hppa & ia64)


earch ffmpeg
ffmpeg-0.4.9_p20050226-r3[0]: ~mips
ffmpeg-0.4.9_p20051216[0]: -* arm
ffmpeg-0.4.9_p20060302[0]: ~arm ~ppc-macos
ffmpeg-0.4.9_p20060530[0]: -*
ffmpeg-0.4.9_p20060816[0]: -*
ffmpeg-0.4.9_p20061016[0]: -* alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd

<0.4.9_p20061016 breaks with 264-svn-20061014-r1 (should not be any problem there)

earch gpac
gpac-0.4.0[0]: (M) ~x86 ~ppc
gpac-0.4.1_pre20060122[0]: amd64 ppc
gpac-0.4.1_pre20060122-r1[0]:
gpac-0.4.2[0]:
gpac-0.4.2-r1[0]: ~alpha ~amd64 ~ppc ppc64 x86 ~x86-fbsd

0.4.2-r1 fixes bugs and poor pic handling.


earch blender
blender-2.41-r1[0]: amd64
blender-2.42[0]:
blender-2.42a[0]: ~alpha
blender-2.42a-r1[0]: ~amd64 ppc ppc64 ~sparc x86

blender-2.42a needs x264-svn-20060612, might be a problem for alpha


earch libquicktime
libquicktime-0.9.2[0]:
libquicktime-0.9.4[0]:
libquicktime-0.9.7-r1[0]: alpha amd64 ia64
libquicktime-0.9.9[0]:
libquicktime-0.9.9-r1[0]:
libquicktime-0.9.10[0]: ~alpha ~amd64 ~ia64 ppc ppc64 sparc x86

0.9.7-r1 does not have x264 support so this is fine.
0.9.9* break with x264-svn-20061014-r1


earch x264-svn-encoder
x264-svn-encoder-20061014[0]: ~alpha amd64 ppc ppc64 sparc x86


x264-svn-20061014-r1 does not build the "x264" executable, this -encoder package now handles it. (this might be a (minor) problem for alpha)



This was today's status update just to not reiterate bug #163956 :)
Comment 18 Simon Stelling (RETIRED) gentoo-dev 2007-02-07 16:01:33 UTC
aside from libquicktime (which is dealt with in bug 157892) amd64 has everything stable, so no reason for us to stay on CC
Comment 19 Jeroen Roovers (RETIRED) gentoo-dev 2007-03-07 14:48:03 UTC
HPPA done (killerfox), it seems.
Comment 20 Raúl Porcel (RETIRED) gentoo-dev 2007-03-27 15:02:28 UTC
ia64 is all done.
Comment 21 Raúl Porcel (RETIRED) gentoo-dev 2007-05-16 15:23:54 UTC
Alpha is all done.
Comment 22 Alexis Ballier gentoo-dev 2007-06-01 21:46:37 UTC
seems we can close this one now