Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 157108 - net-im/gaim-2.0_beta[45] - no Oscar/MSN SSL support without gnutls
Summary: net-im/gaim-2.0_beta[45] - no Oscar/MSN SSL support without gnutls
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-04 08:25 UTC by Aaron Sheldon
Modified: 2007-05-11 16:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Sheldon 2006-12-04 08:25:17 UTC
When I emerge Gaim 2.0 Beta 5 (currently, though this goes back a version) I hit two odd issues.  I can select Oscar for 'new protocols', but in the account list and everywhere else they're marked "Unknown", just like ones I already had.

Second, (very strangely!), MSN won't work for me unless I compile with gnutls support.

However, when I build from source myself and install into /usr/local/bin/gaim, oscar works properly and MSN works despite --disable-gnutls.

I'm pretty much out of ideas why the portage install doesn't work correctly.

From Gaim debugging support info (portage version):


Debugging Information
  Arguments to ./configure:  '--prefix=/usr' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--enable-nls' '--enable-perl' '--enable-gtkspell' '--disable-startup-notification' '--disable-tcl' '--disable-tk' '--disable-mono' '--disable-debug' '--disable-dbus' '--disable-meanwhile' '--enable-nas' '--disable-gevolution' '--enable-gstreamer' '--disable-doxygen' '--with-dynamic-prpls=irc,jabber,msn,oscar,yahoo,zephyr,simple' '--enable-gnutls=no' '--enable-nss=yes' '--disable-gtk-doc' '--build=i686-pc-linux-gnu' 'CFLAGS=-march=pentium4 -O2 -pipe' 'CXXFLAGS=-march=pentium4 -O2 -pipe' 'build_alias=i686-pc-linux-gnu' 'host_alias=i686-pc-linux-gnu'
  Print debugging messages: No
  Binary relocation: Disabled
  Plugins: Enabled
  SSL: Gaim was compiled with SSL support.

  Library Support
    Cyrus SASL: Disabled
    D-BUS: Disabled
    Evolution Addressbook: Disabled
    Gadu-Gadu library (libgadu): Internal
    GtkSpell: Enabled
    GnuTLS: Disabled
    GStreamer: Enabled
    Mono: Disabled
    NetworkManager: Disabled
    Network Security Services (NSS): Enabled
    Perl: Enabled
    Startup Notification: Disabled
    Tcl: Disabled
    Tk: Disabled
    X Session Management: Enabled
    XScreenSaver: Enabled
    Zephyr library (libzephyr): Not External
    Zephyr uses Kerberos: No


gaim debug information (source /usr/local/bin/gaim version)


Debugging Information
  Arguments to ./configure:  '--disable-gnutls' 'CFLAGS=-g -O2'
  Print debugging messages: No
  Binary relocation: Enabled
  Plugins: Enabled
  SSL: Gaim was compiled with SSL support.

  Library Support
    Cyrus SASL: Disabled
    D-BUS: Disabled
    Evolution Addressbook: Disabled
    Gadu-Gadu library (libgadu): Internal
    GtkSpell: Enabled
    GnuTLS: Disabled
    GStreamer: Enabled
    Mono: Disabled
    NetworkManager: Disabled
    Network Security Services (NSS): Enabled
    Perl: Enabled
    Startup Notification: Enabled
    Tcl: Disabled
    Tk: Disabled
    X Session Management: Enabled
    XScreenSaver: Enabled
    Zephyr library (libzephyr): Not External
    Zephyr uses Kerberos: No






emerge --info


Portage 2.1.1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
=================================================================
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.12.6
Last Sync: Mon, 27 Nov 2006 18:50:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/terminfo"
CXXFLAGS="-march=pentium4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.cites.uiuc.edu/pub/gentoo ftp://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.mirrors.tds.net/gentoo ftp://gentoo.mirrors.pair.com/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://mirror.uni-c.dk/pub/gentoo/"
LANG="en_US.utf8"
LC_ALL="en_US.UTF8"
LINGUAS="en sv"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acpi aiglx aim alsa apache2 apm asf audacious automount bash-completion berkdb bidi bitmap-fonts cdr cjk cli cracklib crypt cups divx dlloader dri dvd dvdr dvdread elibc_glibc emboss encode firefox foomaticdb fortran fuse gdbm gif gpm gstreamer gtk gtk2 iconv idn imlib input_devices_evdev input_devices_joystick input_devices_keyboard input_devices_mouse ipod isdnlog jabber javascript joystick jpeg kernel_linux libg++ libwww linguas_en linguas_sv live mad mikmod mmx mmxext motif mp3 mpeg msn nas ncurses nls no-helper nptl nptlonly nsplugin ogg opengl openssh oscar oss pam pcmcia pcre perl png pppd python quicktime rdesktop readline real reflection reiser4 reiserfs samba sdl session slp spell spl sse sse2 ssl stream subtitles tcpd theora timidity truetype truetype-fonts type1-fonts udev unicode userland_GNU v4l v4l2 video_cards_fglrx video_cards_radeon video_cards_vesa video_cards_vga vorbis wifi win32codecs wma wmp xinerama xml xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jory A. Pratt 2006-12-19 17:54:28 UTC
I am unable to duplicate this ... your gonna have to give a better way to duplicate it sorry.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-12-20 07:44:51 UTC
*** Bug 158648 has been marked as a duplicate of this bug. ***
Comment 3 Kathryn Kulick (RETIRED) gentoo-dev 2006-12-20 14:12:41 UTC
please show emerge -pv gaim
Comment 4 Aaron Sheldon 2006-12-23 15:13:33 UTC
(In reply to comment #3)
> please show emerge -pv gaim
> 

Laptop is getting hardware (USB) issues fixed, I'll get it for you when I get it back.
Comment 5 Olivier Crete (RETIRED) gentoo-dev 2007-05-01 03:14:16 UTC
Can you still reproduce with net-im/pidgin-2.0.0beta7 ?
Comment 6 Aaron Sheldon 2007-05-11 15:56:52 UTC
This appears to be fixed by Pidgin 2.0.  Should be Resolved Fixed.