Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156916 - net-p2p/ktorrent-2.1_beta1 configure fails
Summary: net-p2p/ktorrent-2.1_beta1 configure fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2006-12-02 07:55 UTC by Richard H.
Modified: 2007-02-07 23:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge log (just stdout) (ktorrent-bug.txt,14.70 KB, text/plain)
2006-12-02 07:56 UTC, Richard H.
config.log (config.log,118.17 KB, text/plain)
2006-12-02 07:58 UTC, Richard H.
emerge log (just stderr) (ktorrent-bug.txt,18.77 KB, text/plain)
2006-12-02 08:46 UTC, Richard H.
Outputs of configure in non-portage environment (configure,15.87 KB, text/plain)
2006-12-03 08:26 UTC, Richard H.

Note You need to log in before you can comment on or make changes to this bug.
Description Richard H. 2006-12-02 07:55:07 UTC
The log of the compile is attached, emerge --info is here:

Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r3-richNY i686)
System uname: 2.6.18-gentoo-r3-richNY i686 Intel(R) Pentium(R) M processor 2.00GHz
Gentoo Base System version 1.12.6
Last Sync: Sat, 02 Dec 2006 11:31:02 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-O2 -pipe -march=pentium-m"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=pentium-m"
FEATURES="autoconfig candy distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 7zip a52 aac acpi alsa apache2 apm arts asf avi bash-completion bitmap-fonts bluetooth browserplugin cddb cdparanoia chipcard cjk cli connectionstatus contactnotes cups dbus divx4linux dri dts dv dvd dvdr dvdread elibc_glibc encode fame ffmpeg foomaticdb gif gimp gpm hal history hou httpd icq ieee1394 imlib input_devices_keyboard input_devices_mouse irc irmc jabber javascript jikes jingle jpeg kde kdehiddenvisibility kdepim kernel_linux koffice-plugins libwww linguas_de lzw-tiff m17n-lib mad maps memlimit mikmod mime minimal mjpeg mmx mmxext modplug mozbranding mozdevelop mozilla moznocompose moznoirc moznomail moznopango moznoxft mozsvg mp3 mpeg mplayer msn music musicbrainz mythtv ncurses net network nls no-suexec no_wxgtk1 nocd nomac nomotif nosuid nowlistening nptl nptlonly nsplugin nvidia ogg ooo-kde opengl oscar oss parse-clocks pcmcia pcre pcsc-lite pda pdf perl php pic png pnp ppds python qt qt3 qt4 quicktime rar readline samba scanner sdl session smartcard sms sou spl sql sse sse2 ssl subtitles symlink taglib texteffect tga tidy truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l v4l2 vcd video_cards_fbdev video_cards_nv video_cards_nvidia video_cards_vesa videos vim-pager vim-with-x vlm vorbis wifi win32codecs winpopup wxwindows xcomposite xinerama xml xorg xosd xpm xscreensaver xsl xslt xv xvid xvmc yahoo yvl zeroconf zlib"
Comment 1 Richard H. 2006-12-02 07:56:07 UTC
Created attachment 103220 [details]
emerge log (just stdout)
Comment 2 Richard H. 2006-12-02 07:58:18 UTC
Created attachment 103223 [details]
Comment 3 Ioannis Aslanidis (RETIRED) gentoo-dev 2006-12-02 08:30:57 UTC
The error message is missing. Does it fail at configure or at compile?
Comment 4 Richard H. 2006-12-02 08:39:51 UTC
Oh you are right... I think I did a mistake at the redirections. Missing messages follow...
Comment 5 Richard H. 2006-12-02 08:46:15 UTC
Created attachment 103224 [details]
emerge log (just stderr)

configure fails.
Comment 6 Ioannis Aslanidis (RETIRED) gentoo-dev 2006-12-02 10:42:18 UTC
Please, clean your /var/tmp/portage and try to emerge ktorrent again.
Comment 7 Richard H. 2006-12-02 11:10:24 UTC
done that already. Did not help though :(
Comment 8 Ioannis Aslanidis (RETIRED) gentoo-dev 2006-12-02 12:40:51 UTC
I can't reproduce it locally. Does it work for you if you turn off kdehiddenvisibility?
Comment 9 Richard H. 2006-12-02 12:52:35 UTC
ktorrent does not have kdehiddenvisibility.

ALso, I don't have this bug on other machines it seems

Is there something I could do, like remerge something maybe?
Comment 10 Richard H. 2006-12-03 07:50:46 UTC

emerge -e system as recommended from a friend did not help.
Will maybe do emerge -e world overnight...
Comment 11 Richard H. 2006-12-03 08:22:42 UTC
Update 2:

I am able to compile it from source, if untouched by portage:
ebuild `equery w ktorrent` clean
ebuild `equery w ktorrent` unpack
cd /var/tmp/portage/ktorrent-2.1_beta1/work/ktorrent-2.1beta1/
(even running autoreconf works here)
(did not try further)

Now, when I run
ebuild `equery w ktorrent` merge
it tries to compile of course,
and then autoconf and autoreconf spout out the known error messages.

So it seems to me portage does something bad.

For now I will do make install and unmerge ktorrent from my system, but I would be glad to help further finding this bug by trying to merge it.
Comment 12 Richard H. 2006-12-03 08:25:17 UTC
ad Update 2:

forgot to mention ./configure when I try to build without portage, which outputs the following warnings:


---but it still works compiling and installing...
Comment 13 Richard H. 2006-12-03 08:26:31 UTC
Created attachment 103277 [details]
Outputs of configure in non-portage environment
Comment 14 Ioannis Aslanidis (RETIRED) gentoo-dev 2007-02-07 22:29:19 UTC
Assuming it works fine on the later versions.
Comment 15 Richard H. 2007-02-07 23:28:35 UTC
yes, I tried to merge it, and everything worked.