Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156222 - mail-client/mozilla-thunderbird-1.5.0.8 fails to start if Compose window is open
Summary: mail-client/mozilla-thunderbird-1.5.0.8 fails to start if Compose window is ...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-25 08:17 UTC by Petteri Räty (RETIRED)
Modified: 2006-12-06 06:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petteri Räty (RETIRED) gentoo-dev 2006-11-25 08:17:58 UTC
To reproduce:
1. Open a window to write a new mail
2. Close the main Thunderbird window (leave Compose window open)
3. try to reopen Thunderbird

betelgeuse@pena /usr/portage/profiles $ emerge -pv mozilla-thunderbird

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] mail-client/mozilla-thunderbird-1.5.0.8  USE="crypt xinerama -debug -gnome -ipv6 -ldap -moznopango -xprint" LINGUAS="fi -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fr -ga -ga_IE -gu_IN -he -hu -it -ja -ko -lt -mk -nb -nb_NO -nl -pa_IN -pl -pt_BR -ru -sk -sl -sv -sv_SE -tr -zh_CN" 0 kB


This gives the following output in console:
etelgeuse@pena /usr/portage/app-text/trang $ thunderbird
/usr/lib/mozilla-thunderbird/mozilla-xremote-client: Error: Failed to send command: 500 command not parseable
Browser doesn't understand command

betelgeuse@pena /usr/portage/app-text/trang $ emerge --info
Portage 2.1.2_rc2-r1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo i686)
=================================================================
System uname: 2.6.18-gentoo i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.12.6
Last Sync: Unknown
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4, 2.5-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -mfpmath=sse -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe -mfpmath=sse -fomit-frame-pointer"
DISTDIR="/var/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect cvs distlocks fixpackages java-strict parallel-fetch sandbox sfperms sign strict stricter userpriv usersandbox verify-rdepend"
GENTOO_MIRRORS=" http://trumpetti.atm.tut.fi/gentoo  http://lame.lut.fi/linux/gentoo "
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="fi"
MAKEOPTS="-j2"
PKGDIR="/home/pkg/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/mnt/checkouts/overlays/betelgeuse /mnt/checkouts/overlays/migrated-java /mnt/checkouts/overlays/java-experimental /mnt/checkouts/overlays/sunrise /mnt/checkouts/overlays/voip /mnt/checkouts/overlays/einit"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 aac acl acpi alsa arts audiofile bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo cdb cddb cdparanoia cdr cli cracklib crypt cups dbus dlloader dri dts dvd dvdr dvdread elibc_glibc emboss esd fam ffmpeg firefox gif gstreamer hal iconv input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jpeg kde kdeenablefinal kdehiddenvisibility kernel_linux libg++ linguas_fi logitech-mouse mad mikmod mjpeg mmx mp3 mpeg ncurses network nptl nptlonly nsplugin nvidia offensive ogg opengl pam pcre png ppds pppd qt3 quicktime readline real reflection rtc samba session spell spl sse sse2 ssl subversion svg symlink theora threads truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales video_cards_none video_cards_nvidia vim-syntax vorbis xcomposite xinerama xml xorg xv xvid xvmc zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2006-12-06 04:50:07 UTC
If old compose Window is open, then ThunderBird is running. Thus, instance and process are still "up valid running", and lock file is active and valid for good reason.

In theses conditions, not being able to open a new instance of TB is "normal".

Please mark this bug as "invalid" or "wontfix". Jory, can you do this for us ?

or report upstream https://bugzilla.mozilla.org/ you want to be able to run two instances of TB at the time. This is likely to be VERY difficult with branch 1, because TB is actually conceived as single process app, and even rarely use threads.

I have no clue if coming TB2 or 3 will change this. Any way, the "Gentoo" bug should be closed.
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2006-12-06 05:02:00 UTC
alternative: in the compose window, you can querry a new "main" one in the "Tools" menu, or directly press Ctrl+1 ...

othjer wise, you need to save or send email being typed, or kill TB process whatever the way (close window, force close if the window manager has this option, or "killall -9 thunderbird" in console).
Comment 3 Jory A. Pratt 2006-12-06 06:21:35 UTC
(In reply to comment #1)
> Please mark this bug as "invalid" or "wontfix". Jory, can you do this for us ?

I have not be reinstated yet that is about 40 days away before Kloeri makes a final decision. I will get it closed as I know it is the lock that is causing the  issue that is reported. Nothing myself or upstream will do about removing the lock from thunderbird.
Comment 4 Petteri Räty (RETIRED) gentoo-dev 2006-12-06 06:54:07 UTC
Well closing this as CANTFIX then.