Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156116 - media-sound/audacious-1.2.2: build_stamp.c compile failure
Summary: media-sound/audacious-1.2.2: build_stamp.c compile failure
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-24 03:59 UTC by elpeor
Modified: 2006-11-29 05:14 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build_stamp.co you requested (build_stamp.c,189 bytes, text/plain)
2006-11-29 05:04 UTC, elpeor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elpeor 2006-11-24 03:59:04 UTC
Hello, I tried 10 times to emerge audacious, but I get this:

        CC     iir.c               
        CC     iir_cfs.c           
        CC     iir_fpu.c           
        CC     build_stamp.c       
build_stamp.c:6: error: missing terminating " character
build_stamp.c:7: error: missing terminating " character
build_stamp.c:7: error: expected expression at end of input
make[2]: *** [build_stamp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [build] Error 2
make: *** [build] Error 2

!!! ERROR: media-sound/audacious-1.2.1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  audacious-1.2.1.ebuild, line 42:   Called die

!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



============================================================================

Portage 2.1.1-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r3 i686)
=================================================================
System uname: 2.6.18-gentoo-r3 i686 Mobile Intel(R) Celeron(R) CPU 1.60GHz
Gentoo Base System version 1.12.6
Last Sync: Fri, 24 Nov 2006 10:30:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60 
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3  
sys-devel/gcc-config: 1.3.13-r4 
sys-devel/libtool:   1.5.22     
virtual/os-headers:  2.6.17-r1  
ACCEPT_KEYWORDS="x86"           
AUTOCLEAN="yes"                 
CBUILD="i686-pc-linux-gnu"      
CFLAGS="-O2 -march=pentium4"    
CHOST="i686-pc-linux-gnu"       
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4"  
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/"
LINGUAS="es"                    
MAKEOPTS="-j2"                  
PKGDIR="/usr/portage/packages"  
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"       
PORTDIR="/usr/portage"          
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac aalib acpi alsa apache2 apm asf audiofile avi berkdb bitmap-fonts cdr clamav cli cracklib crypt cups dlloader dri dvd dvdread eds elibc_glibc emboss encode esd ffmpeg flac foomaticdb fortran gdbm gdm gif gmail gnome gpm gstreamer gtk gtk2 iconv ieee1394 imlib input_devices_kbd input_devices_keyboard input_devices_mouse ipv6 isdnlog jack jpeg kernel_linux libg++ libwww linguas_es mad mikmod mmx motif mozilla mp3 mpeg mysql ncurses nls nptl nptlonly ogg opengl oss pam pcmcia pcre pdf perl php png pop pppd python qt3 qt4 quicktime readline reflection reiserfs sdl session sndfile sox spell spl sse sse2 ssl svg tcpd threads timidity truetype truetype-fonts type1-fonts udev usb userland_GNU vcd video_cards_fbdev video_cards_radeon video_cards_vesa videos vorbis wifi win32codecs xfce4 xfs xml xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Tony Vroon gentoo-dev 2006-11-24 04:27:48 UTC
Please try whether 1.2.2 works for you.
Comment 2 elpeor 2006-11-24 05:00:33 UTC
(In reply to comment #1)
> Please try whether 1.2.2 works for you.
> 

It would be good to try 1.2.2 

but the version that portage can install is this:

 media-sound/audacious
      Latest version available: 1.2.1
      Latest version installed: 1.1.2-r1
      Size of files: 1,852 kB
      Homepage:      http://audacious-media-player.org/
      Description:   Audacious Player - Your music, your way, no exceptions
      License:       GPL-2

but plugins are:

media-plugins/audacious-plugins
      Latest version available: 1.2.2-r1
      Latest version installed: [ Not Installed ]
      Size of files: 2,127 kB
      Homepage:      http://audacious-media-player.org/
      Description:   Audacious Player - Your music, your way, no exceptions
      License:       GPL-2

maybe is a bug in portage tree???

how could I emerge 1.2.2??

thanks...
Comment 3 elpeor 2006-11-29 02:37:02 UTC
(In reply to comment #1)
> Please try whether 1.2.2 works for you.
> 

hello I just saw this morning that emerge let me compile audacious 1.2.2

but I have the same problem!!!!!:



      CC     iir.c               
        CC     iir_cfs.c           
        CC     iir_fpu.c           
        CC     build_stamp.c       
build_stamp.c:6: error: missing terminating " character
build_stamp.c:7: error: missing terminating " character
build_stamp.c:7: error: expected expression at end of input
make[2]: *** [build_stamp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [build] Error 2
make: *** [build] Error 2

!!! ERROR: media-sound/audacious-1.2.2 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  audacious-1.2.2.ebuild, line 42:   Called die

!!! make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.




What can I do??? 
Comment 4 Matthias Langer 2006-11-29 03:02:41 UTC
In reply to comment #0 and comment #3:

hmm, this is strange as both 
media-sound/audacious-1.2.(2|1)  USE="gnome nls -chardet" compile and work fine here:

Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r2 i686)
=================================================================
System uname: 2.6.18-gentoo-r2 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.12.6
Last Sync: Tue, 28 Nov 2006 10:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig collision-protect distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo "
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.1/gentoo-portage"
USE="x86 3dnow 3dnowext X a52 aac acpi aiglx alsa audiofile beagle berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt css cups dbus dlloader dri dvd dvdr dvdread eds elibc_glibc emboss encode evo exif fam fbcon ffmpeg firefox flac fortran gdbm gif ginac gmp gnome gphoto2 gpm gstreamer gtk gtk2 hal howl iconv icq input_devices_keyboard input_devices_mouse ipv6 isdnlog java javascript jpeg jpeg2k kernel_linux lcms ldap libg++ linguas_de linguas_en mad mikmod mime mmx mmxext mono mozsvg mp3 mpeg msn nautilus ncurses nfs nls nptl nptlonly nsplugin nvidia offensive ogg oggvorbis opengl pam pcre pdf perl plotutils png posix ppds pppd python qt3 qt4 quicktime readline real reflection ruby sdl session sockets spell spl sqlite3 sse ssl subtitles svg tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vcd video_cards_nvidia vorbis win32codecs wma xine xml xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Tony Vroon gentoo-dev 2006-11-29 03:31:46 UTC
None of our testers are able to reproduce this problem. Please attach the faulty build_stamp.c file that is created by the configure script. (In text-plain)
Comment 6 Tony Vroon gentoo-dev 2006-11-29 03:58:01 UTC
Unable to reproduce on 4 independent systems. Feel free to reopen once evidence is attached.
Comment 7 elpeor 2006-11-29 05:04:52 UTC
Created attachment 102975 [details]
build_stamp.co you requested

here you have!!
Comment 8 elpeor 2006-11-29 05:14:30 UTC
(In reply to comment #6)
> Unable to reproduce on 4 independent systems. Feel free to reopen once evidence
> is attached.
> 

ok .. I made alittle change and is compiled now

I made the emerge , but just before the error appeared I paused the process with contro+z, then I edited build_stamp.c and I fixed the line that was wrong, the problem is only that there is a character between the variable and ", I deleted it an everything works well.

Why configure-script in audacius made this error??, why it is only to me??

thanks for you help!!!