Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 155662 - net-www/gnash-0.7.2: missing library
Summary: net-www/gnash-0.7.2: missing library
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Schweizer (RETIRED)
: 156871 (view as bug list)
Depends on:
Reported: 2006-11-19 05:02 UTC by Fiona Klute
Modified: 2006-12-02 01:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Fiona Klute 2006-11-19 05:02:27 UTC
After compiling net-www/gnash-0.7.2 on my AMD64 computer gnash failed with the following error:

# gnash
gnash: error while loading shared libraries: cannot open shared object file: No such file or directory

I checked /usr/lib and found ->

I guessed it was just a missing link or wrong path, and in fact

# ln -s /usr/lib/ /usr/lib/

solved the problem. I don't know if the mistake is in gnash or the ebuild, but it should be fixed.

From emerge --info:

Portage 2.1.1-r2 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.17-gentoo-r8 x86_64)
System uname: 2.6.17-gentoo-r8 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.6
Last Sync: Sun, 19 Nov 2006 11:50:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon64 -O2 -pipe"
CXXFLAGS="-march=athlon64 -O2 -pipe"
Comment 1 Stefan Schweizer (RETIRED) gentoo-dev 2006-11-19 07:06:09 UTC
Did you have any version of gnash installed before that?

Can you please try to uninstall everything, remove the link and then merge from scratch?
Comment 2 Didier Link 2006-11-19 14:03:07 UTC
I've the same problem but a "simple" re-emerge of the package is sufficent for solve it !
Comment 3 Fiona Klute 2006-11-20 13:05:19 UTC
Ummerging and emerging again (after removing the link) worked. Seems like it was a local problem.
Comment 4 Stefan Schweizer (RETIRED) gentoo-dev 2006-11-20 13:12:08 UTC
yeah. Please just remerge gnash when this comes up.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-12-02 01:28:46 UTC
*** Bug 156871 has been marked as a duplicate of this bug. ***