Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 155151 - Backspace key not working when 'make menuconfig' on tty
Summary: Backspace key not working when 'make menuconfig' on tty
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2006-11-14 11:26 UTC by Dustin Polke
Modified: 2009-02-01 11:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (,5.44 KB, text/plain)
2006-11-14 11:30 UTC, Dustin Polke

Note You need to log in before you can comment on or make changes to this bug.
Description Dustin Polke 2006-11-14 11:26:22 UTC
When invoking 'make menuconfig' from tty, the backspace key is not working. Thus, when choosing 'Load/Save config to/from alternate file', proper choice of filename is not possible.
When invoking from xterm, backspace works as expected.

Installed ncurses:

solaris linux # eix sys-libs/ncurses
* sys-libs/ncurses 
     Available versions:  5.4-r6:5 5.5-r2:5 5.5-r3:5
     Installed:           5.5-r3
Comment 1 Dustin Polke 2006-11-14 11:30:53 UTC
Created attachment 101940 [details]
emerge --info
Comment 2 SpanKY gentoo-dev 2006-11-14 16:10:29 UTC
no idea what "from tty" means ... describe what your tty actually is and what $TERM setting you are using
Comment 3 Dustin Polke 2006-11-14 16:39:23 UTC
Okay, I try to explain what I meant:

If I log into a text console like tty1, tty2, etc, then su to become root and invoke 'make menuconfig' in /usr/src/linux, the backspace key is not working in dialogs, eg. when entering a filename to save the configuration. This is, I cannot remove the '.config' by pressing backspace. But I am able to enter additional letters. I have not changed the TERM settings. A 'env | grep TERM' yields:

solaris dustin # env | grep TERM

If I open an X session and do the same in a xterm console, backspace is working.
Here, a 'env | grep TERM' yields:
solaris dustin # env | grep TERM

I hope the problem has become more clear now.


Comment 4 SpanKY gentoo-dev 2006-11-14 16:44:14 UTC
and what if you login as root ... or if you run `su -` instead
Comment 5 Dustin Polke 2006-11-15 04:41:35 UTC
Same result: Backspace is not working. Output of 'env | grep TERM' as well :(
Comment 6 Dustin Polke 2007-08-15 18:57:03 UTC
Cannot reproduce it anymore. Close this bug because it automagically solved 
Comment 7 Sebastiano Cavicchio 2009-02-01 11:27:30 UTC
Hi! I had the same issue (backspace was not working on any text input in "make
menuconfig", not just the save as alternate file). I solved uncommenting
EXTENDED_KEYMAPS="" in /etc/conf.d/keymaps and commenting out
EXTENDED_KEYMAPS="backapace keypad euro" which was there by default after
installing Gentoo 2007.0 via the installer found on the LiveCD.

(this seems a duplicate of bug 2364, where I just put this reply... I'm new to bug reporting so sorry if I'm doing wrong things...)