Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 154536 - nvidia-drivers-1.0.9629 fails to load
Summary: nvidia-drivers-1.0.9629 fails to load
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2006-11-09 00:51 UTC by Lóránt Farkas
Modified: 2007-02-07 18:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (,4.60 KB, text/plain)
2006-11-09 00:54 UTC, Lóránt Farkas
Xorg.0.log (Xorg-error,30.03 KB, text/plain)
2006-11-09 00:56 UTC, Lóránt Farkas
xorg.conf (xorg.conf,8.53 KB, text/plain)
2006-11-09 08:02 UTC, Lóránt Farkas

Note You need to log in before you can comment on or make changes to this bug.
Description Lóránt Farkas 2006-11-09 00:51:33 UTC
The X does not start with the new driver. Probably this is a problem of xorg-server-1.1.1. I couldn't merge xorg-server-1.1.1-r1 due to the bug #153475.
Comment 1 Lóránt Farkas 2006-11-09 00:54:28 UTC
Created attachment 101524 [details]
emerge --info
Comment 2 Lóránt Farkas 2006-11-09 00:56:17 UTC
Created attachment 101525 [details]
Comment 3 Kris Kersey (RETIRED) gentoo-dev 2006-11-09 07:55:38 UTC
1) Did a previous driver work correctly for you?

2) Have you run:
eselect opengl set nvidia

3) Please post your xorg.conf so we can clean up the obvious problems.
Comment 4 Lóránt Farkas 2006-11-09 08:01:57 UTC
The previous drviver had worked

I've used Nvidia GLX, so "eselect opengl set nvidia" have runned

I will add xorg.conf as an attachment
Comment 5 Lóránt Farkas 2006-11-09 08:02:34 UTC
Created attachment 101548 [details]
Comment 6 DocReedSolomon 2006-11-09 08:14:00 UTC
i am getting the same problem. previous driver worked and i just switched back to it (nvidia-drivers-1.0.8776).

could this be a problem because eselect 1.0.7 is missing? emerge liked to upgrade this as well, but its not available yet.

0: /usr/bin/X(xf86SigHandler+0x18c) [0x49a17c]
1: /lib/ [0x3bf662f7f0]
2: /usr/lib/tls/ [0x3bf640065e]

Fatal server error:
Caught signal 11.  Server aborting
Comment 7 DocReedSolomon 2006-11-09 09:35:25 UTC
oops, some more info:
NVidia PCI-E 7300GS
kernel 2.6.18-gentoo-r2
Comment 8 Lóránt Farkas 2006-11-12 02:09:58 UTC
I've runned the original Nvidia package and now all works fine. So it is a problem with the ebuild. 
When i installed the drivers the installer said "resolving conflict with xorg drivers" or something like that. the point is that the driver works.
Comment 9 Lóránt Farkas 2006-12-05 01:13:22 UTC
I've emerged the ebuild (after runed the installer) and now the driver works. I've noticed that the ebuild doesn't install the library to /usr/lib64
is there any business to this?
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2006-12-16 04:59:21 UTC
So has anyone been able to verify this without manually putting files on their system?  I'd like to know if it is fixed in 1.0.9631 or not.
Comment 11 Chris Gianelloni (RETIRED) gentoo-dev 2007-02-07 18:00:14 UTC
No response... been more than a month, and this works perfectly for me.