Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15436 - Cannot upgrade Gnome and Gnome-Media due to gst-plugins dependency
Summary: Cannot upgrade Gnome and Gnome-Media due to gst-plugins dependency
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2003-02-10 10:23 UTC by gtaluvit
Modified: 2004-04-27 08:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description gtaluvit 2003-02-10 10:23:17 UTC
If I try a emerge -up gnome, emerge -up gnome-media, or emerge -up world I get 
the following error:

 emerge -up gnome-media

These are the packages that I would merge, in order:

Calculating dependencies /
!!! all ebuilds that could satisfy ">=media-libs/gst-plugins-0.5.2" have been 
!!!    (dependency required by "gnome-extra/gnome-media-" [ebuild])

!!! Error calculating dependancies. Please correct.

I have manually emerged  gst-plugins-0.6.0-r1.ebuild but to no avail, I still 
have the same problem.

Reproducible: Always
Steps to Reproduce:
1. emerge -up gnome

Actual Results:  
Error listed in details

Expected Results:  
gst-plugins-0.6.0-r1 should have been recognized.
Comment 1 gtaluvit 2003-02-10 10:42:10 UTC
Had the suggestion of not using -u.  I've tried that with emerge -p gnome and now its dieing on not finding nautilus-  I'm manually emerging that now and trying that.
Comment 2 gtaluvit 2003-02-10 11:51:44 UTC
OK, slight change to this bug.  Things work much better without -u.  I got the nautilus dependency issue, so I manually emerged nautilus2.2 which worked fine.  Then a emerge -p gnome showed all the dependencies and its compiling now.  So, the bug is why did I have to manually emerge nautilus2.2 if its not masked?
Comment 3 foser (RETIRED) gentoo-dev 2003-02-10 12:03:26 UTC
im wondering, can you give me the breaking output of gnome-media ? gnome-media doesn't seem to depend on nautilus at all (and i don't know why it should). 

And what exactly was 'dieing' on nautilus ?

What arch are you on ? x86 ? but gstreamer 0.5.2 and up aren't masked for x86, so it makes little sense.
Comment 4 gtaluvit 2003-02-10 12:35:38 UTC
The nautilus issue was with emerge -p gnome or emerge -p world, NOT with gnome-media.  The gnome-media issue occured if I used -u.  Without -u, as in emerge -p gnome I would get a similar error for dependencies as above, stating that

!!! all ebuilds that could satisfy ">=gnome-base/nautilus-" have been 

However, I could manually emerge that ebuild with emerge nautilus- and that installed fine and now gnome installs with no problems.  My question is, why did I need to install that manually to begin with.  emerge gnome should have worked.  As an aside, if I do an emerge -s nautilus, here's my nautilus entry.

*  gnome-base/nautilus
      Latest version available: 2.0.8
      Latest version installed:
      Size of downloaded files: 5,005 kB
      Description: A filemanager for the Gnome2 desktop

2.2 is not masked so why is this happening?

Comment 5 foser (RETIRED) gentoo-dev 2003-02-10 13:28:55 UTC
you ask me, it doesnt make sense . stale files ? something in your local distfiles ? bad rsync mirror ?
Comment 6 gtaluvit 2003-02-10 15:43:42 UTC
I had cleaned out distfiles, rsynced from multiple mirrors and had the same problem.  I don't know what other files could be stale, especially since this system is only a few days old.  The original Gnome was installed via GRP.
Comment 7 foser (RETIRED) gentoo-dev 2003-02-10 16:47:30 UTC
hmmm GRP, maybe that has to do with it.. can you remove /var/cache/edb/dep/* ? See if that makes a difference.
Comment 8 gtaluvit 2003-02-10 18:18:01 UTC
That fixed it.  -u now seems to work and an emerge -s nautilus now shows the correct package.  Thank you very much!
Comment 9 Rod Smith 2004-04-27 08:38:11 UTC
I've recently run into this bug on an AMD64 system. Here's what I get:

# emerge -pu world

These are the packages that I would merge, in order:

Calculating world dependencies |
!!! all ebuilds that could satisfy "=media-plugins/gst-plugins-vorbis-0.6*" have been masked.
!!! possible candidates are:
- media-plugins/gst-plugins-vorbis-0.6.4 (masked by: ~keyword)
!!!    (dependency required by "gnome-extra/gnome-media-" [ebuild])

!!! Problem with ebuild gnome-base/gnome-2.4.2
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.


It looks to me like somebody removed the AMD64-approved gst-plugins-vorbis version from the Portage tree (my system currently has 0.6.3 installed) and changed the gnome-media package description to require 0.6.4. (I've no idea if it really does.) I've tried changing "~amd64" in the gst-plugins-vorbis ebuild to "amd64", and that seems to at least get things building. (The process isn't yet finished on my system, though.)
Comment 10 foser (RETIRED) gentoo-dev 2004-04-27 08:46:49 UTC
yes and this bug has completely nothind todo with that, so file a new bug and file it to the amd64 team.