Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 154213 - ndiswrapper weird compilation failure...
Summary: ndiswrapper weird compilation failure...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
Depends on:
Reported: 2006-11-06 00:31 UTC by Peter Volkov (RETIRED)
Modified: 2006-11-26 02:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Volkov (RETIRED) gentoo-dev 2006-11-06 00:31:55 UTC
I've encountered this bug already 5 times so I've did some investigations and would like to report about results. During *bulk* emerge it normally stops on ndiswrapper with the error message:

>>> Emerging (6 of 9) net-wireless/ndiswrapper-1.28 to /
>>> Compiling source in /home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28 ...
gcc -g -Wall -I../driver -o loadndisdriver loadndisdriver.c
 * Preparing ndiswrapper module
make -C /lib/modules/2.6.17-gentoo-r8/build M=/home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver
make[1]: Entering directory `/usr/src/linux-2.6.17-gentoo-r8'
  LD      /home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver/built-in.o
  CC [M]  /home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver/crt.o
/home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver/crt.c:402:25: error: crt_exports.h: No such file or directory
make[2]: *** [/home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver/crt.o] Error 1
make[1]: *** [_module_/home/misc/porttmp/portage/ndiswrapper-1.28/work/ndiswrapper-1.28/driver] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.17-gentoo-r8'
make: *** [default] Error 2
make: INTERNAL: Exiting with 4 jobserver tokens available; should be 3!

!!! ERROR: net-wireless/ndiswrapper-1.28 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  ndiswrapper-1.28.ebuild, line 58:   Called linux-mod_src_compile
  linux-mod.eclass, line 482:   Called die

!!! Unable to make  KSRC=//usr/src/linux KVERS=2.6.17-gentoo-r8  all.
!!! If you need support, post the topmost build error, and the call stack if relevant.


Always in the same place. And always if I try to resume emerge completes without any errors. By bulk emerge I mean emerge of many packages in a time and ndiswrapper is not the first in the queue.

To reproduce the problem I did, fex, `emerge -1 wepattack ndiswrapper` and every *second* time it fails. But if I do emerge -1 ndsiwrapper, it compiles fine every time. May be this is parallel jobs issue as I did not manage to reproduce problem with `env MAKEOPTS="-j1" emerge -1 wepattack ndiswrapper` but attempts to catch parallel jobs issue with -j100 compiling 100 times did nothing. So this can be reproduced only during bulk emerge. And ndiswrapper is the only package I have such problems with. Yes weired, but I'd voted for adding -j1 into ebuild.

emerge --info
Portage 2.1.1-r1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1700MHz
Gentoo Base System version 1.12.6
Last Sync: Sun, 05 Nov 2006 11:00:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-O2 -mtune=pentium-m -fomit-frame-pointer -mcpu=pentium-m -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -mtune=pentium-m -fomit-frame-pointer -mcpu=pentium-m -pipe"
FEATURES="autoconfig ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
LINGUAS="ru en en_GB en_US"
MAKEOPTS="-j3 -l1"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/www-apps-overlay/webapps/experimental /home/peter/Gentoo/pva-svn/pva /home/peter/Gentoo/www-apps/webapps/experimental"
USE="x86 X a52 aac acl acpi aiglx alsa apache2 apm arts audiofile bash-completion bluetooth branding browserplugin bzip2 cairo cdparanoia chardet cli cracklib crypt cups curl dbus divx divx4linux djvu dlloader dmi dri dv dvd eds elibc_glibc emboss encode expat fam fastcgi ffmpeg firefox flac foomaticdb gd gif gimpprint glibc-omitfp glitz glsa glut gmedia gnome gstreamer gtk gtk2 gtkhtml guile hal iconv idea idn imagemagick input_devices_keyboard input_devices_mouse irda isdnlog java jce jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kernel_linux latex lcms libg++ libwww linguas_en linguas_en_GB linguas_en_US linguas_ru linuxthreads-tls lzo mad math matroska mikmod mmx mng mozdevelop mozsvg mp3 mpeg multitarget musepack nls no-seamonkey nptl nptlonly nsplugin offensive ogg openexr opengl oss pam pcmcia pda pdf pic plotutils png ppds pppd python qt3 quicktime readline real realmedia reflection rtc sdl session sms sndfile snmp sound spell spl sse sse2 ssl svg tcltk tcpd tetex theora tiff timidity truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales vhosts video_cards_fbdev video_cards_r128 video_cards_radeon video_cards_vesa vorbis win32codecs wma wmf wmp xcomposite xinerama xml xorg xv xvid zlib"

Thank you.
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2006-11-25 00:51:50 UTC
This could also be a problem with ccache and something poisoned in the cache. Have you tried with ccache disable?
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2006-11-26 01:00:56 UTC
I've just tried and seems that ccache is not the problem here. At least I reproduced bug with:
env FEATURES="-ccache" emerge -1v wepattack net-wireless/ndiswrapper
and recent net-wireless/ndiswrapper-1.29.
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2006-11-26 02:33:52 UTC
(In reply to comment #2)
> I've just tried and seems that ccache is not the problem here. At least I
> reproduced bug with:
> env FEATURES="-ccache" emerge -1v wepattack net-wireless/ndiswrapper
> and recent net-wireless/ndiswrapper-1.29.

Ok. Forcing -j1. Try ndiswrapper-1.29 after syncing next time. Thanks for reporting.