Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 153983 - Possibility of a 32emerge symlink to emerge 32-bit packages on amd64?
Summary: Possibility of a 32emerge symlink to emerge 32-bit packages on amd64?
Status: RESOLVED DUPLICATE of bug 145737
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Conceptual/Abstract Ideas (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-03 17:59 UTC by Alex Elsayed
Modified: 2006-11-03 18:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Elsayed 2006-11-03 17:59:51 UTC
Might it be possible to have a "32emerge" symlink linking to portage with portage functionality to detect that the command came from the symlink (like kgtk)? If so, might it be possible to set up a sort of "mirror-world" which uses the same files as normal portage to store configuration, world database, etc, but the last file would have "32" prepended to it, and the same for files produced by it? For instance, the command "emerge /masked package/" would check /etc/portage/package.unmask while "32emerge /masked package/" would check /etc/portage/32package.unmask. The downside to this is that it would probably require a separate keyword of some sort which would trigger a patch in programs like flagedit to use the 32'd files instead of the normal ones - but the upside is it could allow a combination 32/64-bit environment  without the hassle of setting up a chroot. Another downside, however, is that load on the developers and the complexity of portage code would need to increase. That is why I am posting it as a conceptual/abstract idea, so that those who know more can take a look at it and figure out if it might be workable. (And if so, how it could be made less onerous on those involved)
Comment 1 Michael Weyershäuser 2006-11-03 18:03:02 UTC
You're probably looking / waiting for the implementation of bug 145737...
Comment 2 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2006-11-03 18:03:51 UTC
Quite...

*** This bug has been marked as a duplicate of 145737 ***