Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 153925 - app-misc/mc wont work with new bash-3.2 propeply with all directories
Summary: app-misc/mc wont work with new bash-3.2 propeply with all directories
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://savannah.gnu.org/bugs/?18136
Whiteboard:
Keywords:
: 164175 (view as bug list)
Depends on:
Blocks: bash-3.2
  Show dependency tree
 
Reported: 2006-11-03 05:40 UTC by Lars Wendler (Polynomial-C)
Modified: 2009-08-05 11:32 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
new patch (mc-4.6.1-bash-3.2.patch,873 bytes, patch)
2006-11-12 06:15 UTC, Mehmet Kemal EROL
Details | Diff
new ebuild (mc-4.6.1-r3.ebuild,3.79 KB, text/plain)
2006-11-12 06:16 UTC, Mehmet Kemal EROL
Details
latest patch (mc-4.6.1-bash-all.patch,926 bytes, patch)
2006-11-12 17:54 UTC, Mehmet Kemal EROL
Details | Diff
latest ebuild (mc-4.6.1-r4.ebuild,3.79 KB, text/plain)
2006-11-12 17:54 UTC, Mehmet Kemal EROL
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2006-11-03 05:40:37 UTC
Hi,

mc won't change into directories that contain a "_" or other "exotic" characters when running in bash-3.2.

upstream is already aware of this bug. I'm posting this here so that Gentoo won't miss the fix when there is one that is accepted upstream.

Cheers
Poly-C
Comment 1 Mehmet Kemal EROL 2006-11-12 06:14:25 UTC
I made a new ebuild containing the patch provided by Andrey Skvortsov upstream.

No ill side-effects, here ... please test it!
Comment 2 Mehmet Kemal EROL 2006-11-12 06:15:34 UTC
Created attachment 101732 [details, diff]
new patch
Comment 3 Mehmet Kemal EROL 2006-11-12 06:16:35 UTC
Created attachment 101734 [details]
new ebuild
Comment 4 Mehmet Kemal EROL 2006-11-12 17:52:23 UTC
Hold it! ... Developer Leonard den Ottolander kindly replied to my entry on `mc's bug page, like: 

Mehmet, instead of using the attached patch that breaks compatibility with bash < 3.2 you might want to use the hack/patch that I posted to the mc-devel list in relation to this report.

That patch is almost identical to this one, but by escaping numbers as well it remains compatible with bash > 2.05b.

***

I dug around, found the mentioned hack, made a new patch with a new ebuild: C'mon fellows, give it a try ;)
Comment 5 Mehmet Kemal EROL 2006-11-12 17:54:03 UTC
Created attachment 101796 [details, diff]
latest patch
Comment 6 Mehmet Kemal EROL 2006-11-12 17:54:58 UTC
Created attachment 101797 [details]
latest ebuild
Comment 7 Tiger!P 2006-11-13 13:10:13 UTC
I've tested on amd64 and it works at least for the directories with a '_' in the name. I'm using bash 3.2.3(1)-release
Comment 8 Hiel Van Campen 2006-11-13 16:08:04 UTC
I tested on a ~x86 with bash-3.2.3(1)-release and its happy viewing ~/tst_tst/tst_tst .
Comment 9 Markus Ullmann (RETIRED) gentoo-dev 2006-11-15 03:02:06 UTC
Imported into CVS, thanks for the patch :)
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-01-28 09:49:21 UTC
*** Bug 164175 has been marked as a duplicate of this bug. ***