Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 153115 - 'Up' arrow key does not work with evdev set as keyboard driver. Mouse works correctly with it, though
Summary: 'Up' arrow key does not work with evdev set as keyboard driver. Mouse works c...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Other
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2006-10-27 23:55 UTC by lothalev
Modified: 2009-04-17 19:14 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description lothalev 2006-10-27 23:55:12 UTC
When keyboard driver module in is set to evdev, the Up arrow key stops working. When running KDE, pressing Up arrow starts ksnapshot (why?!?)

xf86-input-evdev ver. 1.1.3
xorg-server ver. 1.1.1

The solution for now is not to use evdev for keyboard yet (though it should be fixed to have only one, unified input driver).
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-28 01:15:22 UTC
If you can reproduce this w/ latest version, file a bug upstream ( if there's not one yet.
Comment 2 Joshua Baergen (RETIRED) gentoo-dev 2006-10-29 10:40:14 UTC
Make sure you have xkeyboard-config installed instead of xkbdata as well.
Comment 3 lothalev 2006-10-30 01:46:03 UTC
Tried to update all involed packages, it didn't help though. The strange thing about this problem is, before logging in to KDE (still at kdm login screen), the 'up' arrow key works as expected.
So seems it has something to do with KDE shorcut key associations.
Comment 4 Ruben Faelens 2006-10-31 02:50:02 UTC
The evdev keyboard driver has different keycodes than the kbd-driver. When first starting X, it will map the keycodes to the reported keys by the event interface. Needless to say; this doesn't work for internationalization. Thus, when keycodes get mapped to keys by using setxkbmap, things go horribly wrong.
Solution is to use setxkbmap -keycodes 'evdev'. With xkeyboard-config, there is a seperate evdev-keycodes file.
I still had to add a keycode for LessThan-GreaterThan on my Logitech Belgian layout keyboard. The evdev keyboard driver still has issues, developers are still discussing wether the event input keycode to kbd keycode conversion has to be done in the kernel driver, in X11 or ...
Comment 5 Ruben Faelens 2007-01-08 21:08:23 UTC
Currently, this works for me. Using     Option     "XkbModel"      "evdev"
 in xorg.conf did the trick. The only thing that didn't work, are the Super_L and Super_R keys. They have to be added manually to a modifier using xmodmap.

add Mod3 = Super_R
add Mod3 = Super_L

So, this works for me perfectly. Please change the status into FIXED or UPSTREAM, because this was fixed upstream.
Comment 6 James Cloos 2007-01-10 13:46:10 UTC
The super keys should work w/o bothering with xmodmap.

This is what I use:

Section "InputDevice"
  Identifier   "evKeyboard"
  Driver       "evdev"
  Option       "evBits"     "+1"
  Option       "keyBits"    "~1-255 ~352-511"
  Option       "Pass"       "3"
  Option       "AutoRepeat" "500 30"
  Option       "XkbLayout"  "us,gr,ru"
  Option       "XkbOptions" "ctrl:nocaps"
  Option       "XkbOptions" "grp:crtls_toggle"
  Option       "XkbOptions" "grp_leds:scroll"
  Option       "XkbOptions" "compose:menu"

The two Bits options and the Pass option came right out of a howto.
You may need them (or a subset thereof) to get the super keys working
w/o resorting to xmodmap.
Comment 7 Joshua Baergen (RETIRED) gentoo-dev 2007-01-27 18:03:45 UTC
lothalev, please try the suggestions here (and possibly X 7.2 as well) and re-open the bug with your results.  Thanks!
Comment 8 Dmitri 2009-04-17 19:14:11 UTC
Adding following section in to the xorg.conf solved my problem with the arrow up key
Section "InputDevice"
  Identifier   "evKeyboard"
  Driver       "evdev"
  Option       "evBits"     "+1"
  Option       "keyBits"    "~1-255 ~352-511"
  Option       "Pass"       "3"
  Option       "AutoRepeat" "500 30"
tnx a lot