Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 152995 - emerge libstdc++-v3-3.3.4 and 3.3.6 fails: machname.h / fixinc.h error
Summary: emerge libstdc++-v3-3.3.4 and 3.3.6 fails: machname.h / fixinc.h error
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2006-10-27 09:19 UTC by Small_Penguin
Modified: 2008-06-23 11:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

libstdc++-v3-3.3.4 error log. (libstdc-error.log,367.99 KB, text/plain)
2006-10-27 09:21 UTC, Small_Penguin

Note You need to log in before you can comment on or make changes to this bug.
Description Small_Penguin 2006-10-27 09:19:05 UTC
I've tried to compile libstdc++ with gcc-4.1.1, but it always fails. Emerge output follows.

Repeatable: always.

emerge --info:
Gentoo Base System version 1.12.5
Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.17-reiser4-r8 i686)
System uname: 2.6.17-reiser4-r8 i686 Intel(R) Pentium(R) 4 CPU 3.40GHz
Last Sync: Wed, 25 Oct 2006 18:30:01 +0000
ccache version 2.4 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer -fno-ident"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/initng/daemon /etc/initng/net /etc/initng/system /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer -fno-ident"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 7zip X a52 aac acpi alsa bash-completion berkdb bitmap-fonts bzip2 cairo cdparanoia cdr cli cracklib crypt cups curl dbus dlloader dri dvd dvdr dvdread elibc_glibc emacs emacs-w3 encode fam ffmpeg firefox flac fortran ftp gdbm gif gpm gs gstreamer gtk hal idn imagemagick imap initng_plugins_also initng_plugins_bash_launcher initng_plugins_chdir initng_plugins_chroot initng_plugins_conflict initng_plugins_cpout initng_plugins_critical initng_plugins_ctrlaltdel initng_plugins_daemon_clean initng_plugins_dbus_event initng_plugins_debug_commands initng_plugins_envparser initng_plugins_find initng_plugins_fmon initng_plugins_fstat initng_plugins_history initng_plugins_idleprobe initng_plugins_initctl initng_plugins_interactive initng_plugins_iparser initng_plugins_last initng_plugins_limit initng_plugins_lockfile initng_plugins_logfile initng_plugins_netdev initng_plugins_netprobe initng_plugins_ngc4 initng_plugins_ngcs initng_plugins_nge initng_plugins_pause initng_plugins_provide initng_plugins_reload initng_plugins_renice initng_plugins_rlparser initng_plugins_simple_launcher initng_plugins_stcmd initng_plugins_stdout initng_plugins_suid initng_plugins_syncron initng_plugins_syslog initng_plugins_sysreq initng_plugins_unneeded initng_plugins_usplash input_devices_evdev input_devices_joystick input_devices_keyboard input_devices_mouse ipv6 isdnlog java javascript jikes joystick jpeg jpeg2k kdehiddenvisibility kernel_linux ldap libg++ linguas_de lm_sensors mad matroska mikmod mime mmkeys mmx mng mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg openal opengl oss pam pcre pdf perl png ppds pppd python quicktime readline recode reflection samba sdl session shorten slang sndfile speex spell spl sse sse2 ssl startup-notification svg tcpd tetex theora threads tidy tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vcd video_cards_fbdev video_cards_fglrx video_cards_radeon video_cards_vesa video_cards_vga vorbis win32codecs wmf xcomposite xine xinerama xml xorg xpm xprint xscreensaver xv xvid zlib"
Comment 1 Small_Penguin 2006-10-27 09:21:32 UTC
Created attachment 100585 [details]
libstdc++-v3-3.3.4 error log.

Same error with 3.3.6.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-10-27 09:29:28 UTC
Don't see much useful in there, you should try w/ MAKEOPTS="-j1"
Comment 3 Small_Penguin 2006-10-27 09:51:09 UTC
No, -j1 didn't help either. What else can I look for?

    /bin/sh ${srcdir}/ i686-pc-linux-gnu i686-pc-linux-gnu)
constructing ../ for i686-pc-linux-gnu to run on i686-pc-linux-gnu
make TARGETS=oneprocess SHELL="/bin/bash" CC="gcc" CFLAGS=" -march=prescott -O2 -pipe -fno-ident -DIN_GCC -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long -DHAVE_CONFIG_H -DGENERATOR_FILE" LDFLAGS="" LIBERTY="/var/tmp/portage/libstdc++-v3-3.3.4/work/build/gcc/../libiberty/libiberty.a" install-bin
make[2]: Entering directory `/var/tmp/portage/libstdc++-v3-3.3.4/work/build/gcc/fixinc'
/bin/bash /var/tmp/portage/libstdc++-v3-3.3.4/work/gcc-3.3.4/gcc/fixinc/genfixes machname.h
make[2]: *** [machname.h] Error 1
make[2]: Leaving directory `/var/tmp/portage/libstdc++-v3-3.3.4/work/build/gcc/fixinc'
make[1]: *** [] Error 2
make[1]: Leaving directory `/var/tmp/portage/libstdc++-v3-3.3.4/work/build/gcc'
make: *** [all-gcc] Error 2

!!! ERROR: sys-libs/libstdc++-v3-3.3.4 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  libstdc++-v3-3.3.4.ebuild, line 233:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 4 Small_Penguin 2006-10-29 07:48:29 UTC
I didn't think about this before: Maybe the problem is that the file machname.h doesn't exist on my system? I couldn't find it, looked everywhere. Where is it supposed to be? Which package contains it?
Comment 5 Small_Penguin 2006-11-20 17:53:24 UTC
(In reply to comment #4)
Ok, I think I know where the file is after looking at the ebuild ;-)
Never mind. I reinstalled gentoo few days ago and a gcc-4-compiled version is included now.
Comment 6 Small_Penguin 2007-06-17 20:29:46 UTC
I'm sorry, I have to reopen this bug, since it happens on three different machines (error is identical).

I've tried everything stated here (MAKEOPTS="-j1", turned off CCACHE, used other CFLAGS, e.g. those used for compiling the old version which was provided by the installation) with both 3.3.4 and 3.3.6. Use flags are -build -multilib nls nptl. GCC version 4.1.1, 4.1.1-r1, ... 4.1.2.

I've searched the web, but found nothing except the rather dated entry on which *seems* to be similar to my problem (although it's about building on cygwin). Unfortunately, that thread is not really revelatory.

/bin/sh is symlink to /bin/bash. It seems the genfixes script which should generate the machname.h file fails.

I have no clue. What can I do to find a solution... Any ideas?
Comment 7 Mark Loeser (RETIRED) gentoo-dev 2007-12-08 01:57:07 UTC
Just tried this with 4.1.2 and it works for me.  Have you tried recompiling bash with different CFLAGS?  Have you tried running the bash command that fails by hand?  If this were a widespread issue we would definitely be seeing more bugs.
Comment 8 Small_Penguin 2008-06-23 11:59:40 UTC
Hi, after quite a while I gave it another try.

While I'm not completely sure about this, I believe that the recent upgrade to unstable gcc-4.2.4 solved the problem and I could finally compile libstdc++-v3-3.3.6. So it may have been simply an issue with gcc-4.1.*.

Therefore, I consider this solved and will close this bug now. Thanks for your help.