Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 152882 - kernel >= 2.6.14 won't boot on Netra X1
Summary: kernel >= 2.6.14 won't boot on Netra X1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: Sparc64 Linux
: High major (vote)
Assignee: Sparc Porters
Depends on:
Reported: 2006-10-26 08:24 UTC by Max Hacking
Modified: 2006-12-26 07:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Max Hacking 2006-10-26 08:24:44 UTC
While attempting to install the latest stable (on SPARC) kernel (gentoo-sources-2.6.17-r8) on a Netra X1 I ran into the following problem.

Whenever I attempt to boot over the network I receive one of the error messages listed below:

IDPROM: Warning, unknown format type!
Illegal Instruction
Memory Address not Aligned
Data Access Exception
Fast Instruction Access MMU Miss

The error message can be changed by compiling a random kernel component in or out to change the size of the generated kernel.  All kernels I have tried have been less than 3MB, some less than 2.5MB.

I then tried installing every available version of gentoo-sources back to 2.6.14-r7 with the same result.  At this point I moved to testing vanilla-sources, unfortunately with no improvement.  

Kernel versions 2.6.13-r5 and earlier all boot fine.  This led me to believe that the issue was probably introduced in 2.6.14.  After scanning through the changelog for that version I have found the following commit:

commit bff06d552240ba7f5b49482a4865871d7bc03dc2
Author: David S. Miller
Date:   Thu Sep 22 20:11:33 2005 -0700

    [SPARC64]: Rewrite bootup sequence.
    Instead of all of this cpu-specific code to remap the kernel
    to the correct location, use portable firmware calls to do
    this instead.
    Signed-off-by: David S. Miller

Seems like more than a coincidence to me...  

After much searching of the web I have found that the following architectures are affected:

Sun Netra X1 (UltraSPARC-IIe 400MHz)
Sun Fire V240
Sun Blade 2500

Using OBP versions 4.0.5, 4.3.2, 4.5.9 and 4.17.1.

Should I file this directly with the kernel maintainers?
Comment 1 Max Hacking 2006-10-26 08:33:43 UTC
Sorry, should have added that this is NOT related to the similar looking SILO bug.  This occurs when net-booting too.
Comment 2 Gustavo Zacarias (RETIRED) gentoo-dev 2006-11-07 11:21:54 UTC
One of the sparc devels has a V240 running with recent kernels just fine.
However this isn't related since the X1 is a completely different machine. And unfortunately we lack an X1 to help so it's best if you try upstream with the sparclinux mailing list.
Comment 3 Max Hacking 2006-12-22 02:58:25 UTC
Resolved in kernel 2.6.19-r2.

I'm happy to call this closed if you guys are.  :-)
Comment 4 Gustavo Zacarias (RETIRED) gentoo-dev 2006-12-26 07:02:22 UTC
We're happy if you're happy.
2.6.19-r2 won't go stable until we work around the qlogic firmware issue that 2.6.18+ got (removed firmware from the kernel, thus blade 1000/2000 machines can't boot from builtin disk).
Though it's a genkernel issue and completely unrelated.