Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 152612 - Portage doesn't check the ebuilds given as emerge arguments, if they fulfilling needed dependencies
Summary: Portage doesn't check the ebuilds given as emerge arguments, if they fulfilli...
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-23 17:48 UTC by Carsten Lohrke (RETIRED)
Modified: 2006-10-23 18:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Lohrke (RETIRED) gentoo-dev 2006-10-23 17:48:41 UTC
iglu ~ # emerge =sip-4.2.1 =PyQt-3.14.1-r2 -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] dev-python/sip-4.2.1 [4.5_pre20061021]
[ebuild     UD] dev-python/sip-4.2.1-r1 [4.5_pre20061021]
[ebuild     UD] dev-python/PyQt-3.14.1-r2 [3.16.1_pre20061021]


and now having =sip-4.2.1 installed already:


iglu ~ # emerge  =PyQt-3.14.1-r2 -p

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] dev-python/PyQt-3.14.1-r2 [3.16.1_pre20061021]



Tested with Portage 2.1.2_pre3-r7.
Comment 1 Zac Medico gentoo-dev 2006-10-23 18:20:59 UTC
I'm hoping to fix this one in 2.1.3.

*** This bug has been marked as a duplicate of 1343 ***