Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 1520 - The Xvfb hack for gdk-pixbuf and evolution doesn't work for me
Summary: The Xvfb hack for gdk-pixbuf and evolution doesn't work for me
Status: RESOLVED DUPLICATE of bug 1531
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Seemant Kulleen (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-04 00:52 UTC by Stefan Boresch
Modified: 2006-08-05 04:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Boresch 2002-04-04 00:52:25 UTC
The following snippet from the latest gdk-pixbuf (r7) and evolution (1.0.3-r2) 
ebuilds doesn't work for me.

XDISPLAY=$(i=0; while [ -f /tmp/.X${i}-lock ] ; do i=$((${i}+1)); done;
echo ${i})
       /usr/X11R6/bin/Xvfb :${XDISPLAY} >& /dev/null &
       DISPLAY=:${XDISPLAY} emake || DISPLAY=:${XDISPLAY} make || die

       kill $(cat /tmp/.X${XDISPLAY}-lock)

It finds a socket, but you can't connect (here an excerpt from trying this 
interactively):

------------

boresch@lipari boresch $ Xvfb :4 &
[1] 22298

boresch@lipari boresch $ ls -a /tmp/
.                 .xf86config2916  evolution-1000-3178  sandboxpids.tmp
..                GmKjXr8D         evolution-1000-3347  sic13586.tmp
.ICE-unix         GmhRUMg8         evolution-1000-890   sic858.tmp
.X0-lock          badpatches       fileb3I5Q2           svoa5.tmp
.X11-unix         db-upgrade-bak   fileqIO38x           svoa6.tmp
.X4-lock          dcop5I0ORI       kde-boresch          t0swbnkz.ps
.keep             dcop6Iz3gj       kde-root             xdvi5G9yeI
.sawfish-boresch  dcopQGbiXM       ksocket-boresch      xdvipXcepx
.sawfish-mama     dcopi8rZPG       mcop-boresch         xdviu2xEeJ
.sawfish-root     env              mcop-root

boresch@lipari boresch $ ps aux | grep Xvfb
boresch  22298 19.8  1.9  9456 5024 pts/4    S    08:42   0:01 Xvfb :4
boresch  22301  0.0  0.1  1488  484 pts/4    S    08:42   0:00 grep Xvfb

boresch@lipari boresch $ emacs -d :4
AUDIT: Thu Apr  4 08:43:37 2002: 22298 Xvfb: client 1 rejected from local host
Xlib: connection to ":4.0" refused by server
Xlib: No protocol specified

emacs: Cannot connect to X server :4.
Check the DISPLAY environment variable or use `-d'.
Also use the `xhost' program to verify that it is set to permit
connections from your machine.

-------------------

Same if I do this as root.  So, I can start Xvfb, but I can't connect
to it :-(

My XFree is 4.2 (the r8 ebuild).  I am not aware of running 
any special security precautions...

Further, I am building while in X -- maybe this has anything to do
with it ... (This is the first gdk-pixbuf/evolution ebuild I have 
problems with)

Stefan
PS: No version field for 1.0 yet :-) ?
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-04 19:00:32 UTC

*** This bug has been marked as a duplicate of 1531 ***