Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 151528 - net-p2p/amule-2.1.3 crashes with x11-libs/gtk+-2.10.6
Summary: net-p2p/amule-2.1.3 crashes with x11-libs/gtk+-2.10.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Low normal (vote)
Assignee: Gentoo net-p2p team
URL:
Whiteboard:
Keywords:
: 152151 159139 170876 175084 192852 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-15 22:12 UTC by Sawk
Modified: 2007-09-19 16:55 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sawk 2006-10-15 22:12:57 UTC
Hello,

Amule crashes when I try to push the "Clean" button in the "search" bar.
This is the error:

(amule:2107): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

Gtk-ERROR **: file gtkcontainer.c: line 2447 (gtk_container_propagate_expose): assertion failed: (child->parent == GTK_WIDGET (container))
aborting...


--------------------------------------------------------------------------------------------------------------------------------------------

Portage 2.1.2_pre3-r2 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo i686)
=================================================================
System uname: 2.6.18-gentoo i686 Intel(R) Celeron(R) CPU 2.60GHz
Gentoo Base System version 1.12.5
Last Sync: Mon, 16 Oct 2006 05:00:01 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks fixpackages metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="it_IT@euro"
LC_ALL="it_IT@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS=""
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/sawk/wmii"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac alsa apm arts asf bash-completion berkdb bitmap-fonts cairo cdparanoia cli crypt cups curl custom-cflags dbus dga directfb dlloader dri dvb dvd dvdr dvdread eds elibc_glibc emboss encode esd fbcon ffmpeg firefox flac foomaticdb fortran gdbm gif glitz gpm gstreamer gtk gtk2 hal i8x0 imlib infopipe input_devices_joystick input_devices_keyboard input_devices_mouse isdnlog java javascript jce jpeg kde kdeenablefinal kdehiddenvisibility kernel_linux libg++ libsamplerate libwww linguas_it live logitech-mouse lzo mad matroska mikmod mmx motif moznocompose moznoirc moznomail moznoxft mp3 mpeg musepack musicbrainz ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openssh oss pam pcre pdf perl png pop pppd print python qt3 qt4 quicktime readline real reflection rtc scanner sdl session sndfile speex spell spl sse sse2 ssl tcpd tga theora timidity truetype truetype-fonts type1-fonts udev usb userland_GNU v4l vcd video_cards_nvidia vorbis win32codecs xml xmms xorg xprint xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-10-20 11:59:10 UTC
*** Bug 152151 has been marked as a duplicate of this bug. ***
Comment 2 Tomasz L. Nowak 2006-10-21 15:24:47 UTC
It also happens when any of the "Close tab" options is selected. I noticed the aMule maintainers about this issue: http://www.amule.org/abugs/view.php?id=996
Comment 3 Henrique Rodrigues 2006-11-24 17:00:16 UTC
Can you reemerge aMule with gtk+-2.10.6? I've tried and it fails. Maybe it's the same problem:

/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: dynamic variable `_SDA_BASE_@@WXU_2.6' is zero size
/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: /usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../crt1.o(.rodata+0x0): unresolvable R_PPC_ADDR32 relocation against symbol `_SDA_BASE_@@WXU_2.6'
/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output
Comment 4 Lars Schonert 2006-12-07 07:57:36 UTC
Have the same problem too.

net-p2p/amule-2.1.3 was reemerged with x11-libs/gtk+-2.10.6, that was ok.

(amule:19665): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

Gtk-ERROR **: file gtkcontainer.c: line 2447 (gtk_container_propagate_expose): assertion failed: (child->parent == GTK_WIDGET (container))
aborting...
Comment 5 Fabio Rossi 2006-12-13 04:54:46 UTC
It's a problem of wxGTK-2.6 built against gtk-2.10: it's fixed with wxGTK > 2.7

http://www.amule.org/amule/thread.php?postid=62956
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-12-26 07:23:06 UTC
*** Bug 159139 has been marked as a duplicate of this bug. ***
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2007-01-12 16:12:02 UTC
Feel free to provide a patch.

Else we can't fix this unless we get wxGTK bumped...
Comment 8 Henrique Rodrigues 2007-01-12 16:34:23 UTC
Can someone make this bug depend on bug #145884 ?
Comment 9 Mart Raudsepp gentoo-dev 2007-01-12 17:20:56 UTC
(In reply to comment #8)
> Can someone make this bug depend on bug #145884 ?

It doesn't depend on bug #145884 specifically - a bug fix for this will be included in 2.6.4 and if necessary I can rush out a revbump of wxGTK with the trivial patch that fixes it. (I could also include this in current 2.6.3.3 that is up for stabilization, but would likely have to delay the request for stabilization even more then)

Upstream patch to wxGTK: http://cvs.wxwidgets.org/viewcvs.cgi/wxWidgets/src/gtk/notebook.cpp.diff?r1=1.120.2.2&r2=1.120.2.3&only_with_tag=WX_2_6_BRANCH
I want to first check if this doesn't cause any regressions or memleaks for gtk+-2.8 and earlier, though. Most probably is fine.
Comment 10 Fabio Rossi 2007-02-25 12:13:30 UTC
(In reply to comment #9)
> I want to first check if this doesn't cause any regressions or memleaks for
> gtk+-2.8 and earlier, though. Most probably is fine.

Do you think it's safe to apply this patch now that gtk+-2.10 is stable on almost all archs?
Comment 11 Sawk 2007-03-31 12:46:50 UTC
I think is a good idea
Comment 12 Mart Raudsepp gentoo-dev 2007-04-01 05:38:46 UTC
wxGTK-2.6.4.0 will be added to the tree soon, which includes this patch. I still need to do some testing and ABI compatibility checks before.
Comment 13 Mart Raudsepp gentoo-dev 2007-04-05 10:03:06 UTC
(In reply to comment #12)
> wxGTK-2.6.4.0 will be added to the tree soon, which includes this patch. I
> still need to do some testing and ABI compatibility checks before.

I unfortunately can't finish this work before the start of next week, as I'll be completely offline and away from my machine until late evening Sunday. I'll concentrate on this ASAP when I'm back.
Comment 14 Mart Raudsepp gentoo-dev 2007-04-05 10:05:01 UTC
*** Bug 170876 has been marked as a duplicate of this bug. ***
Comment 15 Raúl Porcel (RETIRED) gentoo-dev 2007-04-19 08:43:58 UTC
*** Bug 175084 has been marked as a duplicate of this bug. ***
Comment 16 Jurek Bartuszek (RETIRED) gentoo-dev 2007-05-13 03:51:44 UTC
Any luck with testing?
Comment 17 Piotr Stachura 2007-05-13 09:14:03 UTC
For a long time I'm using wxGTK-2.8.0 without any problems. I only noticed that portage isn't prepared for that version (wx script is looking for 2.6 version and if failed it goes to 2.4).
Why still 2.8 version isn't in portage??
Comment 18 Mart Raudsepp gentoo-dev 2007-05-13 11:01:50 UTC
(In reply to comment #16)
> Any luck with testing?

Yes, I will be asking today for 2.6.4.0 to be released officially.
At which point I can put in the ebuild for 2.6.4.0.

(In reply to comment #17)
> For a long time I'm using wxGTK-2.8.0 without any problems. I only noticed that
> portage isn't prepared for that version (wx script is looking for 2.6 version
> and if failed it goes to 2.4).
> Why still 2.8 version isn't in portage??

See the relevant bump request bug...
Comment 19 Henrique Rodrigues 2007-06-08 17:04:12 UTC
(In reply to comment #18)
> Yes, I will be asking today for 2.6.4.0 to be released officially.
> At which point I can put in the ebuild for 2.6.4.0.

2.6.4 was officially released on May 18th.
Comment 20 Henrique Rodrigues 2007-06-08 17:06:34 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > Yes, I will be asking today for 2.6.4.0 to be released officially.
> > At which point I can put in the ebuild for 2.6.4.0.
> 
> 2.6.4 was officially released on May 18th.

Sorry, I was wrong! That was 2.8.4!

Comment 21 Alexandru Toma 2007-06-09 16:06:36 UTC
> (In reply to comment #19)
> Sorry, I was wrong! That was 2.8.4!
> 

wxGTK 2.6.4 is available for some time now (since 21 March): http://sourceforge.net/project/showfiles.php?group_id=9863&package_id=14076&release_id=495302 
Comment 22 Mart Raudsepp gentoo-dev 2007-06-09 22:20:51 UTC
(In reply to comment #21)
> wxGTK 2.6.4 is available for some time now (since 21 March):

I am waiting on wxPython 2.6.4.0 tarball now, that the author will officially release soon now and will fix the amule crash with gtk2.10.
Comment 23 Alexandru Toma 2007-06-09 22:41:27 UTC
(In reply to comment #22)
> I am waiting on wxPython 2.6.4.0 tarball now, that the author will officially
> release soon now and will fix the amule crash with gtk2.10.
> 

Thanks for letting us know the status of this bug, but I thought amule didn't depend on wxPython. Maybe I'm missing something here... if that's the case then just ignore this comment.
Comment 24 Mart Raudsepp gentoo-dev 2007-06-10 01:35:40 UTC
wxPython tarball contains sources for wxGTK too and that's what we currently use for getting wxGTK sources too. More in depth explanation in various other bug reports where this was queried. It think the 2.8 bump request had this explained too in a comment of mine.
Comment 25 Jurek Bartuszek (RETIRED) gentoo-dev 2007-08-04 22:43:50 UTC
ping? anyone? what's the status?
Comment 26 Ryan Hill (RETIRED) gentoo-dev 2007-09-04 04:55:17 UTC
wxGTK-2.6.4.0 is in the tree now, package.masked for testing since it's pretty much a complete rewrite.  it should be unmasked by next week.
Comment 27 Jurek Bartuszek (RETIRED) gentoo-dev 2007-09-04 21:51:17 UTC
works like a charm with my amule installation

hell ~ # emerge --info
Portage 2.1.2.12 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r5 i686)
=================================================================
System uname: 2.6.22-gentoo-r5 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 04 Sep 2007 18:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms sign strict"
GENTOO_MIRRORS="ftp://ftp:qweryuio12345678@main http://distfiles.gentoo.org/"
LANG="pl_PL"
LC_ALL="pl_PL.UTF-8"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /home/koxta/gentoo/tree/gentoo-x86"
SYNC="rsync://main/gentoo-portage"
USE="X a52 aac aalib accessibility acpi alsa amarok arts asf audiofile avi bash-completion berkdb bitmap-fonts bzip2 cairo cdinstall cdparanoia cdr cli cracklib crypt cscope css cups curl cvs dbus dga divx doc dri dts dvd dvdr dvdread emboss encode esd evo exif expat fam fbcon ffmpeg firefox flac fortran ftp gdbm gif gimpprint glitz glut gmp gphoto2 gpm gstreamer gtk hal iconv idn ieee1394 imagemagick ipv6 isdnlog jack java javascript jpeg jpeg2k kadu-modules kadu-voice kde lcms libnotify libwww lirc logitech-mouse mad matroska md5sum midi mikmod mime mjpeg mmap mmx mng mono mozbranding mozdevelop mp3 mpeg mudflap musepack ncurses nls nptl nptlonly nsplugin nvidia odbc offensive ogg openal opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline real realmedia reflection ruby samba sdl seamonkey session slang snmp sox spell spl sse sse2 ssl startup-notification subversion svg svga tcltk tcpd tetex theora tidy tiff timidity truetype truetype-fonts type1 type1-fonts unicode usb v4l videos vim vim-syntax vim-with-x vorbis win32codecs wmp wxwindows x86 xine xml xorg xpm xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020" INPUT_DEVICES="keyboard mouse vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa vga vmware"
Unset:  CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 28 Ryan Hill (RETIRED) gentoo-dev 2007-09-15 04:35:20 UTC
unmasked.  thanks for being patient.
Comment 29 Raúl Porcel (RETIRED) gentoo-dev 2007-09-19 16:55:20 UTC
*** Bug 192852 has been marked as a duplicate of this bug. ***