Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 151373 - iptables-1.3.5-r4 with gcc-4.1.1 & glibc-2.4-r3 not working on gent-sources-2.6.17-gentoo-r8
Summary: iptables-1.3.5-r4 with gcc-4.1.1 & glibc-2.4-r3 not working on gent-sources-2...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-10-14 11:44 UTC by Michael Hoegler
Modified: 2006-10-15 11:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

kernelconfig + make.conf (kernelconf+ makeconf.txt,73.35 KB, text/plain)
2006-10-14 11:49 UTC, Michael Hoegler

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hoegler 2006-10-14 11:44:48 UTC
After doing a system upgrade from gcc 3.3.6 to gcc-4.1.1 + glibc-2.4.r3 i recompiled !!!REALLY !!! EVERYTHING. kernel: 2.6.17-gentoo-r8 #2 SMP

a test within our fw-rules:
/sbin/iptables -t nat -A POSTROUTING -d -o lo -j SNAT --to-source

leads to:
iptables v1.3.5: can't initialize iptables table `nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
--> upgrade to what ? (kernel-2.9 iptables 3.x ?) 

Module                  Size  Used by
ip_tables              15076  0 
x_tables               15748  1 ip_tables

procedure was: upgrading kernel 2.4 --> 2.6
upgrading gcc (with gentoo cookbook :-))
upgrading glibc.
recompiling all (contents from world file, NOT revdep rebuild)
waiting 2 days ...
recompiling erreanous ebuilds ...
(when not having nvidia-glx in new structure, there is no hint, so recompiling again 1 day)

after 1st iptables error error: reemergeing kernel, patching l7 support. compiling kernel. reboot
reemerging iptables --> no change ....

before upgrading: with kernel 2.6.17-gentoo-r8, but old gcc and old glibc
iptables worked fine (with patched l7 support!)

ALL packages seem to be OK, an emerge -p world shows nothing more to emerge !

I wanted to test openswan, but without iptables it doesnt make sense, the whole upgrade doesnt make sense, as iptables is really neccessary !

net-firewall/iptables       -imq l7filter extended 

the only idea I have, may be in make.conf, Im using
CFLAGS="-O2 -mcpu=i586 -pipe -fomit-frame-pointer"
--> -mcpu instead of march !!!!
but there are no compile errors, just warnings !

or error comes from new gcc / glibc ???

emerge --info
Portage 2.1.1 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Pentium(R) D CPU 3.40GHz
Gentoo Base System version 1.12.5
Last Sync: Sat, 14 Oct 2006 16:50:01 +0000
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.2.3-r6, 2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.4.19, 2.6.17-r1
CFLAGS="-O2 -mcpu=i586 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /opt/glftpd/etc /opt/glftpd/ftp-data /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/service /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
FEATURES="autoconfig buildpkg ccache digest distlocks metadata-transfer noclean sandbox sfperms strict"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="X aalib accessibility acl acpi alsa apache apm arts audiofile avi berkdb bitmap-fonts bluetooth bonobo canna caps cdr cjk clamav cli crypt cups dga directfb divx4linux dlloader doc dri dvb dvd dvdr elibc_glibc emacs encode esd ethereal evms evo fam fastcgi fbcon firebird foomaticdb fortran freetds gb gd gdbm ggi gif ginac gnome gnutls gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile iconv imagemagick imap imlib innodb input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog java jpeg junit kde kerberos kernel_linux krb4 lcms ldap leim libedit libg++ libgda libwww linguas_de linguas_en lirc lvm2 mad mbox memlimit mhash mikmod mng motif mozilla mp3 mpeg msql mssql mule mysql mysqli nas ncurses nls nptl nptlonly oci8 odbc oggvorbis opengl oss pam pcntl pcre pdflib perl php pic png postgres ppds pppd prelude pwdb python qdbm qt quicktime readline reflection samba sasl scanner sdl session slang slp snmp socks5 spell spl ssl svga tcltk tcpd tetex theora tiff tokenizer truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vhosts video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo wmf wxwindows x86 xface xine xml2 xmlrpc xmms xorg xpm xv xvi yazd zeo zlib"
Comment 1 Michael Hoegler 2006-10-14 11:49:59 UTC
Created attachment 99669 [details]
kernelconfig + make.conf
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-10-14 11:51:55 UTC
So, how about recompiling your kernel (and all modules) w/ gcc-4.1.1 :)
Comment 3 Michael Hoegler 2006-10-15 08:04:57 UTC
(In reply to comment #2)
> So, how about recompiling your kernel (and all modules) w/ gcc-4.1.1 :)
thats what I did before posting to bugzilla.

kernel, modules were recompiled, new installed. then reboot and recompile of iptables. leads to the mentioned result.

I will right now recompile kernel+modules and iptables once more. Results will come in 2 hours ;-) 

Comment 4 Michael Hoegler 2006-10-15 11:24:52 UTC
recompiled kernel with iptables (compiled in kernel): OK
recompiled with iptables as modules: OK

so it must have been my fault. But i dont have any idea, what went wrong, cause kernel was compiled before with gcc 411.

sorry !
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-10-15 11:57:23 UTC
No problem, good that it works now. Thanks for reporting back.