Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 151116 - media-sound/alsa-utils-1.0.11 saves bad asound.state
Summary: media-sound/alsa-utils-1.0.11 saves bad asound.state
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 151111 (view as bug list)
Depends on:
Reported: 2006-10-13 01:16 UTC by Diamonte
Modified: 2006-10-13 16:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Diamonte 2006-10-13 01:16:38 UTC
Portage 2.1.1 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 Mobile AMD Sempron(tm) Processor 3200+
Gentoo Base System version 1.12.5
Last Sync: Mon, 09 Oct 2006 10:00:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
CFLAGS="-O2 -march=athlon-xp -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dnow 3dnowext X a52 aac aalib acpi alsa amrr anrr arts asf audiofile bash-completion berkdb bitmap-fonts bzip2 cdparanoia cdr cli cpudetection crypt css cups dbus dga divx dlloader dri dvd dvdr dvdread elibc_glibc encode ffmpeg flac fortran gdbm gif glitz glut gmp gnome gphoto2 gpm gtk gtk2 gtkhtml imagemagick input_devices_keyboard input_devices_mouse input_devices_synaptics irc isdnlog java javascript jpeg jpeg2k kde kernel_linux libg++ mad mjpeg mmap mmx mng mp3 mpeg mplayer ncurses network nls nptl nptlonly nsplugin ogg opengl oss pam pcre perl png ppds pppd python qt3 qt4 quicktime readline real reflection samba session sndfile spl sse sse2 ssl symlink tcl tcpd tiff timidity tk truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l v4l2 video_cards_fglrx video_cards_radeon vorbis wifi win32codecs xcomposite xine xml xmms xorg xvid yahoo zeroconf zlib"
Comment 1 Diamonte 2006-10-13 01:16:48 UTC
Ok this isn't really a bug for alsa-utils but I was told to put it here...

So,... This is about sound device:

00:14.2 Audio device: ATI Technologies Inc SB450 HDA Audio (rev 01)
        Subsystem: Acer Incorporated [ALI] Unknown device 009f
        Flags: bus master, slow devsel, latency 64, IRQ 18
        Memory at d0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-

...And the steps I had to take in order for it to work properly.
I was experiencing problems getting into alsamixer after i had booted.
first i unloaded alsa with the init script and reloaded them and got an error
having to do with a mixer control being invaild. so i removed the mixer settings.

rm /etc/asound.state
/etc/init.d/alsasound restart

now I can get into alsamixer and unmute it and turn the volumes up.
So i exit it seeing now the sound is working. But after a reboot, right when it hits alsa i get and error again complaining about control 11 being invaild.
So then again i removed /etc/asound.state and restarted alsa, umuted the card, 
turned the volume up and it workds again. Ok so then i edited /etc/init.d/alsasound and changed SAVE_ON_STOP="yes" to "no" then edit /etc/asound.state and took out the whole Control 11 block and saved the file. and now when i shut down the computer it doesn't save the mixer settings and screw up the new /etc/asound.state and now everytime i reboot my sound will work. Kind of a crappy fix but I guess I'll have to live with it for now.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-10-13 01:27:46 UTC
*** Bug 151111 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-10-13 01:30:54 UTC
First try with alsa 1.0.13 (need to upgrade all alsa ebuilds, not just alsa-utils). If it still doesn't work, file a bug upstream.
Comment 4 Diamonte 2006-10-13 02:18:03 UTC
I tried alsa 1.0.13, same thing.
Comment 5 Diamonte 2006-10-13 02:28:31 UTC
ok filed a bug with alsa
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-10-13 02:43:12 UTC
Can you please post the URL here so that we can track it?