Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 150333 - screen size reported incorrectly to wm in xinerama mode
Summary: screen size reported incorrectly to wm in xinerama mode
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-06 16:56 UTC by Carl Michal
Modified: 2007-12-22 14:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Michal 2006-10-06 16:56:15 UTC
If I login in text mode, and then start up a dual-head xinerama session
with startx (with XSESSION=Gnome in rc.conf), the window manager seems to be terribly confused about the size of the composite screen.  I can move the mouse everywhere, but I can't move windows into places.  I've tried this with both twm and metacity and they both show the same problem (started up metacity, then killed it to try twm).

If I just start the X server with: X at the console, either window manager behaves properly.  


Portage 2.1.1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-suspend2-r4 i686)
=================================================================
System uname: 2.6.17-suspend2-r4 i686 Intel(R) Pentium(R) M processor 1.73GHz
Gentoo Base System version 1.12.5
Last Sync: Fri, 06 Oct 2006 00:29:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS=""
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.iso88591"
LINGUAS=""
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X a52 aac acpi alsa apache2 asf berkdb bindist bitmap-fonts cdr cli commercial crypt cups divx4linux dlloader dri dts dv dvd dvdr dvdread elibc_glibc emacs emboss encode esd ffmpeg flac foomaticdb fortran gdbm gif gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 hal imlib input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_synaptics isdnlog jpeg kernel_linux libg++ libwww lirc mad mikmod mjpeg mmx mmxext motif mp3 mpeg ncurses network nls nptl nptlonly nsplugin ogg opengl oss pam pcre pdf perl png pppd python quicktime readline real reflection sdl session spell spl sse sse2 ssl tcltk tcpd theora tiff tk truetype truetype-fonts type1-fonts udev unicode userland_GNU userlocales video_cards_i810 video_cards_vesa vorbis win32codecs xinerama xml xmms xorg xv xvid xvmc zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Carl Michal 2006-10-06 17:08:31 UTC
Having tried a couple more things:  if the session is started from gdm, there is no problem.  

If XSESSION is set to Xsession, and started from startx there is no problem.

I only see this if XSESSION=Gnome, and it is started with startx.
Comment 2 Gilles Dartiguelongue gentoo-dev 2007-12-22 12:23:16 UTC
looks like this is a intel driver bug, which version is it ? (adding x11 herd, maybe they know something about this)
Comment 3 Rémi Cardona gentoo-dev 2007-12-22 14:01:44 UTC
Carl,

Do you still see that bug? If so, don't hesitate to reopen this bug with an up to date emerge --info and the version numbers for gdm, xorg-server and whatever video drivers you are using.

Thanks