Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 149977 - www-apps/trac: 0.10 needs different DEPEND for USE=postgres
Summary: www-apps/trac: 0.10 needs different DEPEND for USE=postgres
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Julien Allanos (RETIRED)
Depends on:
Reported: 2006-10-03 10:59 UTC by Tyler Berry
Modified: 2007-03-20 21:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Obvious patch to trac-0.10.ebuild (trac-0.10.ebuild-postgres.patch,82 bytes, patch)
2006-10-03 11:00 UTC, Tyler Berry
Details | Diff
Trimmed apache error log (error_log,5.72 KB, text/plain)
2006-10-04 10:38 UTC, Tyler Berry

Note You need to log in before you can comment on or make changes to this bug.
Description Tyler Berry 2006-10-03 10:59:47 UTC
Trac 0.10 uses dev-python/pypgsql to access Postgres databases instead of dev-python/psycopg. The documentation on the Trac wiki seems to suggest that either will work, but in fact Apache logged a lot of errors when psycopg was the only package installed of the two.
Comment 1 Tyler Berry 2006-10-03 11:00:26 UTC
Created attachment 98713 [details, diff]
Obvious patch to trac-0.10.ebuild
Comment 2 Julien Allanos (RETIRED) gentoo-dev 2006-10-03 12:20:57 UTC
Can you post or attach your Apache error log please?
Comment 3 Tyler Berry 2006-10-04 10:38:38 UTC
Created attachment 98784 [details]
Trimmed apache error log

This is the Apache log, trimmed; it starts at Apache startup and continues through two Python backtraces, then Apache shuts down.

The two backtraces are from two different reloads of the correct Trac URL.

The first backtrace fails trying to import from pypgsql. After installing pypgsql, the second backtrace requested that I run trac-admin to update the old Trac repository; I did so, and everything worked after that.
Comment 4 Julien Allanos (RETIRED) gentoo-dev 2007-03-08 22:16:37 UTC
Please, can you try with trac-0.10.1 or above ? I suspect the dev-python/psycopg dependency was wrong, and psycopg-2 should be used instead.
Comment 5 Tyler Berry 2007-03-20 19:04:37 UTC
You're 100% right. psycopg-2 works as expected. I assume this was just a transitory ~x86 on the new psycopg when I reported the bug.
Comment 6 Julien Allanos (RETIRED) gentoo-dev 2007-03-20 21:51:51 UTC
Then closing. I don't really see the benefit of offering the choice between psycopg-2 and pypgsql in the ebuild, via some kind of USE flag magic. I'll keep depending on psycopg-2.