Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 149586 - glibc-2.4-r4 failed building: multilib glibc for ABIs: x86 amd64
Summary: glibc-2.4-r4 failed building: multilib glibc for ABIs: x86 amd64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 149613 150191 (view as bug list)
Depends on:
Reported: 2006-09-30 00:26 UTC by Lars S. Jensen
Modified: 2006-10-05 11:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Log of emerge -uD --deep --nocolor sys-libs/glib (emerge-glibc.log,116.74 KB, text/plain)
2006-09-30 00:29 UTC, Lars S. Jensen

Note You need to log in before you can comment on or make changes to this bug.
Description Lars S. Jensen 2006-09-30 00:26:58 UTC
Portage 2.1.2_pre2 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.18-gentoo x86_64)
System uname: 2.6.18-gentoo x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.12.5
Last Sync: Sat, 30 Sep 2006 07:00:04 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=k8 -fomit-frame-pointer -msse3 -ftracer -fprefetch-loop-arrays -floop-optimize2 "
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=k8 -fomit-frame-pointer -msse3 -ftracer -fprefetch-loop-arrays -floop-optimize2 "
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
MAKEOPTS=" -j3 "
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/vmware /usr/portage/local/layman/science"
USE="amd64 X a52 aac acl acpi ada alsa ansi apache2 asf asterisk audiofile avi bash-completion berkdb bitmap-fonts blender-game bonobo bzip2 cairo canvas cddb cdr cli crypt cups curl cvs dbus dga divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi dynagraph eds elibc_glibc emacs emboss encode ethereal evo exif f77 fam fat ffmpeg firefox flac font-server foomaticdb fortran gb gd gdbm gif gimp gkthtml glibc-omitfp glut gnome gnutls gphoto2 gpm gs gstreamer gtk gtk2 gtkhtml guile hal hdf ieee1394 imagemagick imlib input_devices_aiptek input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_vmmouse ipv6 isdnlog java jce joystick jpeg jpeg2k kde kernel_linux lcms libg++ libwww lirc live lm_sensors lzo mad mikmod mng mono mozsvg mp3 mp4 mpeg mpi mplayer mudflap nautilus ncurses network nfs nls nntp no_wxgtk1 nptl nptlonly nsplugin nvidia objc objc++ objc-gc ogg openexr opengl pam pcre pdf pdflib perl pg-intdatetime plotutils png postgres povray ppds pppd python qt3 qt4 quicktime readline reflection reiserfs rtc scanner sdk server session smp snmp speex spell spl sql sse3 ssl subtitles subversion svg t1lib tcltk tcpd tetex theora tiff toolkit-scroll-bars transcode truetype truetype-fonts type1-fonts udev unicode usb userland_GNU utf8 v4l2 vdr video_cards_fbdev video_cards_nv video_cards_nvidia video_cards_v4l video_cards_vesa vorbis widescreen wmf wxwindows x264 xcomposite xfs xinerama xml xml2 xmms xorg xpm xprint xv xvid xvmc yv12 zlib"
Comment 1 Lars S. Jensen 2006-09-30 00:29:54 UTC
Created attachment 98429 [details]
Log of emerge -uD --deep --nocolor sys-libs/glib
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-09-30 00:48:01 UTC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.1/include -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h       -DHAVE_INITFINI -S -g0 -fPIC -fno-inline-functions -fno-unit-at-a-time -march=i386 -mtune=i386 -finhibit-size-directive \

You've been using eselect-compiler and unmerged it later on? Can you post gcc-config -l output?
Comment 3 Lars S. Jensen 2006-09-30 01:03:29 UTC
> You've been using eselect-compiler and unmerged it later on? 

gcc-config -l
 [1] x86_64-pc-linux-gnu-3.4.6
 [2] x86_64-pc-linux-gnu-3.4.6-hardened
 [3] x86_64-pc-linux-gnu-3.4.6-hardenednopie
 [4] x86_64-pc-linux-gnu-3.4.6-hardenednopiessp
 [5] x86_64-pc-linux-gnu-3.4.6-hardenednossp
 [6] x86_64-pc-linux-gnu-4.1.1 *
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-09-30 01:08:55 UTC
Can you try something like 

gcc-config 1 && gcc-config 6 && env-update && source /etc/profile 

and see if it helps?
Comment 5 Brent 2006-09-30 03:08:45 UTC
(In reply to comment #4)
> gcc-config 1 && gcc-config 6 && env-update && source /etc/profile 
Same thing here, and that fixed it.
Comment 6 Lars S. Jensen 2006-09-30 04:17:32 UTC
It fixed it.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-09-30 05:52:53 UTC
*** Bug 149613 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-10-05 11:17:52 UTC
*** Bug 150191 has been marked as a duplicate of this bug. ***