Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 149556 - portage should check environment before building world
Summary: portage should check environment before building world
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Other
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-29 12:55 UTC by Michael E Harris
Modified: 2006-09-29 12:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael E Harris 2006-09-29 12:55:02 UTC
From a discussion on the forums, a mod suggested a feature request for portage.  The thread is
http://forums.gentoo.org/viewtopic-t-502941.html

basically, i had an emerge world fail, during the process of updating profile and gcc, after 7 hours, because the current version of evas required the use flag png.  It would be nice if portage could check use flags and other environment factors (like required version of gcc/glibc, for example) for all packages about to be compile,  to make sure everything is sane before starting the world emerge.
Comment 1 Zac Medico gentoo-dev 2006-09-29 12:59:26 UTC
Until bug 2272 has been fixed, we use built_with_use from the eutils eclass.  Portage already does non USE-based dependency checking.

*** This bug has been marked as a duplicate of 2272 ***