Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 148675 - x11-wm/compiz displays a white cube (i915)
Summary: x11-wm/compiz displays a white cube (i915)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-22 10:40 UTC by Rémi Cardona
Modified: 2006-10-03 10:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2006-09-22 10:40:35 UTC
topic says it all, compiz worked fine (first version from portage), then I don't know what changed, it started displaying a white (but fully functionnal) cube instead of application textures. Alt-tab shows the app icons though.

I upgraded to the latest compiz, still the same bug. The laptop is an Intel Pentium-M, using x11-drm from portage, i915 for DRI and i810 for xorg.

Other opengl apps (my own 3D app) and Quake 3 still work fine though.
Comment 1 Gilles Dartiguelongue gentoo-dev 2006-09-22 13:56:58 UTC
maybe unrelated, but I got a similiar result with metacity with compositor activated (hanno-xgl overlay). It happens with latest libcm/metacity from the overlay. Symptoms are accelerated shadows and some other effects of metacity+libcm but the space where the app should appear is just empty.

Pentium III, x11-drm, i830

compiz is working fine for the moment but is not up to date, so I'll post again when I'll upgrade it.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-09-22 17:33:35 UTC

*** This bug has been marked as a duplicate of 148720 ***
Comment 3 Rémi Cardona gentoo-dev 2006-09-28 02:13:29 UTC
Snapshot 20060928 didn't fix this bug (I don't have any nvidia), reopening.
Comment 4 Hanno Böck gentoo-dev 2006-09-28 02:32:23 UTC
jakub, I don't know how you came to the idea this is a dup of 148720 - it's a completely different problem.

Remi and others: The problem with the white cube usually occurs if you're mesa, xorg-server and compiz tfp opcodes are out of sync, which means you've compiled them with different versions of glproto.
Updating glproto to 1.4.8 and recompiling those three should fix it. Can you try this?
Comment 5 Rémi Cardona gentoo-dev 2006-09-28 09:56:59 UTC
thanks hanno, this fixed the white cube problem. However, gtk-window-decorator isn't decorating much ... it looks like it's running, but nothing appears around the windows. I'll try to confirm this on my desktop.
Comment 6 Hanno Böck gentoo-dev 2006-10-03 10:36:50 UTC
whitecube-problem fixed.