Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 148526 - ldap USE-flag not showing correctly for dev-libs/apr-util-0.9.12
Summary: ldap USE-flag not showing correctly for dev-libs/apr-util-0.9.12
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Depends on:
Reported: 2006-09-21 08:54 UTC by William L. Thomson Jr. (RETIRED)
Modified: 2006-09-21 10:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description William L. Thomson Jr. (RETIRED) gentoo-dev 2006-09-21 08:54:39 UTC
It might have been a quirk from when I used to use the ldap USE flag on this system. However I was doing an update, where I needed to update mod_jk. I have -ldap in my global use flags in /etc/make.conf. For some reason it was showing the USE flag as being enabled, and portage wanted to pull in ldap for apr-util. I went one step further and added dev-libs/apr-util -ldap to /etc/portage/package.use. It was still showing USE flag ldap enabled. Finally I tried USE="-ldap" emerge -pvapr-util and it was disabled. Now that I have it disabled and recompiled that package. It's no longer showing it enabled, as it should.

Not sure about all this oddness. Could be a local quirk on the system or a larger problem. Filling this bug per the request of vericgar. Let me know if you need more info or etc.

Version of portage in use at the time is 2.1.2_pre1. Let me know if you want emerge --info. Not sure it's to relevant atm.
Comment 1 Michael Stewart (vericgar) (RETIRED) gentoo-dev 2006-09-21 09:16:22 UTC
Hmm, you are meaning the display of USE-flags before the package is even built? I thought you were meaning that apr-util was still using ldap even though the ldap USE-flag is off.

Can you paste the output of emerge --verbose --pretend apr-util?
Comment 2 William L. Thomson Jr. (RETIRED) gentoo-dev 2006-09-21 09:37:58 UTC
You are thinking correctly. ldap USE flag was showing turned on, and showing up as a dep, despite the flag being off. Now I can't replicate this once I recompiled apr-util with -ldap. Maybe if I compile it again with ldap, I can reproduce.

This seems to be one of the last packages that had compiled in ldap support from when I was experimenting with the use flag. Some time ago. However I have had -ldap in make.conf for a few months now. So not sure how it was remaining on for this one package. All other packages stopped using ldap flag when I disabled it or turned it off.

dev tomcat # emerge --verbose --pretend apr-util

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/apr-util-0.9.12  USE="berkdb gdbm -ldap" 0 kB

Now it's showing correctly since I have recompiled less that flag. But before despite -ldap in make.conf, and -ldap in /etc/portage/package.use for the package. It was still showing
[ebuild   R   ] dev-libs/apr-util-0.9.12  USE="berkdb gdbm ldap" 0 kB

Not sure if I can replicate that. I can try if you like. I am not sure if the problem if I can reproduce it has anything to do with apr-utils. That's just the one package I noticed it on. Since ldap failed to compile, and i was trying to update a few other things I worked on recently.
Comment 3 Michael Stewart (vericgar) (RETIRED) gentoo-dev 2006-09-21 09:47:27 UTC
So, if anything it was a portage issue. I'll let them decide if they want you to try to reproduce or not.
Comment 4 William L. Thomson Jr. (RETIRED) gentoo-dev 2006-09-21 10:10:06 UTC
Yes I agree it's more portage related than package specific.
Comment 5 Zac Medico gentoo-dev 2006-09-21 10:53:03 UTC
Please reopen if you are able to reproduce this.
Comment 6 Marius Mauch (RETIRED) gentoo-dev 2006-09-21 10:55:02 UTC
Sounds like you had USE=ldap defined in your environment somehow. Unless you can reproduce this I'm not going to worry about it.