Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146939 - [GCC 4.1] stabilize net-analyzer/iptraf-3.0.0-r2
Summary: [GCC 4.1] stabilize net-analyzer/iptraf-3.0.0-r2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 147241 (view as bug list)
Depends on: 144205
Blocks: gcc41-stable
  Show dependency tree
 
Reported: 2006-09-09 04:55 UTC by kristian meier
Modified: 2006-10-16 15:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,3.79 KB, text/plain)
2006-09-16 01:58 UTC, Onkobu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kristian meier 2006-09-09 04:55:16 UTC
#emerge info
Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r6 i686)
=================================================================
System uname: 2.6.16-gentoo-r6 i686 Mobile AMD Athlon(tm) XP 2600+
Gentoo Base System version 1.12.4
Last Sync: Sat, 09 Sep 2006 01:54:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-mp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-mp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/ ftp://213.186.33.38/gentoo-distfiles/ ftp://213.186.33.37/gentoo-distfiles/"
LC_ALL="en_US.UTF-8"
LINGUAS=""
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/webapps-experimental /usr/portage/local/layman/java-migration-packages /usr/portage/local/layman/java-gcj-overlay /usr/portage/local/layman/java-experimental /usr/portage/local/layman/initng /usr/portage/local/layman/gnome-experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X accessibility acpi alsa apache2 avi bitmap-fonts cairo cdr cli crypt dbus dlloader dri dvd dvdr eds elibc_glibc emacs emboss encode fam firefox gdbm gif gnome gpm gstreamer gtk gtk2 hal input_devices_keyboard input_devices_mouse input_devices_synaptics ipv6 isdnlog jikes jpeg kernel_linux libg++ mad mikmod minimal mmx mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg opengl oss pam pcre pdflib png ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl sse ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU userlocales video_cards_vesa video_cards_via vorbis win32codecs xml xmms xorg xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 kristian meier 2006-09-09 04:58:30 UTC
# emerge -v iptraf
....

othptab.c: In function 
Comment 2 kristian meier 2006-09-09 04:58:30 UTC
# emerge -v iptraf
....

othptab.c: In function printothpentry:
othptab.c:598: error: ICMP6_DST_UNREACH_NOTNEIGHBOR undeclared (first use in this function)
othptab.c:598: error: (Each undeclared identifier is reported only once
othptab.c:598: error: for each function it appears in.)
othptab.c:630: error: ICMP6_MEMBERSHIP_QUERY undeclared (first use in this function)
othptab.c:633: error: ICMP6_MEMBERSHIP_REPORT undeclared (first use in this function)
othptab.c:636: error: ICMP6_MEMBERSHIP_REDUCTION undeclared (first use in this function)
make: *** [othptab.o] Error 1

!!! ERROR: net-analyzer/iptraf-2.7.0-r1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  iptraf-2.7.0-r1.ebuild, line 40:   Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


this happens after I switch to gcc-4.1.1, during emerge -e world and persists ever since.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-09-09 05:01:45 UTC
Way too old, try w/ 3.0.0-r2 please.
Comment 4 kristian meier 2006-09-09 05:11:38 UTC
(In reply to comment #2)
> Way too old, try w/ 3.0.0-r2 please.
> 

bingo, that's works
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-09-09 05:19:42 UTC
Thanks, we should stabilize a new version.
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-09-11 16:18:35 UTC
*** Bug 147241 has been marked as a duplicate of this bug. ***
Comment 7 Onkobu 2006-09-16 01:58:07 UTC
Created attachment 97128 [details]
emerge --info
Comment 8 Onkobu 2006-09-16 01:59:03 UTC
(In reply to comment #6)
> Created an attachment (id=97128) [edit]
> emerge --info
> 

Forgot text: ~x86 works for me, too. Stabilize newer one, plz
Comment 9 tomas charvat 2006-09-18 01:49:43 UTC
It has happen after latest stable linux-headers-2.6.17-r1

                 from tcptable.h:9,
                 from othptab.c:24:
/usr/include/sys/types.h:62: error: conflicting types for 'dev_t'
/usr/include/linux/types.h:27: error: previous declaration of 'dev_t' was here
/usr/include/sys/types.h:72: error: conflicting types for 'mode_t'
/usr/include/linux/types.h:33: error: previous declaration of 'mode_t' was here
/usr/include/sys/types.h:77: error: conflicting types for 'nlink_t'
/usr/include/linux/types.h:36: error: previous declaration of 'nlink_t' was here
In file included from /usr/include/sys/types.h:133,
                 from /usr/include/stdlib.h:438,
                 from tcptable.h:9,
                 from othptab.c:24:
/usr/include/time.h:105: error: conflicting types for 'timer_t'
/usr/include/linux/types.h:45: error: previous declaration of 'timer_t' was here
In file included from /usr/include/sys/types.h:220,
                 from /usr/include/stdlib.h:438,
                 from tcptable.h:9,
                 from othptab.c:24:
/usr/include/sys/select.h:78: error: conflicting types for 'fd_set'
/usr/include/linux/types.h:24: error: previous declaration of 'fd_set' was here
In file included from /usr/include/stdlib.h:438,
                 from tcptable.h:9,
                 from othptab.c:24:
/usr/include/sys/types.h:235: error: conflicting types for 'blkcnt_t'
/usr/include/linux/types.h:158: error: previous declaration of 'blkcnt_t' was here
make: *** [othptab.o] Error 1
make: Leaving directory `/var/tmp/portage/iptraf-3.0.0-r2/work/iptraf-3.0.0/src'

!!! ERROR: net-analyzer/iptraf-3.0.0-r2 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  iptraf-3.0.0-r2.ebuild, line 53:   Called die


INFO

Portage 2.1.1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-hardened-r11 i686)
=================================================================
System uname: 2.6.16-hardened-r11 i686 AMD Athlon(TM) XP 2000+
Gentoo Base System version 1.12.5
Last Sync: Mon, 18 Sep 2006 08:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -mtune=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 Maildir apache2 apm berkdb bitmap-fonts cli crypt dlloader dri eds elibc_glibc emboss encode foomaticdb fortran gdbm gencertdaily gif gnome gpm gstreamer gtk2 hardened imlib input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog jpeg kde kernel_linux libg++ libwww mad mikmod motif mpeg ncurses nls nptl nptlonly ogg pam pcre perl perlsuid png pppd python qmail qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd tls truetype truetype-fonts type1-fonts udev userland_GNU video_cards_apm video_cards_ark video_cards_ati video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_fbdev video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_imstt video_cards_mga video_cards_neomagic video_cards_nsc video_cards_nv video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo xml xmms xorg zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 10 Christian Faulhammer (RETIRED) gentoo-dev 2006-09-27 02:21:28 UTC
bug #144205 addresses the linux-headers issue and has patches
Comment 11 Markus Ullmann (RETIRED) gentoo-dev 2006-10-10 06:57:15 UTC
As the related compile bug is fixed now, we go for stabilizing and drop 2.7.0 afterwards.

Targets:
alpha
amd64
hppa
mips
ppc64
sparc
x86
Comment 12 Christian Faulhammer (RETIRED) gentoo-dev 2006-10-10 07:11:16 UTC
[ebuild  N    ] net-analyzer/iptraf-3.0.0-r2  USE="ipv6 -suid"

1) emerges fine
2) passes collision test
3) works

Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
=================================================================
System uname: 2.6.17-gentoo-r8 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.12.5
Last Sync: Tue, 10 Oct 2006 05:20:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.informatik.rwth-aachen.de/gentoo-portage"
USE="x86 3dnow 3dnowext X Xaw3d a52 alsa artworkextra asf audiofile bash-completion beagle berkdb bidi bitmap-fonts bootsplash branding bzip2 cairo cdda cddb cdparanoia cdr cli cracklib crypt css cups curl custom-cflags dbus dga directfb divx4linux dlloader dri dts dvd dvdr dvdread dvi eds elibc_glibc emacs emboss encode esd evo exif expat fam fat fbcon ffmpeg firefox fortran ftp gb gcj gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml hal icq idn imagemagick imap input_devices_keyboard input_devices_mouse ipv6 isdnlog java javascript jikes jpeg jpeg2k kde kernel_linux ldap leim libg++ linguas_de lm_sensors mad maildir matroska mbox mhash mikmod mime mmx mmxext mng mono mp3 mpeg mpeg2 mule nautilus ncurses nforce2 nls nocardbus nptl nptlonly nsplugin nvidia objc ogg opengl pam pcre pdf perl plotutils pmu png ppds pppd preview-latex print python qt3 qt4 quicktime readline reflection reiserfs samba sdk session slang spell spl sse ssl svg svga t1lib tcltk tcpd tetex theora thunderbird tiff truetype truetype-fonts type1-fonts udev usb userland_GNU vcd video_cards_fbdev video_cards_radeon video_cards_vesa videos vorbis win32codecs wmf wxwindows xine xml xorg xosd xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 13 Gustavo Zacarias (RETIRED) gentoo-dev 2006-10-10 11:54:47 UTC
sparc stable.
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2006-10-10 14:39:53 UTC
amd64/x86 stable
Comment 15 Jeroen Roovers (RETIRED) gentoo-dev 2006-10-10 14:47:24 UTC
Stable for HPPA.
Comment 16 Markus Rothe (RETIRED) gentoo-dev 2006-10-11 12:19:18 UTC
ppc64 stable
Comment 17 Jose Luis Rivero (yoswink) (RETIRED) gentoo-dev 2006-10-16 15:13:51 UTC
alpha stable.

FIXED stable on all supported arches.