Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146869 - Can't unmerge jext-3.2_pre3
Summary: Can't unmerge jext-3.2_pre3
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-08 12:40 UTC by Christian Marker
Modified: 2006-09-10 04:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Original EBuild (jext-3.2_pre3.ebuild,1.24 KB, text/plain)
2006-09-09 04:14 UTC, Christian Marker
Details
Without line 27 (jext-3.2_pre3.ebuild-workaround,1.09 KB, text/plain)
2006-09-09 04:16 UTC, Christian Marker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Marker 2006-09-08 12:40:00 UTC
# emerge --unmerge jext

 app-editors/jext
    selected: 3.2_pre3
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging app-editors/jext-3.2_pre3...
No package files given... Grabbing a set.

QA Notice: ECLASS 'java-pkg' inherited illegally in app-editors/jext-3.2_pre3


QA Notice: ECLASS 'multilib' inherited illegally in app-editors/jext-3.2_pre3

/var/db/pkg/app-editors/jext-3.2_pre3/jext-3.2_pre3.ebuild: line 27: unexpected EOF while looking for matching `"'
/var/db/pkg/app-editors/jext-3.2_pre3/jext-3.2_pre3.ebuild: line 40: syntax error: unexpected end of file

!!! ERROR: app-editors/jext-3.2_pre3 failed.
Call stack:
  ebuild.sh, line 1447:   Called die

!!! error sourcing ebuild
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! FAILED prerm: 1

# cat /var/db/pkg/app-editors/jext-3.2_pre3/jext-3.2_pre3.ebuild | head -n 27 | tail -n 1

sed -e s:'<property name="classpath" value="" />':"<property name='classpath' value='`java-config --classpath=jython`' />": build.xml > tmp.xml

Can anyone guide me through this quoting hell here? :-) What do I have to change in this line?
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-08 12:43:40 UTC
Just delete the broken lines. Nothing we could fix here.
Comment 2 Josh Nichols (RETIRED) gentoo-dev 2006-09-08 12:46:54 UTC
This is actually related to a bug in java-config-2 that we've observed.
Comment 3 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2006-09-08 12:50:19 UTC
just to be sure, what's the output of this?:
java-config --classpath=jython

Of course you can use the workaround of deleting that line to get rid of the package meanwhile.
Comment 4 Christian Marker 2006-09-09 04:14:58 UTC
Created attachment 96466 [details]
Original EBuild
Comment 5 Christian Marker 2006-09-09 04:16:56 UTC
Created attachment 96467 [details]
Without line 27
Comment 6 Christian Marker 2006-09-09 04:18:42 UTC
I tried the workaround, but emerge still complains about missing quotes at another line:

# emerge --unmerge jext

 app-editors/jext
    selected: 3.2_pre3
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging app-editors/jext-3.2_pre3...
No package files given... Grabbing a set.

QA Notice: ECLASS 'java-pkg' inherited illegally in app-editors/jext-3.2_pre3


QA Notice: ECLASS 'multilib' inherited illegally in app-editors/jext-3.2_pre3

/var/db/pkg/app-editors/jext-3.2_pre3/jext-3.2_pre3.ebuild: line 21: unexpected EOF while looking for matching `"'
/var/db/pkg/app-editors/jext-3.2_pre3/jext-3.2_pre3.ebuild: line 39: syntax error: unexpected end of file

!!! ERROR: app-editors/jext-3.2_pre3 failed.
Call stack:
  ebuild.sh, line 1447:   Called die

!!! error sourcing ebuild
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! FAILED prerm: 1

The output of "java-config --classpath=jython" is:
# java-config --classpath=jython
/usr/share/jython/lib/jython.jar
Comment 7 Christian Marker 2006-09-09 04:31:02 UTC
I just found out that the problem was not caused by line 27, but line 20, where the final quote sign was accidently "^A". After changing this, jext unmerges correctly.
Comment 8 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2006-09-10 04:04:18 UTC
Ah, so java-config wasn't the cause. The ebuild probably must have been broken at some point of time. Sorry for the inconvenience.