Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146608 - Grub error collection missing "Grub Hard Disk Error" failure.
Summary: Grub error collection missing "Grub Hard Disk Error" failure.
Alias: None
Product: [OLD] Docs on
Classification: Unclassified
Component: Other documents (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Docs Team
: 146742 146770 (view as bug list)
Depends on:
Reported: 2006-09-06 14:24 UTC by arthur_torrey
Modified: 2006-10-06 02:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

process for creating GRUB boot floppies as workaround for failure (grub_floppy_procedure,5.94 KB, text/plain)
2006-09-23 18:50 UTC, arthur_torrey

Note You need to log in before you can comment on or make changes to this bug.
Description arthur_torrey 2006-09-06 14:24:34 UTC
I am attempting an install on a new box.  After completing all steps in the guide (including installing Grub w/ grub-install) I attempt to reboot, and remove the live cd.

I get a message "GRUB Hard Disk Error"

According to the GNU Grub manual, this means:
"The stage2 or stage1.5 is being read from a hard disk, and the attempt to determine the size and geometry of the hard disk failed."

As far as I can tell, the hard drive is working properly. It is recognized correctly in the BIOS (IDE1, master drive, and the correct drive make / model, etc), the boot order is correct, and the system has booted correctly into DOS off the hard drive. (I do a quick install of DOS into a very small first partition as part of my hardware testing procedure when I built the box)

There is nothing about this error in the Gentoo GRUB Error Collection document that I can find. The forum sticky on Grub errors pointed at this document and suggested filing a bug on any error not covered....

So far I haven't found a cure.  I have been going through the forum sticky searching for one, and experimenting with other things as ideas come to me.  If I find a cure, I will update this.


I am currently searching for a
Comment 1 nm (RETIRED) gentoo-dev 2006-09-07 13:29:47 UTC
*** Bug 146742 has been marked as a duplicate of this bug. ***
Comment 2 arthur_torrey 2006-09-07 18:57:08 UTC
*** Bug 146770 has been marked as a duplicate of this bug. ***
Comment 3 arthur_torrey 2006-09-07 20:11:20 UTC
see discussion in forum thread here:

As mentioned in that thread, I have found that I can boot the system off a minimal grub floppy, and then start my system from the command line specifying the hard drive's /boot partition and kernel.

This suggests to me that there is something problematic about the way the hard drive is fdisked or formatted, which certainly falls within the scope of this document's coverage.
Comment 4 nm (RETIRED) gentoo-dev 2006-09-07 21:21:07 UTC
(In reply to comment #3)
Judging by the comments in that thread, it looks more like this is a case of user error than a problem with grub itself or something that needs to be added to the docs. But we'll wait for another few days and see where this goes.
Comment 5 arthur_torrey 2006-09-10 18:26:19 UTC
Josh, as the submitter, I won't deny the possibility of this being a user error induced problem, but it is certainly a real bug - the error message IS in the GNU GRUB manual, (but not any suggestions about how to fix it) and there is nothing about it in the Gentoo document. 

It has so far proven very resistant to attempts at finding (and fixing) the error, whatever it is.

If it is a user error, I'd love to know what it is, but so far I haven't seen anything that gives me a solution that works.

I also don't think that "user error" is a good reason to close this particular bug, as it looks to me like most of the existing document could best be described as a list of user errors, as identified by the Grub error message, and how to fix them.  If "Grub Hard Disk Error" is caused by a user error, saying what the error is and how to fix it certainly fits the nature of the Grub Error Collection.

ART / Gooserider
Comment 6 Xavier Neys (RETIRED) gentoo-dev 2006-09-17 04:59:07 UTC
Not much we can do about this. You don't know exactly what the problem and solution are. is not terribly useful either.
Comment 7 arthur_torrey 2006-09-20 10:59:48 UTC
I have found an ugly but functional cure of sorts.  After ruling out obvious broken hardware problems, I tried manually booting grub off a floppy.  This worked, no problem other than the nusiance of having to do the manual boot sequence.

I then followed the directions in this article to create a full grub floppy, including copying over my grub.conf file (renamed to menu.lst) and the splash image file.  The result is a system that initially boots into grub off the floppy drive, displays a grub menu (with splash image) and then boots the selected option off the hard drive.

I don't LIKE this fix, but it does work...

I haven't experimented, but it seems that it might be possible to create an analagous grub boot CD for those folks that don't have floppy drives.

Comment 8 nm (RETIRED) gentoo-dev 2006-09-20 11:39:36 UTC
(In reply to comment #7)
We won't do the work for you -- do you have a procedure written down that we can guidexml-ize (perhaps)?

We really don't like copying and pasting someone else's work that's been done on another site (the reference).
Comment 9 arthur_torrey 2006-09-23 18:50:49 UTC
Created attachment 97911 [details]
process for creating GRUB boot floppies as workaround for failure
Comment 10 arthur_torrey 2006-09-23 18:52:42 UTC
I did a bit of a write-up which tries to describe the problem, and does a re-work of the process for creating a boot floppy.  Some of the info comes from the article I cited earlier in this bug, more of it comes from the Gentoo Wiki article here <> (which I edited to add the optional step of putting on the grub.conf/menu.lst file)  I also cited the Official GNU GRUB documentation, I think that one is OK to point people at.

I am (hopefully) attaching my writeup as a separate file, it is a text file created with KDE's KATE editor  I'm sure you will need to reformat it to look like the rest of the Gentoo docs, If needed you may edit appropriately as well.
Hope this is what you had in mind.

Gooserider / ART
Comment 11 nm (RETIRED) gentoo-dev 2006-09-28 05:01:53 UTC
(In reply to comment #10)
Except that you're no closer to a real solution than you were at the beginning, nor do you yet understand the nature of the problem.

We can't just tell users "when all else fails, try this". We have to know what the problem is, rather than just throw an admittedly ugly hack it it. A doctor doesn't say, "Damn, this patient is screwed up" and then "fix" him by throwing a cornucopia of drugs at him. He has to first figure out what the problem is before treating the symptom.

In your own words, in your thread(s) on the forums, you admit that you probably messed up the partitioning and formatting of your disks -- and that falls outside of the boundaries of the Grub guide (not a Grub configuration error).

We cannot recommend blind fixes like this in good conscience.
Comment 12 arthur_torrey 2006-10-02 21:28:42 UTC
I have kept picking at the problem and eventually I did find a solution that worked for me.  It was NOT a "user induced" problem, as the issue turned out not to be directly under my control.

I found the BIOS revision level on my motherboard was fairly early (Rev F2, latest was Rev. F11) and tonight I just finished upgrading the BIOS to the newest version.  When I did so, the problem disappeared, and the system now boots off the hard drive into grub just the way that it should.  I don't know just which upgrade step solved the issue as I didn't test each one, and the descriptions on the files didn't seem directly applicable to my problem.  In any case any such description would be specific to only my hardware combination.

Thus I would revise my recommended fix steps as follows.

1. Explanation - Quote from the GRUB manual, The system is finding a boot drive, and starting to booot, but due to some hardware incompatibility is unable to finish loading GRUB.

2. Fix
 A. Verify your hardware and BIOS settings.  If your BIOS permits it, make sure it uses LBA addressing on the hard drive, preferably with manual configuration. (use the same numbers the auto detection routine comes up with) Make sure the hardware is properly connected, etc.  Doing the minimal grub floppy boot test MAY be useful at this point to verify that the hardware is otherwise OK, and that the install is doing what it should.

 B. Go to the manufacturers websites and / or contact tech support (your own investigation is likely to be more useful!) and verify that your BIOS versions are the latest available.  If not, upgrade to the latest version, see if that fixes the problem.  The exact procedure for this will vary, and MAY require either some version of that other O/S or some convoluted file manipulations in Linux, good luck!

 C. IF it does not, then the last resort ugly methods are all that's I know of that is left.  I agree with you that the boot floppy is an ugly thing, but it DOES lead to a system that is useable.  A doctor tries very hard to figure out what is wrong with a patient, but if he can't he at least will throw things at trying to treat the symptoms in hopes of providing relief in the meantime.

Incedentally, I suspect that the minimal grub boot floppy might be helpful in solving other problems.  Most systems are only going to have one floppy, which can be made to boot first reliably.  That then allows the user to try finding where his boot stuff really is by doing tab-completion on the GRUB command line, and possibly finding that GRUB sees the system differently from what the user thinks it is...

ART / Gooserider
Comment 13 nm (RETIRED) gentoo-dev 2006-10-03 09:17:41 UTC
(In reply to comment #12)
"I needed to update my BIOS" is not a Grub problem, sorry. This fix still doesn't fit the bill -- there's no reasonable way to accommodate it within the doc. I mean, how does it sound: "If your system is utterly and completely b0rked, try this random 'solution' and hope to hell it has something to do with your problem."

Not gonna fly. Rather than tell users to go through an amazingly convoluted series of steps *outside Gentoo* to get the disk, users should just go outside of Gentoo solutions once, to their motherboard manufacturer, and flash their BIOS. How to do this was actually mentioned in a recent GWN (within the last month).
Comment 14 nm (RETIRED) gentoo-dev 2006-10-03 09:18:00 UTC