Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 144694 - gnome-base/libbonoboui-2.14.0: sandbox violation during test phase
Summary: gnome-base/libbonoboui-2.14.0: sandbox violation during test phase
Status: RESOLVED DUPLICATE of bug 107700
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-21 14:46 UTC by Abraham Marin Perez
Modified: 2006-08-22 00:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Access violation log file (sandbox-gnome-base_-_libbonoboui-2.14.0-7421.log,33 bytes, text/plain)
2006-08-21 14:47 UTC, Abraham Marin Perez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Abraham Marin Perez 2006-08-21 14:46:05 UTC
When trying to install libbonoboui a sandbox access violation occurred during the test phase; aparently it checks whether it can modify config files in $HOME directory. Error message was:

ACCESS DENIED  chmod:     /root/.gnome2_private
Could not set mode 0700 on private per-user gnome configuration directory `/root/.gnome2_private/': Permission denied
FAIL: test-ui-auto
===================
1 of 1 tests failed
===================


*****************
emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.5-r2, 2.6.17-gentoo-r4 i686)
=================================================================
System uname: 2.6.17-gentoo-r4 i686 AMD Athlon(tm)
Gentoo Base System version 1.6.15
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.8.1-r1, 2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon-xp"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=athlon-xp"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict test"
GENTOO_MIRRORS="http://linuv.uv.es/mirror/gentoo/ http://ftp.caliu.info/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LINGUAS="es en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 acpi alsa apache2 asf audiofile avi bash-completion bidi bitmap-fonts bzip2 bzlib canna cdr cjk cli crypt cups dbus dga directfb divx4linux dlloader doc dri dvb dvd dvdr dvdread eds emboss encode esd evo exif fbcon fftw firefox flac foomaticdb freewnn ftp gb gcj gd gdbm gif gmp gnome gpm gstreamer gtk gtk2 gtkhtml hal iconv imlib iodbc isdnlog java jikes jpeg kde libg++ libwww mad memlimit mikmod mime mmx motif mozilla mp3 mpeg msn nas nls nptl nsplugin nvidia odbc offensive ogg oggvorbis openal opengl pam pcre pdflib perl png pnp posix ppds pppd qt3 qt4 quicktime readline reflection samba sdl session sharedmem simplexml spell spl ssl svg svga sysvipc szip tcltk tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales videos vorbis win32codecs wmf x86 xine xml xmms xorg xprint xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux linguas_es linguas_en userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Abraham Marin Perez 2006-08-21 14:47:40 UTC
Created attachment 94807 [details]
Access violation log file

This is the log file of the access violation, the whole summary is:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-gnome-base_-_libbonoboui-2.14.0-7421.log"

chmod:     /root/.gnome2_private
--------------------------------------------------------------------------------
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-08-22 00:18:08 UTC

*** This bug has been marked as a duplicate of 107700 ***