Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 144623 - stabilize media-gfx/gimp-print-5.1.x and rename to gutenprint
Summary: stabilize media-gfx/gimp-print-5.1.x and rename to gutenprint
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Printing (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Alpha Porters
URL:
Whiteboard:
Keywords: STABLEREQ
: 150161 202990 (view as bug list)
Depends on: 203382
Blocks:
  Show dependency tree
 
Reported: 2006-08-21 04:19 UTC by Daniel Herzog
Modified: 2008-04-05 20:57 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Herzog 2006-08-21 04:19:53 UTC
One should rename gimp-print-5 to gutenprint, and make gimp-print-5 a metapackage which doesnt do anything but has gutenprint-ebuild as dependency

see project website, it has been renamed.
Comment 1 Colin Macdonald 2006-08-29 14:10:17 UTC
See bug #143248, comment #3.  Should be resolved "LATER".
Comment 2 Stefan Schweizer (RETIRED) gentoo-dev 2006-08-30 17:57:09 UTC
yeah, I will do it later to allow a smooth migration.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-10-05 06:43:05 UTC
*** Bug 150161 has been marked as a duplicate of this bug. ***
Comment 4 Christian Faulhammer (RETIRED) gentoo-dev 2007-06-15 10:49:54 UTC
(In reply to comment #2)
> yeah, I will do it later to allow a smooth migration.

 Any timeframe on this?
Comment 5 Stefan Schweizer (RETIRED) gentoo-dev 2007-06-19 07:32:55 UTC
gimp-print used to provide the print plugin for gimp. Now from gimp-2.3 onwards gimp includes its own plugin. When renaming I want to catch all current users by removing gimp-print-4*

That can only happen with stable versions. Currently I am waiting for either gimp-2.3 getting stabled (unlikely) or gimp-2.4 released and stabled. After that gimp-print-5* needs to be stabled and -4* removed. When that is done I can easily just change the name without breaking anything or having two names :)
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-12-22 08:50:45 UTC
*** Bug 202990 has been marked as a duplicate of this bug. ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-12-22 09:09:57 UTC
hanno - is gimp-2.4.x ready for get stabilized, or?
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-12-26 15:43:56 UTC
Reopen...
Comment 9 Christian Faulhammer (RETIRED) gentoo-dev 2008-02-05 08:30:37 UTC
(In reply to comment #5)
> That can only happen with stable versions. Currently I am waiting for either
> gimp-2.3 getting stabled (unlikely) or gimp-2.4 released and stabled. After
> that gimp-print-5* needs to be stabled and -4* removed. When that is done I can
> easily just change the name without breaking anything or having two names :)

 Let's get going.
Comment 10 Jonathan 2008-03-16 22:02:43 UTC
Anytime frame on this yet? Is 5.1.4 stable enough for me to use?
Comment 11 Stefan Schweizer (RETIRED) gentoo-dev 2008-03-21 09:00:11 UTC
Please stabilize 5.1.4
Comment 12 Ferris McCormick (RETIRED) gentoo-dev 2008-03-21 15:55:04 UTC
Sparc stable, gimp can print an image using the "Print with Gutenprint" option.  Note, however, that I don't have any printer which is the exact model of any that Gutenprint supports.  So I had to lie to it to get it to print to anything.
(I have an HP4 SIMX, which is not quite HP4 SI, and a Xerox DocuPrint 2125n.  I can get it to print on the Xerox by giving it a random xerox docuprint model.)
Comment 13 Markus Meier gentoo-dev 2008-03-21 17:29:51 UTC
amd64/x86 stable
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2008-03-21 18:45:57 UTC
no mips stable.
Comment 15 Brent Baude (RETIRED) gentoo-dev 2008-03-22 15:42:30 UTC
ppc64 done
Comment 16 Tobias Scherbaum (RETIRED) gentoo-dev 2008-03-23 12:44:16 UTC
According to a thread in the Gentoo Forums this needs emake -j1.

https://forums.gentoo.org/viewtopic-t-679010.html

stefan, please advise.
Comment 17 Raúl Porcel (RETIRED) gentoo-dev 2008-03-24 15:37:48 UTC
ia64 stable
Comment 18 Brent Baude (RETIRED) gentoo-dev 2008-03-26 01:57:02 UTC
ppc done
Comment 19 Jeroen Roovers gentoo-dev 2008-03-27 23:11:33 UTC
Stable for HPPA.
Comment 20 Stefan Schweizer (RETIRED) gentoo-dev 2008-04-05 13:54:24 UTC
moved to net-print/gutenprint now. Alpha needs to add his stable keywords still!
Comment 21 Tobias Klausmann gentoo-dev 2008-04-05 20:57:52 UTC
Stable on alpha, closing.