Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 143469 - Portage does not intelligently resolve dependencies when run with --update
Summary: Portage does not intelligently resolve dependencies when run with --update
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-10 08:27 UTC by Ben Tucker
Modified: 2006-08-10 08:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Tucker 2006-08-10 08:27:18 UTC
When a user attempts to update their installation by running emerge -vuND world (after, of course, emerge -pvuND world), portage should check if the lower order packages (those that will be installed first) either satisfy or break the dependencies of higher order packages.

For example: say I've got openal-20050504-r1 installed alongside freealut-1.0.1 (it probably shouldn't happen since freealut depends on !~media-libs/openal-20050504, but somehow it did)

When I run emerge -pvuND world, portage tells me that openal-0.0.8 will be installed first, and that freealut will be installed a bit later. I am notified however that freealut can't be installed because media-libs/openal-20050504-r1 is blocking it.

I *should* be able to just run emerge -vuND world, and let it intelligently realize that "well, yeah freealut doesn't like openal-20050504-r1, but it does like openal-0.0.8, and since we're installing that first, this update should work just fine."
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-08-10 08:30:14 UTC

*** This bug has been marked as a duplicate of 1343 ***