Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 143341 - dev-lang/ruby-1.8.6-r1 test failure
Summary: dev-lang/ruby-1.8.6-r1 test failure
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
: 154467 159151 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-09 06:03 UTC by Paolo Pedroni
Modified: 2008-12-15 20:36 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ruby test error log (ruby-1.8.4-r3_error_log.txt,41.80 KB, text/plain)
2006-08-09 06:03 UTC, Paolo Pedroni
Details
Solution for the WEBrick testing bug (ruby-1.8.5-p2-webrick-bind-address.patch,354 bytes, patch)
2007-05-20 06:26 UTC, David Tardon
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Pedroni 2006-08-09 06:03:01 UTC
I don't think this is a duplicate of bug 107503, because I have userpriv _and_ usersandbox in FEATURES and I still get errors.

The full error log is in the attachment. It ends with:

1322 tests, 14390 assertions, 2 failures, 51 errors
make: *** [test-all] Error 1

!!! ERROR: dev-lang/ruby-1.8.4-r3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_test
  ebuild.sh, line 987:   Called src_test
  ebuild.sh, line 618:   Called die

!!! Make check failed. See above for details.
!!! If you need support, post the topmost build error, and the call stack if relevant.

# emerge --info
Portage 2.1-r2 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.17-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Gentoo Base System version 1.12.4
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect distcc distlocks fixpackages metadata-transfer sandbox sfperms strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.ngi.it http://gentoo.intergenia.de http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://linuv.uv.es/mirror/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/vmware"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d aalib acpi alsa arts audiofile avi bash-completion berkdb bitmap-fonts bzip2 caps cdparanoia cdr cli crypt cups curl dbus dga dio dlloader dri dvd dvdr dvdread emboss emul-linux-x86 encode exif expat fbcon ffmpeg fftw flac foomaticdb fortran ftp gcj gd ggi gif glut gmp gnutls gphoto2 gpm gstreamer gtk2 hal iconv idn ieee1394 imagemagick isdnlog java javascript jbig jikes jpeg jpeg2k kde kdeenablefinal lcms libcaca lm_sensors lzw lzw-tiff mad maildir matroska memlimit mime mmap mng motif mozilla mp3 mpeg mpi ncurses nls nptl nsplugin offensive ogg openal opengl oss pam pcre pdf pdflib perl png posix ppds pppd python qt qt3 quicktime readline recode reflection samba sasl sdl session sharedmem shorten sndfile sockets sox speex spell spl ssl svg symlink sysvipc tcl tcltk tcpd theora threads tidy tiff tk truetype truetype-fonts type1-fonts unicode usb vcd vorbis wmf xine xml xml2 xorg xosd xpm xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux linguas_it userland_GNU video_cards_radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Paolo Pedroni 2006-08-09 06:03:57 UTC
Created attachment 93843 [details]
Ruby test error log
Comment 2 Caleb Tennis (RETIRED) gentoo-dev 2006-08-09 06:21:14 UTC
> test_success(SOAP::Header::TestAuthHeaderCGI):
> Errno::EADDRINUSE: Address already in use - bind(2)

Are you sure you're not running something on the port that Ruby is trying to use to do the tests?
Comment 3 Paolo Pedroni 2006-08-10 06:25:36 UTC
(In reply to comment #2)
> > test_success(SOAP::Header::TestAuthHeaderCGI):
> > Errno::EADDRINUSE: Address already in use - bind(2)
> 
> Are you sure you're not running something on the port that Ruby is trying to
> use to do the tests?
> 

I didn't have the time to check this, but I don't think this is the problem, because after re-emerging libtool (as per bug #136259) I tried re-emerging ruby and the number of errors dropped to just one. I'm reporting it below:

>>> Test phase [check]: dev-lang/ruby-1.8.4-r3
test succeeded
./miniruby ./runruby.rb --extout=.ext -- -C "./test" runner.rb --runner=console
Loaded suite .
Started
................................................................................................................................................................................................................................................................................................................................................................................./openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
../openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
../openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
../openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
./openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
./openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
../openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
../openssl/test_ssl.rb:64: warning: Insecure world writable dir /var/tmp, mode 041777
........................................................................................................................................................................................................................................................................................................................................................................................................................................./ruby/test_system.rb:12: warning: Insecure world writable dir /var/tmp, mode 041777
./ruby/test_system.rb:19: warning: Insecure world writable dir /var/tmp, mode 041777
./ruby/test_system.rb:20: warning: Insecure world writable dir /var/tmp, mode 041777
./ruby/test_system.rb:27: warning: Insecure world writable dir /var/tmp, mode 041777
./ruby/test_system.rb:37: warning: Insecure world writable dir /var/tmp, mode 041777
./ruby/test_system.rb:38: warning: Insecure world writable dir /var/tmp, mode 041777
............................................................................................................./soap/calc/test_calc_cgi.rb:31: warning: Insecure world writable dir /var/tmp, mode 041777
...........................................................................................................................................................................................................................................................................................................................E.....................................................................................................
Finished in 78.276042 seconds.

  1) Error:
test_client_server(Test_Webrick):
NoMethodError: undefined method `shutdown' for nil:NilClass
    ./xmlrpc/webrick_testing.rb:32:in `stop_server'
    /var/tmp/portage/ruby-1.8.4-r3/work/ruby-1.8.4/lib/timeout.rb:56:in `timeout'
    ./xmlrpc/webrick_testing.rb:31:in `stop_server'
    ./xmlrpc/test_webrick_server.rb:61:in `test_client_server'
    ./xmlrpc/test_webrick_server.rb:56:in `test_client_server'

1322 tests, 14500 assertions, 0 failures, 1 errors
make: *** [test-all] Error 1

!!! ERROR: dev-lang/ruby-1.8.4-r3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_test
  ebuild.sh, line 987:   Called src_test
  ebuild.sh, line 618:   Called die

!!! Make check failed. See above for details.
!!! If you need support, post the topmost build error, and the call stack if relevant.

Any idea?
Comment 4 Paolo Pedroni 2006-09-06 05:40:07 UTC
Bump.
Comment 5 Caleb Tennis (RETIRED) gentoo-dev 2006-09-06 05:42:06 UTC
I don't have a good answer for you.  It seems to pass on my system.
Comment 6 Paolo Pedroni 2006-09-27 05:02:37 UTC
Same error in ruby-1.8.5, but I also get the following:

  1) Failure:
test_endblockwarn(TestBeginEndBlock) [./ruby/test_beginendblock.rb:54]:
<"endblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n"> expected but was
<"/var/tmp/portage/ruby-1.8.5/temp/TestBeginEndBlock.22259.0:6: warning: Insecure world writable dir /var/tmp, mode 041777\nendblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n">.
Comment 7 Benno Schulenberg 2006-09-29 04:45:15 UTC
Same problem here (ruby-1.8.5):

  1) Failure:
test_endblockwarn(TestBeginEndBlock) [./ruby/test_beginendblock.rb:54]:
<"endblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n"> expected but was
<"/var/tmp/portage/ruby-1.8.5/temp/TestBeginEndBlock.30946.0:6: warning: Insecure world writable dir /var/tmp, mode 041777\nendblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n">.

  2) Error:
test_client_server(Test_Webrick):
NoMethodError: undefined method `shutdown' for nil:NilClass
    ./xmlrpc/webrick_testing.rb:32:in `stop_server'
    /var/tmp/portage/ruby-1.8.5/work/ruby-1.8.5/lib/timeout.rb:56:in `timeout'
    ./xmlrpc/webrick_testing.rb:31:in `stop_server'
    ./xmlrpc/test_webrick_server.rb:61:in `test_client_server'
    ./xmlrpc/test_webrick_server.rb:56:in `each'
    ./xmlrpc/test_webrick_server.rb:56:in `test_client_server'

1575 tests, 15650 assertions, 1 failures, 1 errors
make: *** [test-all] Error 1


The same error as in comment #4 occurred here for ruby-1.8.4-r3, but I hadn't bothered yet to report it.


emerge --info:

Gentoo Base System version 1.12.5
Portage 2.1.1 (hardened/x86/2.6, gcc-hardenednopie, glibc-2.3.6-r4, 2.6.17 i686)
=================================================================
System uname: 2.6.17 i686 AMD Athlon(tm) XP 2800+
Last Sync: Fri, 29 Sep 2006 08:50:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer notitles sandbox sfperms strict test userfetch userpriv usersandbox"
LANG="en_GB.utf8"
LINGUAS="en eo es nl"
MAKEOPTS="-j1"
PKGDIR="/usr/portage//packages/x86/"
PORTAGE_RSYNC_EXTRA_OPTS="--progress --human-readable 			  --exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage/"
PORTDIR_OVERLAY="/usr/local/portage"
USE="3dnow X aac alsa apm arts asf audiofile avi bash-completion berkdb bzip2 cdparanoia cdr crypt dio dlloader dri elibc_glibc encode exif fam fbcon ffmpeg flac gif glx gphoto2 gpm gtk gtk2 gtkhtml hardened imagemagick imap imlib input_devices_keyboard input_devices_mouse jabber jpeg jpeg2k kde kdeenablefinal kernel_linux lcms linguas_en linguas_eo linguas_es linguas_nl lm_sensors mad mbox mbrola memlimit mikmod mime mmap mmx mng mp3 mpeg musepack ncurses nls nptl nsplugin ogg opengl pdf pic png python qt3 quicktime readline recode sasl scanner sdl shorten sndfile sox speex spell sqlite sse ssl svg test theora threads tidy tiff truetype unicode usb userland_GNU userlocales vcd video_cards_fbdev video_cards_vesa video_cards_via vorbis win32codecs wmf x86 xface xine xml xorg xpm xsl xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2006-12-17 07:46:45 UTC
*** Bug 154467 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-12-26 11:53:59 UTC
*** Bug 159151 has been marked as a duplicate of this bug. ***
Comment 10 Richard Brown (RETIRED) gentoo-dev 2007-05-01 21:27:25 UTC
All tests pass, for me, with ruby-1.8.6-r1, please see the rubytests use flag as well. I'm assuming your errors were a combination of ruby using the installed ruby for tests and needing to be run as a user other than root, please reopen if you continue to experience test failures.
Comment 11 Paolo Pedroni 2007-05-02 09:14:20 UTC
(In reply to comment #10)
> All tests pass, for me, with ruby-1.8.6-r1, please see the rubytests use flag
> as well. I'm assuming your errors were a combination of ruby using the
> installed ruby for tests and needing to be run as a user other than root,
> please reopen if you continue to experience test failures.
> 

The ebuild installation seems to work fine for me. I have one test failure and one test error, though. Details follow:

Loaded suite .
Started
[snip]
Finished in 74.879646 seconds.

  1) Failure:
test_readline(TestReadline) [./readline/test_readline.rb:25]:
<"> "> expected but was
<"\e[">.

  2) Error:
test_client_server(Test_Webrick):
NoMethodError: undefined method `shutdown' for nil:NilClass
    ./xmlrpc/webrick_testing.rb:32:in `stop_server'
    /usr/lib64/ruby/1.8/timeout.rb:56:in `timeout'
    ./xmlrpc/webrick_testing.rb:31:in `stop_server'
    ./xmlrpc/test_webrick_server.rb:61:in `test_client_server'
    ./xmlrpc/test_webrick_server.rb:56:in `each'
    ./xmlrpc/test_webrick_server.rb:56:in `test_client_server'

1614 tests, 16593 assertions, 1 failures, 1 errors
Comment 12 Paolo Pedroni 2007-05-02 09:15:00 UTC
Forgot to reopen, sorry...
Comment 13 Richard Brown (RETIRED) gentoo-dev 2007-05-02 09:43:06 UTC
Thanks for retesting. Could you please repost your emerge --info for me, as it's been 9 months since you originally opened the bug. Also, could you post the output  emerge -pv ruby, because I'm lazy.
Comment 14 Paolo Pedroni 2007-05-02 16:29:24 UTC
# emerge --info
Portage 2.1.2.2 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r7 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Gentoo Base System release 1.12.9
Timestamp of tree: Wed, 02 May 2007 06:30:10 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31-r5
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.15-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="autoaddcvs ccache collision-protect distcc distlocks fixpackages metadata-transfer sandbox sfperms strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://gentoo.mirror.solnet.ch http://gentoo.intergenia.de http://pandemonium.tiscali.de/pub/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
MAKEOPTS="-j11"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/xeffects"
SYNC="rsync://pedroni03/gentoo-portage"
USE="X Xaw3d a52 aac aalib acpi alsa amd64 ao arts audiofile bash-completion berkdb bitmap-fonts bzip2 cairo caps cddb cdparanoia cdr cli cracklib crypt cups curl dbus dga dio dri dvd dvdr dvdread emboss encode exif expat fam fbcon ffmpeg fftw firefox flac foomaticdb fortran ftp gd gdbm ggi gif glut gmp gnutls gphoto2 gpm gtk gtk2 guile hal iconv idn ieee1394 imagemagick imlib isdnlog java javascript jbig jikes jpeg jpeg2k kde kdeenablefinal lcms libcaca libg++ libsamplerate lm_sensors lua mad maildir matroska memlimit midi mikmod mime mmap mng mozilla mp3 mpeg mpi mplayer ncurses nls nptl nptlonly nsplugin offensive ogg openal openexr opengl oss pam pcre pdf perl png posix ppds pppd python qt3 quicktime rdesktop readline recode reflection ruby samba sdl session sharedmem shorten sndfile sockets sox speex spell spl ssl startup-notification svg symlink sysvipc tcl tcpd test theora threads tidy tiff tk truetype truetype-fonts type1-fonts unicode usb vcd vorbis wmf wxwindows x264 xcomposite xine xml xorg xosd xpm xv xvid yahoo zlib" ALSA_CARDS="intel8x0 virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="kodak ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CTARGET, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

# emerge -pv ruby

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-lang/ruby-1.8.6-r1 [1.8.5_p2] USE="rubytests%* threads tk -debug -doc -examples -ipv6 -socks5 (-cjk%)" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Comment 15 Hans de Graaff gentoo-dev 2007-05-03 06:24:17 UTC
I still see some problems as well on amd64 with (I actually installed with rubytests):

[ebuild   R   ] dev-lang/ruby-1.8.6-r1  USE="ipv6 -debug -doc -examples -rubytests* -socks5 -threads -tk" 0 kB 

I'll try to investigate a bit more later on to see what is causing these problems. It seems at least the first failure is more common as it also happened in comment 11.

  1) Failure:
test_readline(TestReadline) [./readline/test_readline.rb:25]:
<"> "> expected but was
<"\e[">.

  2) Error:
test_naive(WSDL::TestQualified):
LoadError: no such file to load -- default.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/qualified/defaultDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/qualified/test_qualified.rb:135:in `test_naive'

  3) Error:
test_naive(WSDL::TestUnqualified):
LoadError: no such file to load -- lp.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/qualified/lpDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/qualified/test_unqualified.rb:124:in `test_naive'

  4) Error:
test_stub_echoNestedStruct(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

  5) Error:
test_stub_echoStringArray(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

  6) Error:
test_stub_echoStringArrayInline(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

  7) Error:
test_stub_echoStructArray(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

  8) Error:
test_wsdl_echoNestedStruct(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

  9) Error:
test_wsdl_echoStringArray(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

 10) Error:
test_wsdl_echoStructArray(WSDL::RPC::TestRPCLIT):
LoadError: no such file to load -- RPC-Literal-TestDefinitions.rb
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /home/graaff/playground/tests/test/wsdl/rpc/RPC-Literal-TestDefinitionsDriver.rb:1
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
    ./wsdl/rpc/test_rpc_lit.rb:131:in `setup_classdef'
    ./wsdl/rpc/test_rpc_lit.rb:99:in `setup'

1599 tests, 15762 assertions, 1 failures, 9 errors
Comment 16 Hans de Graaff gentoo-dev 2007-05-03 15:54:33 UTC
The readline test seems to fail due to terminal characters creeping in. I normally run tests in gnome-terminal in which they fail. Doing this causes the test to pass...

TERM=vt100 ruby -C . runner.rb -t TestReadline -v

Comment 17 Hans de Graaff gentoo-dev 2007-05-05 19:44:43 UTC
The TestReadline bug has been filed upstream as: http://rubyforge.org/tracker/index.php?func=detail&aid=10620&group_id=426&atid=1698
Comment 18 Carsten Lohrke (RETIRED) gentoo-dev 2007-05-14 09:50:24 UTC
dev-lang/ruby-1.8.5_p2-r1 failed with these tests:

  1) Failure:
test_readline(TestReadline) [./readline/test_readline.rb:25]:
<"> "> expected but was
<"\e[">.

  2) Failure:
test_endblockwarn(TestBeginEndBlock) [./ruby/test_beginendblock.rb:54]:
<"endblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n"> expected but was
<"/var/tmp/portage/dev-lang/ruby-1.8.5_p2-r1/temp/TestBeginEndBlock.23357.0:6: warning: Insecure world writable dir /var/tmp, mode 041777\nendblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n">.
Comment 19 Tiago Cunha (RETIRED) gentoo-dev 2007-05-18 06:17:20 UTC
Here dev-lang/ruby-1.8.5_p2-r1 failed with these:

>>> Test phase [check]: dev-lang/ruby-1.8.5_p2-r1
test succeeded
./miniruby ./runruby.rb --extout=.ext -- -C "./test" runner.rb --runner=console
Loaded suite .
Started
......................................................................................./var/tmp/portage/dev-lang/ruby-1.8.5_p2-r1/work/ruby-1.8.5-p2/lib/drb/extservm.rb:92: warning: Insecure world writable dir /var/tmp, mode 041777
.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................F......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Finished in 68.4225 seconds.

  1) Failure:
test_endblockwarn(TestBeginEndBlock) [./ruby/test_beginendblock.rb:54]:
<"endblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n"> expected but was
<"/var/tmp/portage/dev-lang/ruby-1.8.5_p2-r1/temp/TestBeginEndBlock.1193.0:6: warning: Insecure world writable dir /var/tmp, mode 041777\nendblockwarn.rb:2: warning: END in method; use at_exit\n(eval):2: warning: END in method; use at_exit\n">.

1575 tests, 15663 assertions, 1 failures, 0 errors
make: *** [test-all] Error 1

!!! ERROR: dev-lang/ruby-1.8.5_p2-r1 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_test
  ebuild.sh, line 1026:   Called qa_call 'src_test'
  environment, line 4087:   Called src_test
  ebuild.sh, line 653:   Called die

$ emerge --info --ignore-default-opts
Portage 2.1.2.2 (default-linux/amd64/2007.0/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.20-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r7 x86_64 Intel(R) Pentium(R) D CPU 3.00GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 18 May 2007 05:20:01 +0000
ccache version 2.4 [enabled]
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/init.d /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-av"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirrors1.netvisao.pt/gentoo http://darkstar.ist.utl.pt/pub/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 arts bash-completion bitmap-fonts cairo cdr cli cracklib crypt dbus dri dts dvd dvdr dvdread eds emboss encode evo fam firefox flac fortran gif gpm hal iconv ipv6 isdnlog jpeg kde kdeenablefinal kdehiddenvisibility libg++ mad midi mikmod mmx mp3 mpeg musepack musicbrainz ncurses nptl nptlonly offensive ogg opengl pam pcre pdf perl png postgres pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl svg tcpd test tiff truetype truetype-fonts type1-fonts unicode vorbis xcomposite xml xorg xscreensaver xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 20 David Tardon 2007-05-20 06:26:26 UTC
Created attachment 119759 [details, diff]
Solution for the WEBrick testing bug

I have run WEBrick::HTTPServer.new with parameters from the failing WEBrick test in irb and have got the following:

SocketError: getnameinfo: ai_family not supported
        from /usr/lib/ruby/1.8/webrick/utils.rb:63:in `getaddrinfo'
        from /usr/lib/ruby/1.8/webrick/utils.rb:63:in `create_listeners'
        from /usr/lib/ruby/1.8/webrick/server.rb:75:in `listen'
        from /usr/lib/ruby/1.8/webrick/server.rb:63:in `initialize'
        from /usr/lib/ruby/1.8/webrick/httpserver.rb:24:in `initialize'
        from (irb):7:in `new'
        from (irb):7
        from (eval):5

Now this is a problem I have encountered before, with known solution -- explicit setting of IP address to bind on. The attached patch (one line) does exactly this.
Comment 21 Richard Brown (RETIRED) gentoo-dev 2007-05-24 17:48:19 UTC
(In reply to comment #20)
>
> Now this is a problem I have encountered before, with known solution --
> explicit setting of IP address to bind on. The attached patch (one line) does
> exactly this.
> 
Thanks for commenting, I think that's actually bug #168939, which is on my list of things to fix in this ebuild once I find out whether it's appropriate to include the patch on non-linux or non-glibc systems. 
Comment 22 Paolo Pedroni 2007-08-22 17:59:36 UTC
(In reply to comment #21)
> Thanks for commenting, I think that's actually bug #168939, which is on my list
> of things to fix in this ebuild once I find out whether it's appropriate to
> include the patch on non-linux or non-glibc systems. 
> 

Any news?
Comment 23 Hans de Graaff gentoo-dev 2008-12-15 20:36:40 UTC
I'm going to close this bug CANTFIX since the versions of ruby discussed here are no longer in the tree. Feel free to open a new bug if you encounter problems with current versions of ruby, although I think it makes more sense to report testing problems for the full test suite directly to upstream.