Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 142848 - vmware-workstation-5.5.1-19175-r4 requires ~vmware-modules-1.0.0.13, but emerge world attempts to upgrade it
Summary: vmware-workstation-5.5.1-19175-r4 requires ~vmware-modules-1.0.0.13, but emer...
Status: RESOLVED DUPLICATE of bug 13632
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 137422
  Show dependency tree
 
Reported: 2006-08-04 18:52 UTC by Francois Chenier
Modified: 2006-08-06 13:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info,2.51 KB, text/plain)
2006-08-05 07:39 UTC, Francois Chenier
Details
vmware-workstation-5.5.1.19175-r4.ebuild (vmware-workstation-5.5.1.19175-r4.ebuild,1.48 KB, text/plain)
2006-08-05 07:48 UTC, Francois Chenier
Details
emerge --debug --pretend (debug,79.91 KB, text/plain)
2006-08-06 01:58 UTC, Francois Chenier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Chenier 2006-08-04 18:52:58 UTC
Little inconsistency in the ebuild ;-)

vmware-workstation-5.5.1-19175-r4 requires =~vmware-modules-1.0.0.13 and portage should not upgrade vmware-modules to version 1.0.0.15

This version of VMWare Workstation is not compatible with the latest vmware-modules package as the application returns wrong version message when user try to start/resume a virtual machine.
Comment 1 Mike Auty gentoo-dev 2006-08-05 05:46:32 UTC
Hi Francois,

You're correct, vmware-workstation-5.5.1-19175-r4 requires ~vmware-modules-1.0.0.13 and won't work with later versions, and you're also correct that portage should *not* be automatically upgrading this.

Is this bug that portage is trying to upgrade you to vmware-modules-1.0.0.15?  If that's the case please post as much more useful information as you can, such as what emerge command you're trying, any special settings in /etc/portage/package.* relating to vmware, whether you have any overlays that might be influencing vmware, things like that...
Comment 2 Francois Chenier 2006-08-05 06:35:45 UTC
I have presently installed on my laptop

   vmware-modules-1.0.0.13
   vmware-workstation-5.5.1.19175-r4

which are working fine together. If I pretend to 'emerge world' I have this ...

*****
belgix@edinburgh ~ $ emerge -p world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] app-emulation/vmware-modules-1.0.0.15 [1.0.0.13]

Unless I mask manually vmware-modules-1.0.0.15 in /etc/portage/package.mask, portage will upgrade automatically vmware-modules tomorrow morning at my next world update.
Comment 3 Mike Auty gentoo-dev 2006-08-05 06:57:52 UTC
Hmmm, that's is weird.  I'll have a chat with portage guys and see if they can help me figure it out...
Comment 4 Mike Auty gentoo-dev 2006-08-05 07:02:18 UTC
Sorry for the spam, but someone reminded me to check whether you've got --deep or --update set as defaults for your emerge command?  Please check your aliases, and also emerge --info to see if they're set anywhere.  If so, it might be related to bug #13632...
Comment 5 Francois Chenier 2006-08-05 07:39:00 UTC
Created attachment 93502 [details]
emerge --info

Nothing unusual in my emerge --info (see attachment).

I just have ACCEPT_KEYWORD="~x86" and nothing specific to overlays in my /etc/make.conf file.

(TESTED) As expected, adding =app-emulation/vmware-modules-1.0.0.15 in my package.mask file fix my problem.
Comment 6 Francois Chenier 2006-08-05 07:48:35 UTC
Created attachment 93506 [details]
vmware-workstation-5.5.1.19175-r4.ebuild

Just a question. Can you tell me why line 39 is 
 ~app-emulation/vmware-modules-1.0.0.13
and not 
 =app-emulation/vmware-modules-1.0.0.13
in this ebuild ?
Comment 7 Mike Auty gentoo-dev 2006-08-05 07:53:15 UTC
Ok, I'm gonna throw this over to the portage guys, to see if one of them can tell whether this is a known duplicate, or something else...

In answer to your question, it's ~<version> rather than =<version> so that it still accepts <version>-r1 and <version>-r2, etc.
Comment 8 Zac Medico gentoo-dev 2006-08-06 00:18:00 UTC
Please attach emerge --pretend --debug output for the command that behaves improperly.
Comment 9 Francois Chenier 2006-08-06 01:58:53 UTC
Created attachment 93576 [details]
emerge --debug --pretend

Normally,
  vmware-workstation-5.5.1.19175-r4
    should block vmware-modules-1.0.0.15 because
  vmware-workstation-5.5.1.19175-r4 requires =vmware-modules-1.0.0.13

Relevant info from the attachment ...

Parent:    None
Depstring: app-emulation/vmware-workstation
Candidates: ['app-emulation/vmware-workstation']
   ebuild: app-emulation/vmware-workstation-5.5.1.19175-r4
Exiting... None

Parent:    None
Depstring: app-emulation/vmware-modules
Candidates: ['app-emulation/vmware-modules']
   ebuild: app-emulation/vmware-modules-1.0.0.15

Parent:    ebuild / app-emulation/vmware-modules-1.0.0.15 merge
Depstring: x11-misc/shared-mime-info kernel_linux? ( virtual/linux-sources ) kernel_linux? ( virtual/modutils ) sys-app$Candidates: ['sys-apps/sed', 'sys-apps/module-init-tools', 'sys-kernel/vanilla-sources', 'x11-misc/shared-mime-info', '$   ebuild: sys-apps/sed-4.1.5
   ebuild: sys-apps/module-init-tools-3.2.2-r1
   ebuild: sys-kernel/vanilla-sources-2.6.18_rc3
   ebuild: x11-misc/shared-mime-info-0.18-r1
   ebuild: sys-apps/portage-2.1.1_pre4-r3
Exiting... ebuild / app-emulation/vmware-modules-1.0.0.15 merge
Exiting... None
Comment 10 Zac Medico gentoo-dev 2006-08-06 02:22:53 UTC
(In reply to comment #9)
> Parent:    None
> Depstring: app-emulation/vmware-modules
> Candidates: ['app-emulation/vmware-modules']
>    ebuild: app-emulation/vmware-modules-1.0.0.15

The "Parent:    None" indicates that app-emulation/vmware-modules is in your world set or it's pulled in as a PDEPEND of some package.  Most likely, you have it listed in /var/lib/portage/world.
Comment 11 Francois Chenier 2006-08-06 02:42:23 UTC
> The "Parent:    None" indicates that app-emulation/vmware-modules is in your
> world set or it's pulled in as a PDEPEND of some package.  Most likely, you
> have it listed in /var/lib/portage/world.
> 
I see nothing wrong with this. Both packages are installed in my laptop.
Comment 12 Zac Medico gentoo-dev 2006-08-06 02:50:45 UTC
(In reply to comment #11)
> I see nothing wrong with this. Both packages are installed in my laptop.

If it's in the world set, you're going to experience bug #13632.  There's no need to have it in the world set if it's a dep of another package.

*** This bug has been marked as a duplicate of 13632 ***
Comment 13 Francois Chenier 2006-08-06 04:11:06 UTC
Yes, quite similar behavior but w/o using --deep switch. BTW, I will mask vmware-modules-1.0.0.15 in my package.mask to fix this issue.
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2006-08-06 13:25:09 UTC
The "fix" is to remove vmware-modules from your world file.  It shouldn't ever be there.  I'll be sure to update anything that mentions merging the modules to use --oneshot...
Comment 15 Chris Gianelloni (RETIRED) gentoo-dev 2006-08-06 13:27:21 UTC
Nevermind... it already says to use --oneshot... =]