Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 142643 - KDE 3.5.4: Unable to toggle HAL usage
Summary: KDE 3.5.4: Unable to toggle HAL usage
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL: http://forums.gentoo.org/viewtopic-p-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-03 05:47 UTC by Sebastian
Modified: 2009-11-27 23:22 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Picture of the mishap (hal.png,40.05 KB, image/png)
2006-08-03 05:50 UTC, Sebastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2006-08-03 05:47:18 UTC
Hi all,

I emerged kde 3.5.4 (split ebuilds) yesterday and then I thought I'd give HAL a shot. So I updated my USE flags and reemerged kdebase-kioslaves. The problem is, in kcontrol center -> peripherals -> media (translated!) I can't toggle HAL usage. The box is greyed out, I can't tick it.

There's also a forum thread about this (URL above).

Thanks
Sebastian
Comment 1 Sebastian 2006-08-03 05:50:46 UTC
Created attachment 93336 [details]
Picture of the mishap
Comment 2 Sebastian 2006-08-03 05:55:20 UTC
I forgot to mention that I can actually toggle HAL usage by editing ~/.kde/share/config/mediamanagerrc manually:

[Global]
AutostartEnabled=false
CdPollingEnabled=false
HalBackendEnabled=true

emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17.7 i686)
=================================================================
System uname: 2.6.17.7 i686 AMD Sempron(tm)   2400+
Gentoo Base System version 1.6.15
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/data/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="de_DE@euro"
LC_ALL="POSIX"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/data/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.informatik.rwth-aachen.de/gentoo-portage"
USE="x86 3dnow 3dnowext X crypt cups gif gnutls hal jpeg kde kdeenablefinal logrotate mmx mmxext ncurses nls nptl png qt3 readline spell sse ssl threads udev zlib elibc_glibc input_devices_mouse input_devices_keyboard kernel_linux linguas_de lirc_devices_serial userland_GNU video_cards_radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Jesús Guerrero Botella (RETIRED) gentoo-dev 2006-08-03 09:19:45 UTC
I can confirm the same thing. It also works by manually editing the resources file, though.

Portage 2.1.1_pre4 (default-linux/amd64/2006.0, gcc-4.1.1/amd64-vanilla, glibc-2.4-r3, 2.6.17.1 x86_64)
=================================================================
System uname: 2.6.17.1 x86_64 AMD Sempron(tm) Processor 3000+
Gentoo Base System version 1.12.1
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=athlon64 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon64 -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ 		ftp://ftp.caliu.info/pub/gentoo/ "
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,-z,now"
LINGUAS="es en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 3ds X aac aalib acpi alsa apache2 asf audiofile avi bzip2 cairo cdda cddb cdparanoia cgi cle266 cli crypt cups curl custom-cflags dbus directfb divx4linux dlloader dmi dri dts dv dvb dvd dvdr dvdread eds emboss encode fam fbcon ffmpeg flac flash foomaticdb freetype ggi gif gimp glitz glut gpm gtk2 hal hfs idn imagemagick isdnlog javascript jfs jpeg kde kipi lcms lzo lzw lzw-tiff mad matroska mikmod mng modplug mozsvg mozxmlterm mp3 mpeg music mysql nls nomac nptl nptlonly nsplugin ogg openal opengl pam pcre pdflib perl pic png pppd profile python qt qt3 qt4 quicktime readline reflection reiser4 rtc sasl scanner sdl session slang slp sndfile soundtouch speex spell spl ssl svg taglib tcpd theora threads tiff truetype truetype-fonts type1-fonts unicode usb userlocales vcd vorbis wmf xanim xine xml2 xorg xpm xprint xrandr xv xvid xvmc zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_es linguas_en userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Roderick B. Greening 2006-08-04 11:35:21 UTC
I have the same issue. All was working correctly up until I emerged 3.5.4 
 
 I have the following relevant packages: 
 
 sys-fs/udev-086 
 sys-apps/hal-0.5.5.1-r3 
 sys-apps/dbus-0.62 
 sys-apps/pmount-0.9.6 
 
 and have built all KDE 3.5.4 packages with USE="hal" set in make.conf. 
 
 Is there a possible issue with KDE 3.5.4 and the revisions of packages I have? They worked fine in 3.5.3. 
 
 As well, if I insert my USB stick the icon appears just fine, but when I click to open (i.e. it attempts to mount device) I get the following popup error dialog: 
 
 "Method "Mount" with signature "ssas" on interface "org.freedesktop.Hal.Device.Volume" doesn't exist" 
 
 So, something is broken, possibly with the Hal backend in either not having a new enough Hal or in changes to it via KDE.

 Just so you know, bugs.novell.com has listed a KDE bug surrounding this as well (though I do not remember the ID). 

 Any suggestions on how to fix are welcome.
Comment 5 Roderick B. Greening 2006-08-04 11:56:29 UTC
HAL 0.5.7-r1 fixed the Mount error (for anyone else viewing this). Still have other problem.
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2006-09-12 07:51:40 UTC
Same problem like the original reporter, but on a completely fresh gentoo install

Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r7 i686)
=================================================================
System uname: 2.6.17-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 1.70GHz
Gentoo Base System version 1.12.4
Last Sync: Mon, 11 Sep 2006 06:30:07 +0000
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r3
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/"
LANG="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
USE="x86 X alsa avi berkdb bitmap-fonts cairo cdr cli crypt cups dbus dlloader dri dvd dvdr eds elibc_glibc emboss encode esd fam firefox fortran gdbm gif gpm gstreamer hal input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux ldap libg++ linguas_de mad mikmod mmx mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png ppds pppd python qt3 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_none video_cards_nvidia vorbis win32codecs xml xorg xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Timo Gurr (RETIRED) gentoo-dev 2006-09-13 06:01:11 UTC
In the meantime I got it working without changing anything in
/usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
or
~/.kde/share/config/mediamanagerrc (doesn't even exist on my system)
however in the kde controlcenter the HAL and CD polling options are still greyed out
so I don't consider this issue as solved

I unmasked the masked dbus version and (re-)installed in the following order:

dbus-core-0.92
dbus-python-0.71
dbus-0.91
dbus-glib-0.71
hal-0.5.7.1
kdebase-kioslaves

I also did another fresh Gentoo install but emerged hal dbus and pmount before emerging any kde packages. I can't tell if this makes a difference but media notification and mouting worked  straight after fireing up kde for the first time on this machine.
On this machine I used the ~testing versions without unmasking the hardmasked ones.

However the two select boxes in the controlcenter are greyed out, too.
Comment 8 Doug Goldstein gentoo-dev 2006-11-15 12:55:26 UTC
This should be fixed in KDE 3.5.5. Please test.
Comment 9 tuXXer 2006-11-20 09:17:17 UTC
Same problem here with KDE 3.5.5.

I'd upgraded to KDE 3.5.5 with use flag "hal".

Neither HAL backend nor CD polling is activatable in kcontrol.

When setting in "~/.kde/share/config/mediamanagerrc" "HalBackendEnabled" to true, I'm getting a dialog when inserting removable media. But it seems that KDE can't mount drives (e.g. sda1). I'm getting no permissions every time. My users is member of the "plugdev" group.

No quick fix works for me.

Furthermore "ivman" doesn't work with current dbus version, because dbus use expat in version 0.62 (Bug #149112, http://bugs.gentoo.org/show_bug.cgi?id=149112).

So I'm masked dbus version 0.62 and deactivate HAL backend in KDE.

Other distributions seems to have/had with the same problem:
- http://www.kubuntu.de/forum/forum.php?req=thread&id=5620
- http://forum.ubuntuusers.de/topic/52287/
- http://kanotix.com/PNphpBB2-viewtopic-t-19817-start-15.html
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=377689
- http://tsdgeos.blogspot.com/2006/10/solution-for-kubuntu-355-and-usb-not.html

But no solution fixes the problem, yet.

emerge --info
=============
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r2 i686)
=================================================================
System uname: 2.6.18-gentoo-r2 i686 Intel(R) Pentium(R) 4 CPU 2.53GHz
Gentoo Base System version 1.12.6
Last Sync: Sun, 19 Nov 2006 19:00:01 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.3.5, 1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS=""
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X X509 a52 aac aalib acl acpi activefilter aiglx alsa apache2 ares arts asf async audiofile bcmath berkdb bitmap-fonts branding bzip2 cairo calendar caps cddb cdr cli cracklib crypt css ctype cups curl curlwrappers dbus dga discard-path dlloader dmi dmx doc dri dts dv dvd dvdr dvdread eds elibc_glibc emboss encode esd examples exif expat extraengine extrafilters fam fame ffmpeg firefox flac fltk fontconfig foomaticdb fortran fpx gd gdbm ggi gif glibc-omitfp glitz gnome gnutls gphoto2 gpm graphviz gs gstreamer gtk hal iconv idn imagemagick imap imlib inifile input_devices_keyboard input_devices_mouse ipod ipv6 isdnlog java javascript jbig jikes jpeg jpeg2k kcal kde kerberos kernel_linux lcms ldap libcaca libg++ linguas_de lm_sensors lzo mad madwifi mailwrapper mbox mcve memlimit mhash mikmod ming mjpeg mmap mmx mng modplug motif mozbranding mp3 mpeg mpm-worker musepack musicbrainz mysql mysqli ncurses network nis nls nntp nowebdav nptl nptlonly nsplugin nxclient ogg openexr opengl oss pam pccts pcntl pcre pcsc pdo perl php physfs pic png posix ppds pppd pwdb python qt3 qt4 quicktime quotas rdesktop readline real reflection samba sasl scanner sdl session simplexml slang slp smux sndfile snmp sockets socks5 speex spell spl srp srvdir sse sse2 ssl subversion svg symlink syslog sysvipc tcpd tetex theora threads tidy tiff tk tokenizer toolbar tools truetype truetype-fonts type1-fonts ucs2 udev unicode usb userland_GNU vcd vda video_cards_nvidia vidix visualization vnc vorbis wddx wifi win32codecs winbind wmf xcomposite xforms xine xml xmlreader xmlrpc xmlwriter xorg xpm xprint xscreensaver xsl xv xvid xvmc yaz yv12 zip zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS

/etc/fstab
==========
...
##############################################################################
# Removable media devices
##############################################################################
/dev/hdc         /media/dvd         auto        user,exec,noauto                                              0    0
/dev/ipod        /media/ipod        vfat        user,exec,noatime,noauto,iocharset=iso8859-15,codepage=850    0    0
/dev/lyra1       /media/lyra1       vfat        user,exec,noatime,noauto,iocharset=iso8859-15,codepage=850    0    0
/dev/lyra2       /media/lyra2       vfat        user,exec,noatime,noauto,iocharset=iso8859-15,codepage=850    0    0
/dev/usbstick    /media/usbstick    vfat        user,exec,noatime,noauto,iocharset=iso8859-15,codepage=850    0    0

Versions:
=============
* sys-apps/hal
     Available versions:  0.5.5.1-r3 0.5.7-r3 ~0.5.7.1-r1 [M]0.5.7.1-r2
     Installed:           0.5.7-r3
     Homepage:            http://www.freedesktop.org/Software/hal
     Description:         Hardware Abstraction Layer
* sys-apps/dbus
     Available versions:  0.61-r1 0.62-r1 [M]1.0.1 [M]1.0.1-r1
     Installed:           0.61-r1
     Homepage:            http://dbus.freedesktop.org/
     Description:         A message bus system, a simple way for applications to talk to each other
* kde-base/kdebase-kioslaves
     Available versions:  3.5.2:3.5 3.5.5-r1:3.5
     Installed:           3.5.5-r1
     Homepage:            http://www.kde.org/
     Description:         kioslave: the kde VFS framework - kioslave plugins present a filesystem-like view of arbitrary data
Comment 10 tuXXer 2006-11-29 10:40:28 UTC
Well, I'd solved my auto mount problem, but the options in kcontrol I couldn't enable/disable.

My problem was that neither adding or removing "managed" option in /etc/fstab leads to auto mount removeable media with KDE HAL backend.

Only removing all lines of removeable media works.

Setting "HalBackendEnabled=true". Now, all of my removeable media getting auto mounted.