Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 141436 - Gnome 2.14 - gdm - every other login fails
Summary: Gnome 2.14 - gdm - every other login fails
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-22 14:33 UTC by Mark Knecht
Modified: 2006-11-29 17:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Knecht 2006-07-22 14:33:02 UTC
Since updating to Gnome-2.14 every other login fails with this message:

GDM could not write to your authorization file. This could mean that
you are out of diskspace or that your account could not be opened for
writing. In any case you cannot login. Please contact your
administrator.

I hit enter, get the gdm login page again, and then am able to login just fine. Next time I log out the same thing happens again. It happens on all accounts since the update.

dragonfly ~ # eix -I gdm
* gnome-base/gdm
     Available versions:  2.2.5.4-r5 2.8.0.7 2.8.0.7-r1 2.8.0.8 ~2.14.8 ~2.14.9 2.14.9-r1
     Installed:           2.14.9-r1
     Homepage:            http://www.gnome.org/projects/gdm/
     Description:         GNOME Display Manager


Found 1 matches
dragonfly ~ #


dragonfly ~ # emerge -pv gdm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gdm-2.14.9-r1  USE="ipv6 pam tcpd -accessibility -debug -xinerama" 0 kB

Total size of downloads: 0 kB
dragonfly ~ #



dragonfly ~ # emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r2 i686)
=================================================================
System uname: 2.6.17-gentoo-r2 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://gentoo.seren.com/gentoo ftp://gentoo.mirrors.tds.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/home/portage_temp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/root/EBUILDS"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 audiofile avi berkdb bitmap-fonts caps cdr cli crypt cups dlloader dri dvd dvdr dvdread eds emboss encode firebird flac fluidsynth foomaticdb fortran gdbm gif gimp gimpprint gnome gpm gstreamer gtk gtk2 i8x0 imlib ipv6 isdnlog jack jack-tmpfs jpeg kde ladcca ladspa libg++ libwww mad mikmod mjpeg mmx motif mp3 mpeg mysql mythtv ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png ppds pppd python qt qt3 qt4 quicktime readline reflection sdl session sndfile spell spl sse sse2 ssl tcltk tcpd threads transcodei truetype truetype-fonts type1-fonts udev usb userlocales v4l v4l2 vorbis xml xmms xorg xscreensaver xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_i810 video_cards_mesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
dragonfly ~ #
Comment 1 Mark Knecht 2006-07-24 09:49:16 UTC
Looking at /var/log/messages I'm seeing these two messages every time login fails:

Jul 24 09:40:21 dragonfly gdm(pam_unix)[16755]: session opened for user mark by (uid=0)
Jul 24 09:40:21 dragonfly gdm[16755]: gdm_auth_user_add: Could not open cookie file /home/mark/.Xauthority
Jul 24 09:40:21 dragonfly gdm[16755]: gdm_auth_user_add: Could not open cookie file .gdmRtOJDj
Jul 24 09:40:27 dragonfly gdm(pam_unix)[16755]: session closed for user mark


I tried erasing .Xauthority. It is recreated wach time I try to log in. 


When I log in the second time, which works as expected, I get these messages:
Jul 24 09:42:19 dragonfly gdm(pam_unix)[16945]: session opened for user mark by (uid=0)
Jul 24 09:42:19 dragonfly gdm[16945]: gdm_auth_user_add: Could not open cookie file /home/mark/.Xauthority
Jul 24 09:42:19 dragonfly gdm[16945]: gdm_auth_user_add: /tmp is not owned by uid 500.
Jul 24 09:42:19 dragonfly (mark-17011): starting (version 2.14.0), pid 17011 user 'mark'
Jul 24 09:42:19 dragonfly (mark-17011): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jul 24 09:42:19 dragonfly (mark-17011): Resolved address "xml:readwrite:/home/mark/.gconf" to a writable configuration source at position 1
Jul 24 09:42:19 dragonfly (mark-17011): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jul 24 09:42:20 dragonfly (mark-17011): Resolved address "xml:readwrite:/home/mark/.gconf" to a writable configuration source at position 0
Jul 24 09:43:38 dragonfly su[17086]: Successful su for root by mark
Jul 24 09:43:38 dragonfly su[17086]: + pts/0 mark:root
Jul 24 09:43:38 dragonfly su(pam_unix)[17086]: session opened for user root by (uid=500)


Keying on the '/tmp is not owned by uid 500' my login account uid is 500:

dragonfly ~ # cat /etc/passwd | grep mark
mark:x:500:100:Mark:/home/mark:/bin/bash
dragonfly ~ #


I don't see the problem but clearly gdm is upset about something.
Comment 2 Mark Knecht 2006-07-24 09:51:02 UTC
NOTE: I have tried loggin out, removing everything from /tmp and logging back in. No difference in the problem.
Comment 3 Mark Knecht 2006-07-25 11:04:13 UTC
I went back to the previous version (2.8.0.8) and now things work correctly. Possibly 2.14.9-r1 should be masked?

I could not try and of the intermediate versions as it seems that someone has removed them from portage very quickly:

mark@dragonfly ~ $ eix -I gdm
* gnome-base/gdm
     Available versions:  2.2.5.4-r5 2.8.0.7 2.8.0.7-r1 2.8.0.8 [M]2.14.9-r1
     Installed:           2.8.0.8
     Homepage:            http://www.gnome.org/projects/gdm/
     Description:         GNOME Display Manager


Found 1 matches
mark@dragonfly ~ $


Comment 4 Gilles Dartiguelongue gentoo-dev 2006-07-26 21:46:03 UTC
there were lots of problems with previous versions. You can search bugzilla, there was some CVE issues as well, that's why they got removed.

About gdm, I'm using 2.14.9-r1 version on an unstable box. Didn't have your problem. There are just 2 things that come to my mind about this :
 - maybe your config file for 2.14.9 are screwd up
 - my users have a uid > 1000, maybe you could have a look at this
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2006-11-06 13:29:15 UTC
A couple of questions:

Is /tmp writable for you?  Do you set TMPDIR in your .profile/.bashrc?
Does it still happen with 2.16.x?
How is /var/log/messages different when you succeed in logging in?
Comment 6 Saleem Abdulrasool (RETIRED) gentoo-dev 2006-11-29 15:51:45 UTC
No response from user, marking as NEEDINFO.
Comment 7 Mark Knecht 2006-11-29 17:01:22 UTC
As background, we had this problem whn I upgraded gdm back in July. That's when I posted this bug. My work around at the time, since it's my wife's machine and I didn't want her to have to deal with this every day was to downgrade gdm to 2.8.0.8 which worked.

Just last week during the holiday I did the gcc-4.1.1 upgrade on her machine as well as my son's machine. gdm was upgraded on both machines to version 2.14.9-r1 on both machines. The problem has returned on her machine. My son's machine hasn't seen the problem, nor have any of my machines. On my wife's machine it happens for all users.

As for /tmp, it looks writable to me, but in the following listing it the 'tmp' on the right has a green background. This is some new Gentoo thing that I haven't located the answer for so I don't know what to make of that. None the less it's the same green background on all our Gentoo machines so it doesn't seem different.

dragonfly ~ # ls -al /
total 100
drwxr-xr-x  21 root   root      4096 Sep 22 05:18 .
drwxr-xr-x  21 root   root      4096 Sep 22 05:18 ..
drwxrwxr-x 343 evelyn musiclib 12288 Jun 28 13:42 Musiclib
drwxr-xr-x   2 root   root      4096 Nov 24 10:24 bin
drwxr-xr-x   2 root   root      4096 Apr 17  2005 boot
drwxr-xr-x  18 root   root     14040 Nov 29 16:24 dev
drwxr-xr-x  80 root   root      4096 Nov 29 12:04 etc
drwxr-xr-x  10 root   root      4096 Jun  4 10:27 home
drwxr-xr-x   8 root   root      4096 Nov 25 07:39 lib
drwx------   2 root   root     16384 Apr 15  2005 lost+found
drwxr-xr-x   7 root   root      4096 Nov  5  2005 mnt
drwxr-xr-x  10 root   root      4096 Nov 24 05:09 opt
dr-xr-xr-x 105 root   root         0 Nov 24 15:01 proc
drwx------  20 root   root      4096 Nov 25 12:48 root
drwxr-xr-x   2 root   root      4096 Nov 25 07:39 sbin
drwxr-xr-x   2 root   root      4096 Nov 24 03:07 service
drwxr-xr-x  11 root   root         0 Nov 24 15:01 sys
drwxrwxrwt  42 root   root      8192 Nov 29 16:25 tmp
drwxr-xr-x  15 root   root      4096 Nov 24 07:41 usr
drwxr-xr-x  14 root   root      4096 Nov 23 22:57 var
drwxrwxrwx   9 root   root      8192 Nov 29 15:58 video
dragonfly ~ # df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda8              9621848   3926604   5206468  43% /
udev                    249852       380    249472   1% /dev
/dev/hda2             50394996  47714768    120272 100% /Musiclib
/dev/hda3             30233928  12082116  16616000  43% /home
/dev/hda6              3020140   2102200    764524  74% /usr/src
/dev/hda9              9621848   4023580   5109492  45% /usr/portage
/dev/hda10             2893628    514364   2232272  19% /var
none                    249852         0    249852   0% /dev/shm
myth14:/video        225373664  75029472 138895872  36% /video
dragonfly ~ #
   

I have not tested gdm-2.16.X because they are masked. However, since the problem is only on this one machine it seems to be a subtle problem and most likely is machine config dependant I would guess so I hope someone can guide me toward what might be causing it.

dragonfly ~ # emerge -pv gdm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gdm-2.14.9-r1  USE="ipv6 pam tcpd -accessibility -debug (-selinux) -xinerama" 0 kB

Total size of downloads: 0 kB
dragonfly ~ #


Here is the /var/log/messages file from a failed attempt at logging in:

Nov 29 16:55:32 dragonfly (evelyn-32604): Exiting
Nov 29 16:55:33 dragonfly gdm(pam_unix)[32544]: session closed for user evelyn
Nov 29 16:55:48 dragonfly gdm(pam_unix)[32544]: session opened for user evelyn by (uid=0)
Nov 29 16:55:48 dragonfly gdm[32544]: gdm_auth_user_add: Could not open cookie file /home/evelyn/.Xauthority
Nov 29 16:55:48 dragonfly gdm[32544]: gdm_auth_user_add: Could not open cookie file .gdmsTjZff
Nov 29 16:55:55 dragonfly gdm(pam_unix)[32544]: session closed for user evelyn



and here is /var/log/messages when the login works correctly:
Nov 29 16:57:33 dragonfly gdm(pam_unix)[522]: session opened for user evelyn by (uid=0)
Nov 29 16:57:33 dragonfly gdm[522]: gdm_auth_user_add: Could not open cookie file /home/evelyn/.Xauthority
Nov 29 16:57:33 dragonfly gdm[522]: gdm_auth_user_add: /tmp is not owned by uid 501.
Nov 29 16:57:34 dragonfly (evelyn-582): starting (version 2.14.0), pid 582 user 'evelyn'
Nov 29 16:57:34 dragonfly (evelyn-582): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Nov 29 16:57:34 dragonfly (evelyn-582): Resolved address "xml:readwrite:/home/evelyn/.gconf" to a writable configuration source at position 1
Nov 29 16:57:34 dragonfly (evelyn-582): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Nov 29 16:57:36 dragonfly (evelyn-582): Resolved address "xml:readwrite:/home/evelyn/.gconf" to a writable configuration source at position 0


From my group file here are the three users:

mark:x:500:
evelyn:x:501:
matt:x:502:


Let me know what other info you might need and I'm happy to get it.