Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 140756 - netscape-flash fails to render any text/fonts
Summary: netscape-flash fails to render any text/fonts
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
: 140761 (view as bug list)
Depends on:
Reported: 2006-07-17 03:32 UTC by Ed Catmur
Modified: 2006-10-19 16:24 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Attachments with Firefox on Gentoo Linux with 7.1 (,446.51 KB, image/png)
2006-07-31 23:01 UTC, Sebastian Bergmann (RETIRED)
Details with Firefox on Windows (,453.00 KB, image/png)
2006-07-31 23:02 UTC, Sebastian Bergmann (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Catmur 2006-07-17 03:32:29 UTC
The Macromedia binary flash plugin fails to render any text.

As stated at, this is because it uses its own font library, looking for /usr/X11R6/lib/X11/fs/config.

Two options:
1. Install a compatibility symlink /usr/X11R6/lib/X11/fs -> /etc/X11/fs (should xorg-x11 do this?)
2. Patch the binary (ick)!
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 03:47:16 UTC
Uhm... Using 7.0.63 and it renders fonts/text just fine here...
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 06:26:58 UTC
*** Bug 140761 has been marked as a duplicate of this bug. ***
Comment 3 Frédéric COIFFIER 2006-07-17 06:57:24 UTC
I correct my problem (with a workaround) :

- As said above, a symlink is needed /usr/X11R6/lib/X11/fs -> /etc/X11/fs because flash uses /etc/X11/fs/config file to find font
- The content of /etc/X11/fs/config must be synchronized with the content of FontPaths in /etc/X11/xorg.conf ! Only the catalogue entry is required by flash and catalogue must be on one line.

Example :
catalogue = /usr/share/fonts/misc/,/usr/share/fonts/75dpi/, /usr/share/fonts/100dpi/,/usr/share/fonts/truetype/, /usr/share/fonts/Type1/, /usr/share/fonts/TTF/
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-07-17 07:07:56 UTC
(In reply to comment #3)
> I correct my problem (with a workaround) :
> - As said above, a symlink is needed /usr/X11R6/lib/X11/fs -> /etc/X11/fs
> because flash uses /etc/X11/fs/config file to find font

Well, I don't have any symlink and don't have /etc/X11/fs either... 
Comment 5 Ed Catmur 2006-07-17 07:48:46 UTC
Well, the symlink is needed here to get it to display text. Note: I'm using xfs, though other people not using xfs appear to indicate that they need the symlink.
Comment 6 Frédéric COIFFIER 2006-07-17 08:02:45 UTC
Right, I'm not using xfs
Comment 7 Sebastian Bergmann (RETIRED) gentoo-dev 2006-07-27 16:54:05 UTC
I have the same (or a similar?) problem with netscape-flash not rendering fonts. I am not using xfs and do not have /etc/X11/fs.

I am using X.Org 7.1.
Comment 8 Sebastian Bergmann (RETIRED) gentoo-dev 2006-07-31 23:01:13 UTC
Created attachment 93181 [details] with Firefox on Gentoo Linux with 7.1
Comment 9 Sebastian Bergmann (RETIRED) gentoo-dev 2006-07-31 23:02:03 UTC
Created attachment 93182 [details] with Firefox on Windows
Comment 10 Frédéric COIFFIER 2006-08-01 00:28:42 UTC
Exactly my problem.
Have you tried my workaround above ?
Comment 11 Sebastian Bergmann (RETIRED) gentoo-dev 2006-08-02 00:31:51 UTC
I created the following directories/files/symlink:

wopr-mobile ~ # ll /usr/X11R6/lib/X11/fs
lrwxrwxrwx 1 root root 11 Aug  1 10:21 /usr/X11R6/lib/X11/fs -> /etc/X11/fs
wopr-mobile ~ # ll /etc/X11/fs
total 4
-rw-r--r-- 1 root root 125 Aug  1 10:20 config
wopr-mobile ~ # cat /etc/X11/fs/config
catalogue = /usr/share/fonts/misc,/usr/share/fonts/75dpi,/usr/share/fonts/100dpi,/usr/share/fonts/TTF,/usr/share/fonts/Type1

But it still does not work.
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2006-08-10 08:10:06 UTC
Could you post all the FontPath lines from /etc/X11/xorg.conf please?
Comment 13 Donnie Berkholz (RETIRED) gentoo-dev 2006-08-10 08:13:20 UTC
FYI, is a quite detailed bug on the topic. Note the possible hack fix at and workaround at .
Comment 14 Sebastian Bergmann (RETIRED) gentoo-dev 2006-08-10 08:15:27 UTC
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi"
FontPath     "/usr/share/fonts/100dpi"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/Type1"
Comment 15 Sebastian Bergmann (RETIRED) gentoo-dev 2006-08-12 08:41:23 UTC
It suddenly works for me, although I do not know why.

AFAIK, I did two things that could have caused this to work again:

  1. Changing my font paths to

       FontPath     "/usr/share/fonts/misc:unscaled"
       FontPath     "/usr/share/fonts/75dpi:unscaled"
       FontPath     "/usr/share/fonts/100dpi:unscaled"
       FontPath     "/usr/share/fonts/Type1"
       FontPath     "/usr/share/fonts/TTF"
       FontPath     "/usr/share/fonts/default/ghostscript"
       FontPath     "/usr/share/fonts/corefonts"
       FontPath     "/usr/share/fonts/ttf-bitstream-vera"

  2. Or upgrading to GNOME 2.15 and then downgrading again to GNOME 2.14.
Comment 16 Andrew Evans 2006-08-17 10:01:38 UTC
I started having this problem after migrating to modular X11.  The fix in my case was different than those proposed previously.

Something created a symlink (unowned by anything in /var/db/pkg/*/*/CONTENTS) from  /usr/X11R6/lib/X11/fs to /etc/X11/fs.  I had /etc/X11/fs/config, but it contained old legacy monolithic X11 font paths (e.g. /usr/X11R6/lib/X11/fonts/75dpi).

I don't even run a font server, so I mv'ed /etc/X11/fs/config to config.disabled.  I went to, which uses Flash, and the text was back!


1. There seems to be something in the modular X11 migration that moves /usr/X11R6/lib/X11/fs/config to /etc/X11/fs/config, but doesn't fix the font paths inside the file.  That seems like a bug to me.

2. I don't think I should have an /etc/X11/fs/config file if I don't have xfs installed.  I suppose I wouldn't if I had never had monolithic X11 installed before.  This seems like an undesirable side effect of CONFIG_PROTECT.
Comment 17 Krzysztof Pawlik (RETIRED) gentoo-dev 2006-10-19 02:22:12 UTC
Latest version ( solved this bug for me.

Olivier: you've done last version bump: do you want to take this package?
Comment 18 Olivier Crete (RETIRED) gentoo-dev 2006-10-19 16:24:36 UTC
Flash 9 uses fontconfig
Flash 7 reads the X file manually, so if you want it, use the fsconfig file.. There is nothing more we can do..
So I'm closing as cantfix.. because we can't fix flash7.. and you have to wait for  stable flash9 to come out of Adobe