Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 140322 - qemu-0.8.1-r1 doesn't emerge
Summary: qemu-0.8.1-r1 doesn't emerge
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-14 02:22 UTC by Branko Badrljica
Modified: 2006-09-02 00:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Branko Badrljica 2006-07-14 02:22:17 UTC
while emergeing it, I get error ( tail'ed few last lines):

--------------------------------------
gcc -O2 -Wall -O2 -g -fno-strict-aliasing -I. -I.. -I/var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/target-sparc -I/var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/fpu -I/var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/slirp -c -o translate.o /var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/target-sparc/translate.c
In file included from /var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/translate-op.c:36:
./op.h: In function `dyngen_code':
./op.h:3595: error: syntax error before '.' token
./op.h:3597: error: syntax error before '.' token
make[1]: *** [translate-op.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/qemu-softmmu-0.8.1-r1/work/qemu-0.8.1/sparc-softmmu'
make: *** [all] Error 1

!!! ERROR: app-emulation/qemu-softmmu-0.8.1-r1 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  qemu-softmmu-0.8.1-r1.ebuild, line 89:   Called die
-------------------------------------

I have tried it with new gcc-4.1.1 and more stable gcc-3.4.6 with the same results...


Here is the result of "emerge --info" :


--------------------------------------------------------
Portage 2.1-r1 (default-linux/amd64/2006.0, gcc-3.4.6/amd64-vanilla, glibc-2.3.6-r4, 2.6.16-gentoo-r10 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r10 x86_64 AMD Opteron(tm) Processor 240
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.15.92.0.2-r10, 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg candy distlocks fixpackages keepwork metadata-transfer nostrip sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.ecc.u-tokyo.ac.jp/GENTOO http://mirror.gentoo.gr.jp http://ftp.gentoo.or.kr/ http://gentoo.kems.net ftp://gentoo.kems.net/mirrors/gentoo"
LANG="sl_SI.utf8"
LC_ALL="sl_SI.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages/opteron_glibc_235"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 7zip X a52 aac acl acpi activefilter alsa aotuv apache2 asf avi bash-completion berkdb bitmap-fonts browserplugin bzip2 c++ cairo caps cdda cddb cdr cli crypt cscope cups curl daap dar64 dbus dga dhcp divx4linux djvu dlloader doc dpms dri ds dts dv dvb dvd dvdr dvdread dvi eds effects elf emacs emboss encode epiphany esd evo examples exif fame fbcon ffmpeg firefox flac fltx font-server foomaticdb fortran fpx freetype ftp ggi gif gimp gimpprint glut gnome gphoto2 gpm grammar graphviz gs gstreamer gtk gtk2 gtkhtml hal httpd ieee1394 imagemagick imlib inetd inkjar iproute2 ipv6 isdnlog jack jack-tmpfs java javascript jbig jpeg jpeg2k kerberos kqemu lcms ldap libgda libsamplerate lirc live lm_sensors lzo lzw lzw-tiff mad math matroska mjpeg mmap mng mod modplug mozilla mozsvg mp3 mp4 mpeg mpqc multislot mysql ncurses network nls nntp nptl nsplugin nvidia ogg oggvorbis openal opengl oss pam pcre pdf pdflib perl plotutils png portaudio postgresql pppd prelude profile python quicktime readline reflection rle samba scanner sdk sdl sensord session shared sharedmem smartcard smp sndfile sockets spell spl sse-filters ssl stream svg sysfs t1lib tcpd theora thesaurus threads tiff truetype truetype-fonts type1-fonts unicode usb v4l vcd vdr vhosts vorbis wmf wordperfect x264 xbase xine xinerama xinetd xml xml2 xmms xorg xosd xpm xprint xv xvid xvmc yv12 zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nv video_cards_vga video_cards_vesa video_cards_v4l video_cards_fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS

-----------------------------------------------------
Comment 1 Branko Badrljica 2006-07-14 02:24:30 UTC
Oh, one more thing. qemu-0.8.1 works fine (last time I checked)  and also reemerges without a problem...
Comment 2 Luca Barbato gentoo-dev 2006-07-14 03:59:17 UTC
use a default gcc and not vanilla

the patches in -r1 are supposed to work just on x86

I'll borrow a shell on an amd64 to reproduce the issue
Comment 3 Luca Barbato gentoo-dev 2006-07-14 05:11:14 UTC
with gcc-3.4.6-r1 builds properly, with gcc-4.1.1 doesn't as it is supposed to
Comment 4 Stefan Schweizer (RETIRED) gentoo-dev 2006-09-01 04:58:57 UTC
bugs should be closed when there is no one fixes them
Comment 5 Branko Badrljica 2006-09-02 00:19:06 UTC
O.K. Qemu 0.8.2 seems to be working and original bug seems to be irrelevant.

I'm closing this bug.