Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 140100 - cmucl-19a-r1 fails to build (using gcc-3.4.6-r1 and +hardened)
Summary: cmucl-19a-r1 fails to build (using gcc-3.4.6-r1 and +hardened)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Common Lisp Bugs
: 93460 (view as bug list)
Depends on:
Reported: 2006-07-12 05:03 UTC by Denilson Sá Maia
Modified: 2007-06-20 18:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

cmucl-19a-r1 emerge log (3216-cmucl-19a-r1.log,78.24 KB, text/plain)
2006-07-12 05:04 UTC, Denilson Sá Maia

Note You need to log in before you can comment on or make changes to this bug.
Description Denilson Sá Maia 2006-07-12 05:03:38 UTC
cmucl-19a-r1 (latest stable) fails to build. Using latest stable system. The entire build log (with all error messages) is attached at next comment.

$ emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r7 i686)
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv usersandbox"
LINGUAS="en pt_BR pt"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 X acpi apache2 avi berkdb bitmap-fonts bzip2 cli crypt cscope cups dlloader dri eds emboss encode exif foomaticdb fortran gd gdbm gif gmp gpm gstreamer gtk gtk2 gzip hardened imagemagick imlib innodb isdnlog java javascript jpeg kdeenablefinal libg++ libwww mad mikmod mmx motif mp3 mpeg mysql ncurses nis nls nptl nptlonly nsplugin ogg pam pcre pdflib perl php png postgres pppd python qt qt3 qt4 readline reflection samba session spell spl sse sse2 ssl tcltk tcpd truetype truetype-fonts type1-fonts udev unicode usb vorbis xml xorg zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_pt_BR linguas_pt userland_GNU video_cards_dummy video_cards_fbdev video_cards_radeon video_cards_vesa video_cards_vga"
Comment 1 Denilson Sá Maia 2006-07-12 05:04:26 UTC
Created attachment 91559 [details]
cmucl-19a-r1 emerge log

cmucl-19a-r1 emerge log
Comment 2 Denilson Sá Maia 2006-07-12 05:06:12 UTC
I forgot to say... this package is important because it is a dependency of maxima.
Comment 3 Denilson Sá Maia 2006-07-12 06:48:05 UTC
Although not 100% related to this bug, both clisp and gcl fail to compile.

cmucl-19c took more than one hour (on a Pentium 4 with some GB of ram) and did not finish compilation, so I aborted it. Maybe I should have waited more.
Comment 4 R Stephan 2006-07-21 03:55:40 UTC
the same version (19a-r1) bails out in compilation of interrupt.c when using gcc-4.1.1. now trying 19c
Comment 5 R Stephan 2006-07-21 04:10:46 UTC
OK I confirm that cmucl-19c compiles and installs fine with gcc-4.1.1 so this bug report will be obsolete when 19c is out of testing
Comment 6 Denilson Sá Maia 2006-07-21 04:16:25 UTC
(In reply to comment #5)
> OK I confirm that cmucl-19c compiles and installs fine with gcc-4.1.1 so this
> bug report will be obsolete when 19c is out of testing

both cmucl-19c and gcc-4.1

Well, the fact is I tried to install maxima on a "stable" system with above emerge --info, and I couldn't. I tried all three lisps that maxima can depend on, but no one worked. (hum... this is a bit off-topic)
Comment 7 R Stephan 2006-07-21 07:07:16 UTC
fwiw, maxima DID install and run with cmucl-19c/gcc-4.1.1 here.

I agree that "stable" may be a misnomer at some times, esp. when bug fixes remain in testing for too long. my list of testing packages isn't too long, the essential entries being gcc, gentoolkit, autoconf, autoconf-wrapper, gmp, mpfr, imagemagick, libpng, libpaper, cups, cmucl.
Comment 8 Matthew Kennedy (RETIRED) gentoo-dev 2006-09-02 00:52:04 UTC
So cmucl-19c works for everyone?  If so, then we'll make a stablization request to the arch testers.
Comment 9 Denilson Sá Maia 2006-09-02 10:17:17 UTC
As I said in comment #2, I could not install it on that "stable hardened" system. It simply never stopped compiling, even after hours.

I *needed* to install maxima on that system, so I unpacked a pre-built RPM and used it... :-\
Comment 10 Matthew Kennedy (RETIRED) gentoo-dev 2006-09-02 11:40:50 UTC
I think the source of your problems is probably your "hardened" system, especially since you tried 3 lisps and none of them worked.  Hardened "features" tend to assume all the world is C and do not play well with sophisticated, image-based, garbage collected programming systems like Lisp.

As for the other problem where cmucl-19a in our stable keywords bails on GCC 4, we'll have to resolve that by stablizing cmucl-19c.  We'll do that after I check for other bugs on CMUCL.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-09-03 02:39:55 UTC
*** Bug 93460 has been marked as a duplicate of this bug. ***
Comment 12 Marijn Schouten (RETIRED) gentoo-dev 2007-06-20 16:57:07 UTC
Does the problem persist with 19d_p2?
Comment 13 Denilson Sá Maia 2007-06-20 18:06:24 UTC
Sorry, but I can't answer this. I don't even have access to that machine anymore. Maybe someone else could test it, because I can't.