Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 139796 - openoffice-2.0.3 fails to build - g++ internal error building SllideSorterView.obj
Summary: openoffice-2.0.3 fails to build - g++ internal error building SllideSorterVie...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-07-09 10:33 UTC by Peter Fox
Modified: 2006-07-15 00:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fox 2006-07-09 10:33:18 UTC
I get this (after a long time of building):

Making: ../../../../
g++ -Wreturn-type -fmessage-length=0 -c -I.  -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solver/680/ -I../inc -I../../inc -I../../../../inc -I../../../../unx/inc -I../../../../ -I. -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solver/680/ -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solver/680/ -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solver/680/ -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solenv/unxlngi6/inc -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solenv/inc -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/res -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solver/680/ -I/var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/solenv/inc/Xp31 -I/opt/blackdown-jdk- -I/opt/blackdown-jdk- -I/opt/blackdown-jdk- -I/usr/include     -I. -I../../../../res -I. -Os -fno-strict-aliasing -Wuninitialized   -fvisibility=hidden -pipe -march=athlon-xp -mmmx -msse -mfpmath=sse -m3dnow -msse2 -O2 -pipe -fomit-frame-pointer -Wno-ctor-dtor-privacy -fvisibility-inlines-hidden -fexceptions -fno-enforce-eh-specs   -fpic -DLINUX -DUNX -DVCL -DGCC -DC341 -DINTEL -DCVER=C341 -D_USE_NAMESPACE -DNPTL -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -DHAVE_GCC_VISIBILITY_FEATURE -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DGXX_INCLUDE_PATH=/usr/lib/gcc/i686-pc-linux-gnu/3.4.6/include/g++-v3 -DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI -DSOLAR_JAVA -DOOC680=OOC680   -DSD_DLLIMPLEMENTATION -DSHAREDLIB -D_DLL_  -DMULTITHREAD  -o ../../../../ /var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/sd/source/ui/slidesorter/view/SlideSorterView.cxx
g++: Internal error: Killed (program cc1plus)
Please submit a full bug report.
See <URL:> for instructions.
dmake:  Error code 1, while making '../../../../'
'---* *---'

ERROR: Error 65280 occurred while making /var/tmp/portage/openoffice-2.0.3/work/ooo-build-ooc680-m7/build/ooc680-m7/sd/source/ui/slidesorter/view
make: *** [stamp/build] Error 1

My installation is mixed stable/unstable, but openoffice 2.0.2 built ok when it came out a while ago. This is the first time I've tried to build openoffice with LINGUAS set, but I don't see why that should be relevant.

emerge --info:
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.4-r3, 2.6.17-gentoo i686)
System uname: 2.6.17-gentoo i686 AMD Sempron(tm) Processor 2800+
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.4.3-r4, 1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon-xp -mmmx -msse -mfpmath=sse -m3dnow -msse2 -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon-xp -mmmx -msse -mfpmath=sse -m3dnow -msse2 -O3 -pipe -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
LINGUAS="en en_GB fr es de"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dnow 3dnowext X aalib acpi alsa apache2 audiofile avi berkdb bitmap-fonts bzip2 cairo cdr cli crypt cups curl dlloader doc dri dvdr eds emboss encode esd exif ffmpeg firefox flac foomaticdb fortran gd gdbm gif gimp gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal imagemagick imlib isdnlog jack java jbig jpeg jpeg2k lcms libg++ libwww lynxkeymap mad mikmod mmx mng mono motif mozilla mp3 mpeg ncurses nls nptl nptlonly ogg oggvorbis opengl pam pcre pdf pdflib perl png pppd python qemu-fast qt qt3 qt4 quicktime readline reflection samba sdl session softmmu speex spell spl sqlite sse sse2 ssl svg tcpd tetex tiff truetype truetype-fonts type1-fonts udev usb vorbis win32codecs wmf xml xml2 xmms xorg xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_en_GB linguas_fr linguas_es linguas_de userland_GNU video_cards_nvidia video_cards_vesa"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-07-09 11:12:28 UTC
Uhm, can you reproduce it, i.e. does it fail again at exactly the same place? Looks more like you are out of RAM/disk space.
Comment 2 Peter Fox 2006-07-09 12:34:58 UTC
Yes. It has failed at the same place twice now. I'm building it again with empty LINGUAS to see if that makes a difference, but it'll take a day to find out...
Comment 3 Peter Fox 2006-07-09 22:36:04 UTC
It went wrong again with LINGUAS unset in make.conf, but it looks like it may have run out of memory as you suggest. I had another program monitoring memory usage while the build was running, it would do a df and free every second if it saw a cc1plus process running, the last one was (some mounts removed):

date: Mon Jul 10 03:46:23 BST 2006
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1               972404    679720    243288  74% /
/dev/hda2               972436     18692    904348   3% /tmp
/dev/hda5              1929068    731852   1099224  40% /var
/dev/hda7            134226824 110718304  16690136  87% /home
/dev/hdb1             19236308   4277952  13981204  24% /var/tmp/portage
             total       used       free     shared    buffers     cached
Mem:        905480     897700       7780          0        216       9208
-/+ buffers/cache:     888276      17204
Swap:            0          0          0

I shall add more swap and try again.
Comment 4 Peter Fox 2006-07-15 00:02:08 UTC
I added some swap (turned out I didn't have any), and then it crashed the PC* when building in a gnome-terminal. Did this twice. The third time I tried building ssh'd from another machine and it built fine.

* X Display garbled, no response via keyboard (can't change to text console) or network.

896M physical memory and no swap is not sufficient to build openoffice-2.0.3.
Don't build openoffice in a gnome-termnal.